Zabbix em Tcloud não roda.

1. Zabbix em Tcloud não roda.

Leandro Vasconcelos Santos
leandrobfr25

(usa Ubuntu)

Enviado em 12/07/2021 - 11:37h

Boa tarde Sr(a)s.

Tenho um ambiente tcloud, onde preciso criar um zabbix para monitorar o pool de máquinas pertencente à rede local. (tcloud)
Junto à Totvs, pedi as liberações de portas no servidor (CentOs7) para que pudesse fazer o redirecionamento à minha rede local pela porta 80, pra que pudesse acessar pela minha rede local.
Feita a liberação consigo acessar normalmente a interface gráfica via browser, porém, após o fim da instalação, notei que havia um erro na dashboard principal do zabbix "Zabbix server is not running". Sobre esta informação, tomei todas as medidas cabíveis em busca de informação.
* Verifiquei o serviço do banco de dados, que está de pé, e tudo funcionando.
* Verifiquei as configurações no zabbix-server.conf se alguma ação poderia ser tomada, porém nada funcinou.

Vendo que possivelmente problema não era no serviço, e menos ainda no zabbix, uma vez que a instalação foi feita de forma cuidadosa, resolvi verificar se o servidor tinha alguma questão que impossibilitasse o servidor de funcionar.
Verifiquei se o selinux estava startado, não estava.
Verifiquei se o serviço do firewall estava estartado também, e não estava.
Verifiquei as portas que estavam abertas com o comando netstat -na, notei que todas as portas estão abertas, exceto a 10051.

Ativei o firewalld, e liberei todas as portas referentes ao zabbix, mesmo assim, com o netstat -na continua trasendo que a 10051 não está ouvindo.

Alguém consegue me informar como fazer a porta 10051 ouvir?


  


2. Re: Zabbix em Tcloud não roda.

Leandro Silva
LSSilva

(usa Outra)

Enviado em 12/07/2021 - 14:53h

Boa tarde!

É porque o serviço não está rodando mesmo.

Temos que analisar o log pra ver o que é.

Poste a saída do comando:

tail -n 150 /var/log/zabbix-server/zabbix_server.log 



3. .

Lucas Radtke
LucasRadtke

(usa Ubuntu)

Enviado em 15/07/2021 - 23:01h


Da uma olhada nesse link


https://sobrelinux.info/questions/670065/zabbix-agent-unreachable


Como o colega mensiona acima, vais ter que tentar verificar pelo Log específico.