NÃO CONSIGO INSTALAR ZABBIX NO DEBIAN 11 [RESOLVIDO]

1. NÃO CONSIGO INSTALAR ZABBIX NO DEBIAN 11 [RESOLVIDO]

RENATO LINCONL DA SILVA LIMA
renatrenolinconl

(usa Fedora)

Enviado em 08/12/2021 - 20:26h

Amigos estou tentando instalar para estudar o zabbix com o seguinte comando no DEBIAN 11

apt install build-essential libmariadb-dev sudo libxml2-dev snmp libsnmp-dev libcurl4-openssl-dev php-gd php-xml php-bcmath php-mbstring vim libevent-dev libpcre3-dev libxml2-dev libmariadb-dev libapache2-mod-php libopenipmi-dev pkg-config php-ldap php-mysql -y

A Saída do Comando Fica Assim:

endo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
pkg-config is already the newest version (0.29.2-1).
pkg-config configurado para instalar manualmente.
sudo is already the newest version (1.9.5p2-3).
sudo configurado para instalar manualmente.
vim is already the newest version (2:8.2.2434-3).
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
dpkg-dev : Depende: libdpkg-perl (= 1.19.7) mas 1.20.9 está para ser instalado
Recomenda: fakeroot
Recomenda: libalgorithm-merge-perl mas não será instalado
g++ : Depende: cpp (= 4:8.3.0-1) mas 4:10.2.1-1 está para ser instalado
gcc : Depende: cpp (= 4:8.3.0-1) mas 4:10.2.1-1 está para ser instalado
libc6-dev : Depende: libc6 (= 2.28-10) mas 2.31-13+deb11u2 está para ser instalado
Depende: libc-dev-bin (= 2.28-10) mas não será instalado
libcurl4-openssl-dev : Depende: libcurl4 (= 7.64.0-4+deb10u2) mas 7.74.0-1.3+b1 está para ser instalado
libgdbm-dev : Depende: libgdbm6 (= 1.18.1-4) mas 1.19-2 está para ser instalado
libgnutls28-dev : Depende: libgnutls-dane0 (= 3.6.7-4+deb10u7) mas não será instalado
Depende: libgnutls-openssl27 (= 3.6.7-4+deb10u7) mas não será instalado
Depende: libgnutls30 (= 3.6.7-4+deb10u7) mas 3.7.1-5 está para ser instalado
Depende: libgnutlsxx28 (= 3.6.7-4+deb10u7) mas não será instalado
Depende: libidn2-dev mas não será instalado
Depende: libp11-kit-dev (>= 0.23.10) mas não será instalado
Depende: libtasn1-6-dev mas não será instalado
Depende: nettle-dev (>= 3.4.1~rc1) mas não será instalado
libpci-dev : Depende: libpci3 (= 1:3.5.2-1) mas 1:3.7.0-5 está para ser instalado
Depende: libudev-dev (>= 196) mas não será instalado
libpcre3-dev : Depende: libpcre3 (= 2:8.39-12) mas 2:8.39-13 está para ser instalado
libsensors4-dev : Depende: libsensors5 (= 1:3.5.0-3) mas 1:3.6.0-7 está para ser instalado
libssl-dev : Depende: libssl1.1 (= 1.1.1d-0+deb10u7) mas 1.1.1k-1+deb11u1 está para ser instalado
libwrap0-dev : Depende: libwrap0 (= 7.6.q-28) mas 7.6.q-31 está para ser instalado
libxml2-dev : Depende: libxml2 (= 2.9.4+dfsg1-7+deb10u2) mas 2.9.10+dfsg-6.7 está para ser instalado
zlib1g-dev : Depende: zlib1g (= 1:1.2.11.dfsg-1) mas 1:1.2.11.dfsg-2 está para ser instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
.
Eu já fiz muitas coisas e não sei mais oq fazer.
Nunca usei o debian estou meio perdido ficarei grato se alguém poder me ajudar.


  


2. Re: NÃO CONSIGO INSTALAR ZABBIX NO DEBIAN 11 [RESOLVIDO]

alberto roberto
adminbuster

(usa Debian)

Enviado em 08/12/2021 - 20:57h


você está usando o debian instável ?
parece que seu sistema está quebrado
mas afinal porque você está instalando tudo isso ?
você quer compilar o tal do software em questão ou oque porque só para instala-lo não depende de tudo isso
https://www.zabbix.com/download?zabbix=5.4&os_distribution=debian&os_version=10_buster&d...


3. Re: NÃO CONSIGO INSTALAR ZABBIX NO DEBIAN 11 [RESOLVIDO]

RENATO LINCONL DA SILVA LIMA
renatrenolinconl

(usa Fedora)

Enviado em 08/12/2021 - 22:29h


adminbuster escreveu:


você está usando o debian instável ?
parece que seu sistema está quebrado
mas afinal porque você está instalando tudo isso ?
você quer compilar o tal do software em questão ou oque porque só para instala-lo não depende de tudo isso
https://www.zabbix.com/download?zabbix=5.4&os_distribution=debian&os_version=10_buster&d...



Eu instalei o debian só pra fazer isso é versão 11 do site da debian
Debian 11, codinome bullseye, netinst, para PC 64 bits (amd64).


4. Re: NÃO CONSIGO INSTALAR ZABBIX NO DEBIAN 11 [RESOLVIDO]

RENATO LINCONL DA SILVA LIMA
renatrenolinconl

(usa Fedora)

Enviado em 08/12/2021 - 23:14h


AGORA QUANDO EU DO COMANDO:
apt-get install mysql-server apache2 build-essential snmp-mibs-downloader snmp

A SAÍDA É ESSA

Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
O pacote snmp-mibs-downloader não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

O pacote mysql-server não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote 'mysql-server' não tem candidato para instalação
E: O pacote 'snmp-mibs-downloader' não tem candidato para instalação



5. Re: NÃO CONSIGO INSTALAR ZABBIX NO DEBIAN 11

alberto roberto
adminbuster

(usa Debian)

Enviado em 09/12/2021 - 21:58h

realmente parece que seu sistema está quebrado por alguma razão

instale um novo sistema limpo e siga a instrução de instalação do software

não entendo porque você quer instalar o mysql-server para instalar o tal do zabbix

https://www.zabbix.com/download?zabbix=5.4&os_distribution=debian&os_version=11_bullseye&...


6. Re: NÃO CONSIGO INSTALAR ZABBIX NO DEBIAN 11 [RESOLVIDO]

Amarildo Sertório dos Santos
amarildosertorio

(usa Fedora)

Enviado em 10/12/2021 - 10:31h

adminbuster escreveu:

realmente parece que seu sistema está quebrado por alguma razão

instale um novo sistema limpo e siga a instrução de instalação do software

não entendo porque você quer instalar o mysql-server para instalar o tal do zabbix

https://www.zabbix.com/download?zabbix=5.4&os_distribution=debian&os_version=11_bullseye&...


O Zabbix Server depende de um banco de dados, isso é pré-requisito. Acredito que o mais popular seja o MySQL.

A comunidade tem falado bastante sobre TimescaleDB. Para quem tem uma volumetria muito grande vale o estudo.


7. Re: NÃO CONSIGO INSTALAR ZABBIX NO DEBIAN 11 [RESOLVIDO]

Amarildo Sertório dos Santos
amarildosertorio

(usa Fedora)

Enviado em 10/12/2021 - 11:01h

renatrenolinconl escreveu:


AGORA QUANDO EU DO COMANDO:
apt-get install mysql-server apache2 build-essential snmp-mibs-downloader snmp

A SAÍDA É ESSA

Lendo listas de pacotes... Pronto
Construindo árvore de dependências... Pronto
Lendo informação de estado... Pronto
O pacote snmp-mibs-downloader não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

O pacote mysql-server não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote 'mysql-server' não tem candidato para instalação
E: O pacote 'snmp-mibs-downloader' não tem candidato para instalação


* Como instalar o MySQL 8.0 no Debian 11
https://computingforgeeks.com/how-to-install-mysql-8-0-on-debian/

O snmp-mibs-downloader faz parte do repositório non-free e tudo indica que esteja desabilitado no seu sources.list.
https://cstan.io/?p=11512&lang=en






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts