Não consigo instalar wine32

1. Não consigo instalar wine32

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 25/02/2021 - 13:19h

pessoas .. uso aqui Debian 10 + Cinnamon ... estou tentando instalar ( e usar ) o wine e sempre embaça no erro


[email protected] /mnt/Dados/Programas # wine CrystalDiskInfo7_0_5.exe
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first. as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first. as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"
wine: Formato EXE impróprio para Z:\mnt\Dados\Programas\CrystalDiskInfo7_0_5.exe.
[email protected] /mnt/Dados/Programas # dpkg --add-architecture i386 && apt-get update &&
> apt-get install wine32
Obter:1 http://security.debian.org buster/updates InRelease [65,4 kB]
Atingido:3 http://ppa.launchpad.net/fossfreedom/rhythmbox-plugins/ubuntu xenial InRelease
Atingido:2 http://cdn-fastly.deb.debian.org/debian buster InRelease
Atingido:5 https://download.sublimetext.com apt/stable/ InRelease
Obter:4 http://cdn-fastly.deb.debian.org/debian buster-updates InRelease [51,9 kB]
Obter:6 https://mega.nz/linux/MEGAsync/Debian_10.0 ./ InRelease [2.461 B]
Ign:7 http://liveusb.info/multisystem/depot all InRelease
Atingido:8 http://liveusb.info/multisystem/depot all Release
Baixados 120 kB em 2s (73,0 kB/s)
Lendo listas de pacotes... Pronto
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
wine32:i386 : Depende: libwine:i386 (= 4.0-2) mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
[email protected] /mnt/Dados/Programas # apt -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
[email protected] /mnt/Dados/Programas #


NOTA: usando playonlinux e winetricks o erro persiste
NOTA1: esse executável foi só usado só para exemplificar aqui no fórum, acontece com qualquer um

OBS: eu tô achando que o problema está sendo para conseguir usar arquitetura X86, mas não consegui encontrar nada que me desse uma luz




  


2. Re: Não consigo instalar wine32

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 25/02/2021 - 14:43h


Tenque habilitar a arquitetura i386:

sudo dpkg --add-architecture i386
sudo apt -get update

Aí se for preciso, complemente com:

sudo apt-get dist -upgrade

___________________________________________________________
Conhecimento não se Leva para o Túmulo.
https://github.com/MauricioFerrari-NovaTrento



3. Re: Não consigo instalar wine32

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 25/02/2021 - 14:44h


Detalhes aqui:
https://wiki.debian.org/pt_BR/Multiarch/HOWTO

___________________________________________________________
Conhecimento não se Leva para o Túmulo.
https://github.com/MauricioFerrari-NovaTrento



4. Re: Não consigo instalar wine32

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 25/02/2021 - 14:48h


mauricio123 escreveu:


Tenque habilitar a arquitetura i386:

sudo dpkg --add-architecture i386
sudo apt -get update

Aí se for preciso, complemente com:

sudo apt-get dist -upgrade

___________________________________________________________
Conhecimento não se Leva para o Túmulo.
https://github.com/MauricioFerrari-NovaTrento


tá lá jovem ... já foi feito ... tá postado

NOTA: meu sistema está todo atualizo !!!

------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




5. Re: Não consigo instalar wine32

Mauricio Ferrari
mauricio123

(usa Slackware)

Enviado em 25/02/2021 - 21:12h

Então quer dizer que você já fez o que eu havia mencionado.

Nesse caso não sei o que sugerir.

___________________________________________________________
Conhecimento não se Leva para o Túmulo.
https://github.com/MauricioFerrari-NovaTrento



6. Re: Não consigo instalar wine32

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 25/02/2021 - 23:08h

Você já olho esse resultado do APT?
ou foram retirados da "Incoming". 
As vezes acontece das distros removerem um pacote dos repositório por vários motivos incluindo vulnerabilidades graves.
Se fosse Ubuntu eu olharia no ubuntu package(pagina web) se ele foi retirado.
https://packages.ubuntu.com/
Se você estiver no Debian ele tem um sistema(pagina web) parecido com o do Ubuntu para checar os pacotes dos repositório.
https://www.debian.org/distrib/packages
Por exemplo.
Tem uma dependência de compilação do Firefox que foi retirado da incoming do Ubuntu 16.04, e não sei o motivo.

Você tem que olhar essa msg:
wine32:i386 : Depende: libwine:i386 (= 4.0-2) mas não será instalado 
Diz o APT que não vai instalar o "libwine:i386" então é esse que você tem que saber se ele esta na incoming.
Pode ser que o comando:
$ apt search libwine:i386 
Procure o pacote para você mais eu nunca usei esse método, sempre olhei pelo navegador.
Caso você não encontre então a dependência do wine32 foi retirado do repositório(incoming) sendo assim é impossível instalar pelo método que você esta usando.

Neste caso o único que você pode usar é o do site do WineHQ.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


7. Re: Não consigo instalar wine32

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 26/02/2021 - 01:37h

Tente essas dicas aqui
https://linuxhint.com/apt_get_fix_missing_broken_packages/
Se não estou enganado o comando dpkg --add-architecture i386 && apt-get update deve ser o 1o a ser rodado p instalar o wine, então seria interessante desinstalar e recomeçar a instalação. Outra coisa são os repositórios peculiares da sua instalação. Logo logo vai começar a aparecer confluto de versão. Descomente os extras e use os da distro. Vc pode verificar o pacote e as dependências além de ver de qual repositório vai baixar fazendo
apt-cache policy wine32
apt-cache depends wine32
apt-cache showpkg wine32






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts