Problema webcam [RESOLVIDO]

1. Problema webcam [RESOLVIDO]

Julian Soares
juliansoares

(usa Debian)

Enviado em 16/01/2012 - 12:09h

Bom dia Linux's

tenho um notebook dell vostro 3450

aparentemente minha webcam estava funcionando normal com o cheese, agora parou de funcionar,

saida do caomando lsusb :
zeus ~ # lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 138a:0011 Validity Sensors, Inc. VFS5011 Fingerprint Reader


erro do cheese :

(cheese:10287): Clutter-CRITICAL **: clutter_actor_set_text_direction: assertion `text_dir != CLUTTER_TEXT_DIRECTION_DEFAULT' failed

** (cheese:10287): WARNING **: cheese-window.vala:1259: Error: Nenhum dispositivo localizado


obs. ja tentei instalar o luvcview, dov4l, v4l* , uvcvideo,

mas até agora nada!




  


2. Re: Problema webcam [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/01/2012 - 13:48h

mais um? esse negócio de webcam aki já tá virando mania.

Mutcho bem, lá vamos nós de novo.

Em primeiro lugar vc vai fazer estes procedimentos:

=============================================

a) primeiramente, instale o pacote gstreamer0.10-gconf. para debian só existe da versão "testing" para cima...

=============================================

b) como root, rode o seguinte comando:

$ modprobe uvcvideo

somente isso.

=============================================

c) veja se não tem um botãozinho liga/desliga a webcam. Pode ter a imagem de uma câmera de filmar. Nos NoBo's que os tem, a ligar a webcam aparece uma luzinha ao lado da lente da webcam.

na imagem: http://va.mu/TdOX o botão da webcam pode ser um dos três no canto superior direito. Se não tiver lá, procure entre F1 até F12.

se tiver o botão, ligue-o, espere a luzinha acender ao lado da lete da webcam e rode o comando abaixo no terminal:

$ mplayer tv:///

se a imagem aparecer, tá tudo ok...

==============================================

d) se vc não obteve sucesso no passo "c", deixe a webcam ligada e dê um boot com o cd do seu linux e rode o comando:

$ lsmod > modulos.txt

copie o arquivo modulos.txt para um pendrive, saia do cd e entre novamente no seu linux. Coloque aqui o conteúdo do arquivo pre'u analisar.

==============================================

e) com a webcam ligada rode o comando abaixo, também:

$ cd /dev
$ ls video*


==============================================

Só volte a responder quando tiver feito TODOS os passos acima. Para cada um que eu falei, vc responde dizendo o que ocorreu.

Estou no aguardo.

FAÇA TUDO que eu disse!!!
FAÇA TUDO que eu disse!!!
FAÇA TUDO que eu disse!!!
FAÇA TUDO que eu disse!!!

;-/



3. Re: Problema webcam [RESOLVIDO]

Julian Soares
juliansoares

(usa Debian)

Enviado em 16/01/2012 - 13:55h

a - zeus ~ # apt-get install gstreamer0.10-gconf
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
gstreamer0.10-gconf já é a versão mais nova.
gstreamer0.10-gconf configurado para instalar manualmente.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

b - zeus ~ # modprobe uvcvideo

c - zeus ~ # mplayer tv:///
MPlayer SVN-r34442 (C) 2000-2010 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv:///.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <[email protected]>
comment: first try, more to come ;-)
v4l2: unable to open '/dev/video0': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped.

obs.( no notebook vostro não tem botao para ligar a CAM. é automatico.)


d - para dar o boot com o cd, precisar ser o Live-CD? se não como faço, quando coloco o cd ele aparece a imgagem de instalar graphical etc etc...

e - não existe o arquivo/diretorio /dev/video



4. Re: Problema webcam [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/01/2012 - 14:09h

vamos lá:

a) o gstreamer já tá instalado -> menos um problema
b) o modulo uvcvideo tá carregado -> menos outro problema
c) sem botão para webcam -> menos outro problema
d) o comando mplayer não abriu a webcam e já sei o porquê -> menos outro problema
e) não existe /dev/video* -> menos outro problema

agora:

e) com o debian não é cd modo live, se tiver pode usar qualquer outra distro. Se vc não tiver, deixe pra lá.

qual cd live vc tem aí?



5. Re: Problema webcam [RESOLVIDO]

Julian Soares
juliansoares

(usa Debian)

Enviado em 16/01/2012 - 14:14h

d- zeus ~ # mplayer tv:///
MPlayer SVN-r34442 (C) 2000-2010 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv:///.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <[email protected]>
comment: first try, more to come ;-)
v4l2: unable to open '/dev/video0': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped.


Exiting... (End of file)

obs. Não ligou a CAM.



e - Não entendi ainda, precisa ser ou nao live-cd ?


f - zeus /dev # ls
agpgart char dvdrw kmsg loop6 network_latency random sda3 stdin tty13 tty20 tty28 tty35 tty42 tty5 tty57 tty7 urandom vcs6 vcsa6
autofs console fb0 log loop7 network_throughput rfkill sda4 stdout tty14 tty21 tty29 tty36 tty43 tty50 tty58 tty8 vboxusb vcs7 vcsa7
block core fd loop0 loop-control null root shm tty tty15 tty22 tty3 tty37 tty44 tty51 tty59 tty9 vcs vcsa vga_arbiter
bsg cpu full loop1 MAKEDEV port rtc snapshot tty0 tty16 tty23 tty30 tty38 tty45 tty52 tty6 ttyS0 vcs1 vcsa1 watchdog
btrfs-control cpu_dma_latency fuse loop2 mapper ppp rtc0 snd tty1 tty17 tty24 tty31 tty39 tty46 tty53 tty60 ttyS1 vcs2 vcsa2 xconsole
bus disk hpet loop3 mcelog psaux sda sndstat tty10 tty18 tty25 tty32 tty4 tty47 tty54 tty61 ttyS2 vcs3 vcsa3 zero
cdrom dri initctl loop4 mem ptmx sda1 sr0 tty11 tty19 tty26 tty33 tty40 tty48 tty55 tty62 ttyS3 vcs4 vcsa4
cdrw dvd input loop5 net pts sda2 stderr tty12 tty2 tty27 tty34 tty41 tty49 tty56 tty63 uinput vcs5 vcsa5
zeus /dev #


obs. Não existe o diretorio ou arquivo video.



6. Re: Problema webcam [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/01/2012 - 14:23h

o live-cd é para descobrirmos qual módulo sua webcam usa. Como ela liga automaticamente e não aparece no comando lsusb, fica difícil identificá-la no linux instalado.

por isso pedi o live-cd. Ele detecta a webcam no boot e carrega o módulo apropriado, que descobriremos qual é. Por ser live-cd vc faz tudo no ambiente gráfico, sendo muito mais simples.

sua webcam parou de ser ligada automaticamente. Pode ser por alguma atualização que vc fez, um bug no próprio módulo ou no cheese. Tanto que o mplayer não reconhece o /dev/video0 ou video1 etc...

Não há dispositivo /dev/video pq ela não tá ligada.

=======================================

veja que o mplayer não achou o dispositivo de vídeo, no diretório /dev:

v4l2: unable to open '/dev/video0': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped.


se tivesse ativo, seria mais ou menos assim:

Selected device: BisonCam, NB Pro
Capabilities: video capture streaming
supported norms:
inputs: 0 = Camera 1;
Current input: 0
Current format: YUYV


=======================================

Neste exato momento estamos na seguinte situação:

a) precisamos "ligar" a webcam para identificá-la com o comando lsusb
b) mas ela não pode ser ligada, aí não podemos identificá-la
c) sem identificá-la, não podemos descobrir seu módulo
d) sem módulo, sem /dev/video0

neste contexto insere-se o live-cd, tentar desatar este nó.

LEMBREI: se tiver um live-cd qualquer, rode também o lsusb para descobrirmos a identidade da webcam.

LEMREI 2: instale os pacotes firmware-linux-free e firmware-linux-nonfree




7. Re: Problema webcam [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/01/2012 - 14:42h

tente isso também. Logue-se como root:

# modprobe sn9c102
# exit
$ mplayer tv:///




8. Re: Problema webcam [RESOLVIDO]

Julian Soares
juliansoares

(usa Debian)

Enviado em 16/01/2012 - 14:49h

acvsilva escreveu:

tente isso também. Logue-se como root:

# modprobe sn9c102
# exit
$ mplayer tv:///



nada ainda, tentei instalar os firmware e rodei os comandos vc colocou :

zeus ~ # modprobe sn9c102
zeus ~ # mplayer tv:///
MPlayer SVN-r34442 (C) 2000-2010 MPlayer Team
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv:///.
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <[email protected]>
comment: first try, more to come ;-)
v4l2: unable to open '/dev/video0': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped


ps. estou no trabalhao chegando em casa eu vcoloco o live-cd e rodo o lsusb e copio a saida do comando num txt.




9. Re: Problema webcam [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/01/2012 - 14:51h

tô no aguardo!



10. Re: Problema webcam [RESOLVIDO]

Julian Soares
juliansoares

(usa Debian)

Enviado em 16/01/2012 - 15:06h

acvsilva escreveu:

tô no aguardo!
o comando no live-cd é o lsmod ou lsusb ?



11. Re: Problema webcam [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/01/2012 - 15:20h

o mesmo da distro instalada. n tem diferença:

$ lsusb > perifericos.txt

e também

$ lsmod >> perifericos.txt

vamos ver oq a gente consegue...



12. Re: Problema webcam [RESOLVIDO]

Julian Soares
juliansoares

(usa Debian)

Enviado em 18/01/2012 - 11:03h

só para notificar a webcam voltou a funcionar!

fiz o que a galera ae pediu , não tinha dado certo, mas hj ela esta funcionando normalmente.



01 02