Câmera não funciona [RESOLVIDO]

1. Câmera não funciona [RESOLVIDO]

Sergio Teixeira - Linux User # 499126
Teixeira

(usa Linux Mint)

Enviado em 12/10/2009 - 20:27h

Adquiri uma webcam genérica, que é reconhecida mas não funciona de jeito nenhum no Linux (atualmente Big Linux 4.2).
Trata-se de uma LDLC OV7620+VC302 que é reconhecida como:

Bus 001 Device 006: 0ac8:307b Z-Star Microelectronics

O dispositivo é reconhecido, mas não necessariamente como uma webcam.
Depois do lsmod | grep usb e no meio daquela verbose toda, diz:
[ 7823.523984] usb 1-1.4: new full speed USB device using uhci_hcd and address 6
Depois eu entrei com
ln -s /dev/v4l/video0 /dev/video
e
ln -s /dev/v4l/video0 /dev/video0
Aí veio a resposta
ln: criando link simbólico '/dev/video0': O arquivo já existe

Eu deveria obter pelo menos uma tela preta, mas acontece que nem no Skype, nem no Camera Monitor, ou gspca, gqcam, camorama, (conforme um monte de dicas que andei lendo por aí), consegui alguma coisa. Nada até agora.
Sendo uma cãmera MUITO barata (R$ 25,00) e de 480k funciona muito bem no Windows XP, com o driver que acompanha o produto, semelhantemente a essas que são vendidas como sendo de "1.3 megapixels", conseguindo acompanhar com firmeza um frame rate de 30 quadros por segundo.

O Camera Monitor me diz se a câmera está "on" ou "off", mas imagem que é bom, nada.
Camorama me dá todas as configurações, que a meu ver estão perfeitamente normais e rigorosamente de acordo com as configurações de outras câmeras que funcionam.

Em grep usb obtive a seguinte resposta:
usb storage - 74432 0
libusual ---- 20772 1 usb_storage
scsi_mod --- 151436 5 usb storage,sg,sr_mod,sd_mod,libata
usbcore ---- 146028 6 usb_storage,libusual,gspca,ehci_hcd,uhci_hcd

Esse tipo de câmera é listado como compatível com zc3xx (tem um monte de fabricantes que assemblam esse tipo de câmera)
mas não sei onde informar esse parâmetro.
Alguém pode me dar uma luz?






  


2. MELHOR RESPOSTA

Joao
stack_of

(usa Slackware)

Enviado em 12/10/2009 - 21:08h

Acredito que o módulo da câmera é o gspca_zc3xx.

Tenta carregar o módulo:

#modprobe gspca_zc3xx

Se nao carregar o modulo voce vai ter que compilar o kernel. Se quiser ajuda e só falar, que tamos ai.
Se o módulo instalar e a câmera não produzir imagem, instala a biblioteca libv4l, que pode ser encontrada aqui:

http://hansdegoede.livejournal.com/3636.html

Após instalar a biblioteca, inicia o Skype assim:

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype







3. Re: Câmera não funciona [RESOLVIDO]

Rodrigo Chaves
stilldre

(usa Funtoo)

Enviado em 12/10/2009 - 20:42h

tem alguma coisa com o GSPCA
talvez isso possa ajudar:
http://www.slackbr.org/forum/viewtopic.php?f=200&t=18007


4. Re: Câmera não funciona [RESOLVIDO]

Andre Antonio da Silva Neto
andre_asn

(usa Slackware)

Enviado em 12/10/2009 - 21:06h

Boa noite bom tente este comando aqui como usuario comum e veja se abre sua cam pelo terminal, se abrir sua camera esta funcionando mas o sistema não consegue enxerga-la -( a minha funciona) mas o sistema não acha ela de forma alguma -

$ gst-launch-0.10 v4l2src ! autovideosink


5. Re: Câmera não funciona [RESOLVIDO]

Sergio Teixeira - Linux User # 499126
Teixeira

(usa Linux Mint)

Enviado em 13/10/2009 - 07:27h

Stildre, o meu problema é que não tenho uma tela preta, mas tela nenhuma.

As demais sugestões, somente à noite poderei testar.
Por enquanto, fica aqui muito obrigado a vocês.



6. Re: Câmera não funciona [RESOLVIDO]

Rossano Huf
millemiglia

(usa Slackware)

Enviado em 13/10/2009 - 14:13h

Teixeira, dá uma olhada nessa dica do fórum do Big Linux. Acho que vai te ajudar.
http://www.biglinux.com.br/forum/viewtopic.php?t=6775


7. Re: Câmera não funciona [RESOLVIDO]

Sergio Teixeira - Linux User # 499126
Teixeira

(usa Linux Mint)

Enviado em 15/10/2009 - 15:22h

Agradeco aos amigos pela rapidez em responder.

Tentei inscrever-me no forum do Big Linux para postar minha duvida, mas ate` agora nao recebi o email de confirmacao de minha inscricao.

Entretanto, o DreamLinux reconhece e instala a camera com todos os parametros, porem exibe apenas uma tela com os padroes de cores (barras verticais coloridas) e uma pequena tela onde aparece um chuvusco e nada mais.

Pelo que pude apurar. o driver para Windows se chama "ZSMC USB PC Camera (ZS0211)" e esse modulo zc3xx aceita varios modelos de sensores, porem com 0ac8:3072 e nao 307b embora existam modelos 307b porem que nao sao da Z-Star, mas de outro fabricante.
O nome que vem silkado na camera e` VENEZYX.



8. Re: Câmera não funciona [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 15/10/2009 - 15:52h

Fala Teixeira... o seu problema eu ja enfrentei, mas com a Logitech Quickcam Express... o fato é que não sei porque... o driver que vem não funciona... ele detecta diz que a camera esta la etc, mas na hora de dar o grau...nada... amsn, cheese, skype. etc, nada funciona. No meu caso, a solução foi recompilar o driver e reinstalar o tal módulo.

AGORA... penso que vc deveria dar um lsmod e verificar o nome do que é carregado e buscar recompilar em cima do seu modelo de web... de fato, é um belo enrosco,mas estou certo de que vc vai conseguir...

tenta os foruns gringos de ubuntu, eles saõ prodigos em solucoes (algumas furadas é bem verdade)...


9. Re: Câmera não funciona [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 15/10/2009 - 16:18h

Teixeira, eu tenho uma webcam generica com chipset Z-Star Microelectronics...

os drivers SPCA não funcionam bem em kerneis mais novos que o 2.6.26.

para os kerneis 27 em diante, pode ser necessário instalar uma bilioteca de compatibilidade e carregar o aplicativo )skpe, camorama etc..._ com uma instrução de preload dessa biblioteca.

veja:

http://www.vivaolinux.com.br/dica/Instalando-webcams-simples-em-Linux/

E COMENTARIOS da DICA, EM ESPECIAL O cOMENTÁRIO NÚMERO 3

Se preferir, faça downgrade do kernel ao 2.6.26, e instalce gspcav1, como na dica.
as duas alternativas tem funcionado bem com minha cam, em Sabayon, gentoo e Mandriva.
Para windows Vista e Windows 7, minha cam também é problematica, o driver Z-Star do XP não funcionou no Vista, mas eeu usei o driver para vista da web cam Lenovo e funcionou.


10. Re: Câmera não funciona [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 15/10/2009 - 16:23h

So um adendo... NUNCA consegui usar essa libcompat-blablabla...

sempre foi necessario recompilar, usando alguns patches que andei encontrando...

como uso muito a webcam, voces podem verificar que muito material que produzi se refere a isso... script pra compilar e baixar etc...


11. Re: Câmera não funciona [RESOLVIDO]

Sergio Teixeira - Linux User # 499126
Teixeira

(usa Linux Mint)

Enviado em 16/10/2009 - 10:14h

Recebi o email de confirmação de minha inscrição no forum do Big Linux.
Como estão prometendo a nova versão 5.0 e trancaram o tópico referente a compatibilidade de hardware, acho bom aguardar mais um pouco.
Aproveito para deixar a dica de que a impressora Canon BJC 2100, embora não esteja (no Big Linux) na lista das compatíveis, funciona perfeitamente bem, com tonalidades bem suaves e perdendo apenas cerca de 3mm de cada margem, graças ao CUPS em sua versão 1.3.
Vou marcar o tópico como "RESOLVIDO", mas mesmo que o Big 5.0 não resolva, continuarei a fazer experimentos até esgotar a última possibilidade.
Contudo determinar qual foi a melhor resposta foi bastante difícil, pois todas foram muito úteis - da mais simples à mais extensa.
Esta comunidade está realmente de parabéns.




12. Re: Câmera não funciona [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 16/10/2009 - 16:39h

Teixeira, experimenta da uma lida aqui...

http://lists-archives.org/spca50x-devs/01731-0ac8-307b-z-star-microelectronics-corp-usb-1-1-webcam.h...

driver? : http://moinejf.free.fr/gspcav2-2.0.3.tar.gz

"We shall never surrender" -- Winston Churchill



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts