Erro ao iniciar o X do Slackware no VirtualBox [RESOLVIDO]

1. Erro ao iniciar o X do Slackware no VirtualBox [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 25/01/2010 - 20:52h

Olá, galera, eu estou enfrentando um problema com o VirtualBox (tanto com o SUN quanto o OSE), eu consigo instalar e usar o Slackware 13 apenas em modo texto, quando eu executo o comando "startx" sempre ocorre um erro crítico e a máquina virtual pára de funcionar. O incrível é que isso só acontece com o Slackware, lembrando que o meu sistema nativo é o Ubuntu 9.10.


  


2. Re: Erro ao iniciar o X do Slackware no VirtualBox [RESOLVIDO]

Diego Langer
dlanger

(usa Debian)

Enviado em 26/01/2010 - 11:47h

Dê uma olhada nesta dica aqui do VoL, deve resolver seu problema.

- http://www.vivaolinux.com.br/dica/Iniciando-no-modo-grafico-no-Slackware/


3. Erro ao iniciar o X do Slackware no VirtualBox

Perfil removido
removido

(usa Nenhuma)

Enviado em 26/01/2010 - 16:29h

eim colega, eu dei uma olhada nesse artigo que vc me recomendou, mas a menos que eu não tenha entendido direito ele se limita a explicar como fazer para que o Slackware inicie o X automaticamente,
Mas o meu caso não se trata do Slackware instalado na máquina e sim no Virtualbox, que dá um erro crítico sempre que eu inicio o X no Slackware Virtual, portanto acho que esse artigo não se aplica ao meu caso.


4. Solucao

ribeiro
alerocha19

(usa Nenhuma)

Enviado em 27/04/2011 - 20:14h

Após fazer o upgrade para Ubuntu 11.04 voltou o erro: Kernel driver not installed (rc=-190)

O que fiz?

segui os passos:

1)
http://www.tiagohillebrandt.eti.br/blog/2011/01/instalando-o-virtualbox-4-0-via-repositorio-no-ubunt...

2)
http://www.vivaolinux.com.br/dica/Suporte-a-pendrive-no-VirtualBox-4

3)
E por fim:

Após seguir os passos do Alan Souza, o meu ubuntu 11.04 apresentava o seguinte erro e não carregava no VirtualBox 4.0.6.

Erro:
Failed to load unit 'HGCM' (VERR_INVALID_PARAMETER)

Solução:

Vai na máquina virtual e com o botão direito do mouse em cima da máquina, clica em descartar, assim, sua máquina virtual irá iniciar do zero e o problema solucionado.


valeu.


5. Re: Erro ao iniciar o X do Slackware no VirtualBox [RESOLVIDO]

Ciro Souza
cirofsouza

(usa Slackware)

Enviado em 28/04/2011 - 22:13h

Gedimar,
Se vc está instalando o Slackware 13.1 então voce terá problemas mesmo. Não me lembro exatamente como se faz no VitualBox (eu uso o qemu) mas vc já tentou configurar a interface gráfica que vai ser emulada? Alguns drivers do X do Slackware 13.1 dão problemas. Voce pode também tentar usar o arquivo xorg.conf-vesa como arquivo de configuração do X (é só criar uma copia com o nome xorg.conf). Nas instalações que faço em maquinas reais quando o X não inicia ou inicia travando a maquina, eu uso esse drive para diagnosticar o problema.


6. Re: Erro ao iniciar o X do Slackware no VirtualBox [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 29/04/2011 - 07:48h

Olá

Na verdade, esse erro acontecia com o Slackware 13, faz bastante tempo que fiz esse tópico. mas acho que o problema tinha muito mais a ver com a versão do Virtual Box, pois o mesmo Slack 13 funciona normalmente agora.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts