Não consigo executar o VMWare Player no Linux Mint

1. Não consigo executar o VMWare Player no Linux Mint

Keity Melo
krafidhi

(usa Ubuntu)

Enviado em 29/04/2018 - 20:58h

Pessoal, eu tive esse problema com o Ubuntu 16.04 e estou tendo também agora no Linux Mint 18.3
Eu instalei o VMWare depois de baixar o instalador do site oficial, e tudo correu perfeitamente. Quando tento executar o programa pela primeira vez, recebo uma mensagem de que preciso compilar alguns módulos. Todos os detalhes do erro estão descritos neste post: https://www.vivaolinux.com.br/dica/VMware-Player-no-Ubuntu-Erro-Before-you-can-run-VMware-several-mo...

Tentei executar as alterações sugeridas neste tutorial, mas a partir do comando " tar xvf vmnet.tar vmnet-only/filter.c "
começo a receber mensagens de erro...
O VMWare gera o seguinte arquivo de log:

2018-04-29T20:51:59.892-03:00| vthread-4| I125: Log for VMware Workstation pid=9966 version=12.5.9 build=build-7535481 option=Release
2018-04-29T20:51:59.892-03:00| vthread-4| I125: The process is 64-bit.
2018-04-29T20:51:59.892-03:00| vthread-4| I125: Host codepage=UTF-8 encoding=UTF-8
2018-04-29T20:51:59.892-03:00| vthread-4| I125: Host is Linux 4.13.0-39-generic Linux Mint 18.3 Sylvia
2018-04-29T20:51:59.848-03:00| vthread-4| I125: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": Arquivo ou diretório não encontrado.
2018-04-29T20:51:59.848-03:00| vthread-4| I125: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2018-04-29T20:51:59.891-03:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/config": Arquivo ou diretório não encontrado.
2018-04-29T20:51:59.891-03:00| vthread-4| I125: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
2018-04-29T20:51:59.891-03:00| vthread-4| I125: PREF Unable to check permissions for preferences file.
2018-04-29T20:51:59.891-03:00| vthread-4| I125: DictionaryLoad: Cannot open file "/root/.vmware/preferences": Arquivo ou diretório não encontrado.
2018-04-29T20:51:59.891-03:00| vthread-4| I125: PREF Failed to load user preferences.
2018-04-29T20:52:00.228-03:00| vthread-4| W115: Logging to /tmp/vmware-root/vmware-9966.log
2018-04-29T20:52:00.315-03:00| vthread-4| I125: Obtaining info using the running kernel.
2018-04-29T20:52:00.316-03:00| vthread-4| I125: Created new pathsHash.
2018-04-29T20:52:00.316-03:00| vthread-4| I125: Setting header path for 4.13.0-39-generic to "/lib/modules/4.13.0-39-generic/build/include".
2018-04-29T20:52:00.316-03:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-39-generic/build/include" for kernel release "4.13.0-39-generic".
2018-04-29T20:52:00.316-03:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-39-generic/build/include/linux/version.h
2018-04-29T20:52:00.316-03:00| vthread-4| I125: /lib/modules/4.13.0-39-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-29T20:52:00.316-03:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-04-29T20:52:00.343-03:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-39-generic".
2018-04-29T20:52:00.343-03:00| vthread-4| I125: The header path "/lib/modules/4.13.0-39-generic/build/include" for the kernel "4.13.0-39-generic" is valid. Whoohoo!
2018-04-29T20:52:01.136-03:00| vthread-4| I125: found symbol version file /lib/modules/4.13.0-39-generic/build/Module.symvers
2018-04-29T20:52:01.136-03:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.13.0-39-generic/build/Module.symvers.
2018-04-29T20:52:01.340-03:00| vthread-4| I125: Read 22206 symbol versions
2018-04-29T20:52:01.341-03:00| vthread-4| I125: Reading in info for the vmmon module.
2018-04-29T20:52:01.341-03:00| vthread-4| I125: Reading in info for the vmnet module.
2018-04-29T20:52:01.341-03:00| vthread-4| I125: Reading in info for the vmblock module.
2018-04-29T20:52:01.341-03:00| vthread-4| I125: Reading in info for the vmci module.
2018-04-29T20:52:01.341-03:00| vthread-4| I125: Reading in info for the vsock module.
2018-04-29T20:52:01.341-03:00| vthread-4| I125: Setting vsock to depend on vmci.
2018-04-29T20:52:01.341-03:00| vthread-4| I125: Invoking modinfo on "vmmon".
2018-04-29T20:52:01.350-03:00| vthread-4| I125: "/sbin/modinfo" exited with status 0.
2018-04-29T20:52:01.350-03:00| vthread-4| I125: Invoking modinfo on "vmnet".
2018-04-29T20:52:01.358-03:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2018-04-29T20:52:01.358-03:00| vthread-4| I125: Invoking modinfo on "vmblock".
2018-04-29T20:52:01.366-03:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2018-04-29T20:52:01.366-03:00| vthread-4| I125: Invoking modinfo on "vmci".
2018-04-29T20:52:01.373-03:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2018-04-29T20:52:01.373-03:00| vthread-4| I125: Invoking modinfo on "vsock".
2018-04-29T20:52:01.381-03:00| vthread-4| I125: "/sbin/modinfo" exited with status 0.
2018-04-29T20:52:01.482-03:00| vthread-4| I125: to be installed: vmnet status: 0
2018-04-29T20:52:01.611-03:00| vthread-4| I125: Obtaining info using the running kernel.
2018-04-29T20:52:01.611-03:00| vthread-4| I125: Setting header path for 4.13.0-39-generic to "/lib/modules/4.13.0-39-generic/build/include".
2018-04-29T20:52:01.611-03:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-39-generic/build/include" for kernel release "4.13.0-39-generic".
2018-04-29T20:52:01.611-03:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-39-generic/build/include/linux/version.h
2018-04-29T20:52:01.611-03:00| vthread-4| I125: /lib/modules/4.13.0-39-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-29T20:52:01.611-03:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-04-29T20:52:01.640-03:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-39-generic".
2018-04-29T20:52:01.640-03:00| vthread-4| I125: The header path "/lib/modules/4.13.0-39-generic/build/include" for the kernel "4.13.0-39-generic" is valid. Whoohoo!
2018-04-29T20:52:02.416-03:00| vthread-4| I125: found symbol version file /lib/modules/4.13.0-39-generic/build/Module.symvers
2018-04-29T20:52:02.416-03:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.13.0-39-generic/build/Module.symvers.
2018-04-29T20:52:02.611-03:00| vthread-4| I125: Read 22206 symbol versions
2018-04-29T20:52:02.612-03:00| vthread-4| I125: Kernel header path retrieved from FileEntry: /lib/modules/4.13.0-39-generic/build/include
2018-04-29T20:52:02.612-03:00| vthread-4| I125: Update kernel header path to /lib/modules/4.13.0-39-generic/build/include
2018-04-29T20:52:02.612-03:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-39-generic/build/include" for kernel release "4.13.0-39-generic".
2018-04-29T20:52:02.612-03:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-39-generic/build/include/linux/version.h
2018-04-29T20:52:02.612-03:00| vthread-4| I125: /lib/modules/4.13.0-39-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-29T20:52:02.612-03:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-04-29T20:52:02.642-03:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-39-generic".
2018-04-29T20:52:02.642-03:00| vthread-4| I125: The header path "/lib/modules/4.13.0-39-generic/build/include" for the kernel "4.13.0-39-generic" is valid. Whoohoo!
2018-04-29T20:52:02.647-03:00| vthread-4| I125: Found compiler at "/usr/bin/gcc"
2018-04-29T20:52:02.658-03:00| vthread-4| I125: Got gcc version "5.4.0".
2018-04-29T20:52:02.658-03:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-04-29T20:52:02.659-03:00| vthread-4| I125: Using user supplied compiler "/usr/bin/gcc".
2018-04-29T20:52:02.671-03:00| vthread-4| I125: Got gcc version "5.4.0".
2018-04-29T20:52:02.671-03:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-04-29T20:52:02.678-03:00| vthread-4| I125: Trying to find a suitable PBM set for kernel "4.13.0-39-generic".
2018-04-29T20:52:02.679-03:00| vthread-4| I125: No matching PBM set was found for kernel "4.13.0-39-generic".
2018-04-29T20:52:02.679-03:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-04-29T20:52:02.680-03:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-39-generic/build/include" for kernel release "4.13.0-39-generic".
2018-04-29T20:52:02.680-03:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-39-generic/build/include/linux/version.h
2018-04-29T20:52:02.680-03:00| vthread-4| I125: /lib/modules/4.13.0-39-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-29T20:52:02.680-03:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-04-29T20:52:02.709-03:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-39-generic".
2018-04-29T20:52:02.709-03:00| vthread-4| I125: The header path "/lib/modules/4.13.0-39-generic/build/include" for the kernel "4.13.0-39-generic" is valid. Whoohoo!
2018-04-29T20:52:02.717-03:00| vthread-4| I125: The GCC version matches the kernel GCC minor version like a glove.
2018-04-29T20:52:02.717-03:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-39-generic/build/include" for kernel release "4.13.0-39-generic".
2018-04-29T20:52:02.717-03:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-39-generic/build/include/linux/version.h
2018-04-29T20:52:02.717-03:00| vthread-4| I125: /lib/modules/4.13.0-39-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-29T20:52:02.717-03:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-04-29T20:52:02.746-03:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-39-generic".
2018-04-29T20:52:02.746-03:00| vthread-4| I125: The header path "/lib/modules/4.13.0-39-generic/build/include" for the kernel "4.13.0-39-generic" is valid. Whoohoo!
2018-04-29T20:52:02.746-03:00| vthread-4| I125: Using temp dir "/tmp".
2018-04-29T20:52:02.753-03:00| vthread-4| I125: Obtaining info using the running kernel.
2018-04-29T20:52:02.753-03:00| vthread-4| I125: Setting header path for 4.13.0-39-generic to "/lib/modules/4.13.0-39-generic/build/include".
2018-04-29T20:52:02.754-03:00| vthread-4| I125: Validating path "/lib/modules/4.13.0-39-generic/build/include" for kernel release "4.13.0-39-generic".
2018-04-29T20:52:02.754-03:00| vthread-4| I125: Failed to find /lib/modules/4.13.0-39-generic/build/include/linux/version.h
2018-04-29T20:52:02.754-03:00| vthread-4| I125: /lib/modules/4.13.0-39-generic/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
2018-04-29T20:52:02.754-03:00| vthread-4| I125: using /usr/bin/gcc for preprocess check
2018-04-29T20:52:02.782-03:00| vthread-4| I125: Preprocessed UTS_RELEASE, got value "4.13.0-39-generic".
2018-04-29T20:52:02.783-03:00| vthread-4| I125: The header path "/lib/modules/4.13.0-39-generic/build/include" for the kernel "4.13.0-39-generic" is valid. Whoohoo!
2018-04-29T20:52:03.549-03:00| vthread-4| I125: found symbol version file /lib/modules/4.13.0-39-generic/build/Module.symvers
2018-04-29T20:52:03.549-03:00| vthread-4| I125: Reading symbol versions from /lib/modules/4.13.0-39-generic/build/Module.symvers.
2018-04-29T20:52:03.749-03:00| vthread-4| I125: Read 22206 symbol versions
2018-04-29T20:52:03.749-03:00| vthread-4| I125: Invoking modinfo on "vmnet".
2018-04-29T20:52:03.768-03:00| vthread-4| I125: "/sbin/modinfo" exited with status 256.
2018-04-29T20:52:06.542-03:00| vthread-4| I125: Setting destination path for vmnet to "/lib/modules/4.13.0-39-generic/misc/vmnet.ko".
2018-04-29T20:52:06.542-03:00| vthread-4| I125: Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
2018-04-29T20:52:06.570-03:00| vthread-4| I125: Successfully extracted the vmnet source.
2018-04-29T20:52:06.572-03:00| vthread-4| I125: Building module with command "/usr/bin/make -j2 -C /tmp/modconfig-JMyyFq/vmnet-only auto-build HEADER_DIR=/lib/modules/4.13.0-39-generic/build/include CC=/usr/bin/gcc IS_GCC_3=no"
2018-04-29T20:52:34.693-03:00| vthread-4| W115: Failed to build vmnet. Failed to execute the build command.

Eu não faço ideia do que possa ser e peço a ajuda de vocês...



  


2. Re: Não consigo executar o VMWare Player no Linux Mint

Fabio
enoc

(usa Fedora)

Enviado em 17/05/2018 - 12:13h

eu estava com esse erro no fedora 28 no kernel 4.16.8
arrumei assim
baixa o modulo em https://github.com/mkubecek/vmware-host-modules em clone or Download no formato zip
descompacta o arquivo
entre na pasta
usa o comando make
depois make install
reinicia o pc

para mim fico tudo ok.

Boa sorte


3. Re: Não consigo executar o VMWare Player no Linux Mint

Keity Melo
krafidhi

(usa Ubuntu)

Enviado em 18/05/2018 - 07:38h

enoc escreveu:

eu estava com esse erro no fedora 28 no kernel 4.16.8
arrumei assim
baixa o modulo em https://github.com/mkubecek/vmware-host-modules em clone or Download no formato zip
descompacta o arquivo
entre na pasta
usa o comando make
depois make install
reinicia o pc

para mim fico tudo ok.

Boa sorte


Oi, obrigada por responder. Eu baixei e naveguei até a pasta já descompactada com o terminal, dei o comando make mas diz que o comando não existe. Se vc puder me explicar mais detalhadamente vai ajudar muito. Desculpa a ignorância, é que eu entendo muito pouco de comandos, ainda tô aprendendo Linux e fico perdida muitas vezes...


4. Re: Não consigo executar o VMWare Player no Linux Mint

Fabio
enoc

(usa Fedora)

Enviado em 08/06/2018 - 20:31h

vc tem que instalarr o make o gcc

assim

https://www.youtube.com/watch?v=i-ZY0puWdR4






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts