Problema com BOOT UEFI [RESOLVIDO]

1. Problema com BOOT UEFI [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 18/08/2019 - 11:52h

Boas a todos.
Passei alguns anos sem usar computador, comprei um notebook samsung i3 com 4GB ram e 1 TB hd.
Veio com o Windows 10. Tentei instalar o ubuntu e nada de dar boot pelo pendrive, mudei para o debian, depois de mexerna bios por diversas vezes consegui o boot e instalei o debian 10 xfce.
Droga, muito ruim....
baixei o Mint e coloquei no pendrive mas não consigo dar boot pelo pendrive, mudei a ordem para o pendrive, desabilitei o label debian e só vai para o hd, se tirar o boot protection mostra tela vermelha, 1 dia e meio tentando (e olha que não sou facil de desistir), como passei muito tempo sem usar Linux, esse UEFI está me dando dor de cabeça.
no Terminal tentei efibootmgr e desabilitei o debian e removi o do windows e só tenho opção de iniciar pelo hd, como posso remover esse debian e bootart pelo pendrive pelo amor de Deus...

grato.


  


2. Re: Problema com BOOT UEFI [RESOLVIDO]

Ryuk Shinigami
Ryuk

(usa Nenhuma)

Enviado em 18/08/2019 - 12:35h

Se puder tirar umas fotos da tela UEFI, ajudaria a entender.
Mostre também como está o particionamento do HD.




3. Re: Problema com BOOT UEFI [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 18/08/2019 - 13:48h

Sou leigo.
Não tenho como tirar screenshots da BIOS.
Andei vendo na Net sobre gpt partições, eu criei com o gparted, mas quando uso o de para gravar a ISO, é sobrescrito e a partição gpt não aparece.
Já tentei de tudo, meus conhecimentos já não dá para avançar...
Eu só quero iniciar pelo pendrive, só isso!!!!
O noite priority da BIOS, após salvar e reiniciar volta para o Debian, algo tá errado com a BIOS, ele não salva...


4. Re: Problema com BOOT UEFI [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 18/08/2019 - 13:53h

Corrigindo texto...

dd
Quando uso o dd para gravar a ISO ele perde a partição gpt.

BIOS
Priority boot não salva o pendrive, fica só no Debian, por isso que não dá boot pelo pendrive.
Tem uma opção para fuderrr com o HD não???
Quero ver se a porrada do boot vai reconhecer o Debian e entrar. Não sei como fazer isso senão faria.
Tô já jogando esse notebook no lixo de tanta raiva.


5. Re: Problema com BOOT UEFI [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 18/08/2019 - 15:24h


Até certo tempo atrás o dd me atendia, hoje também dá erro, então... seguuinte:

Se conseguir fazer (se tiver como usar um LiveCD)...

1. Crie uma partição mbr no pendrive, algo do tipo:

# cfdisk -z /dev/dispositivo 


Aí tu escolhe o MBR, cria uma nova partição (só cria não precisa formatar) e após salvar, saia do CFDISK e execute:

# dd if=camino-da-imagem.iso of=/dev/dispositivo bs=8M; sync 


Reinicie o PC e veja se ao menos tens acesso ao instalador.

* como aqui tem dado erro ao rodar o DD em pendrive com tabela GPT, uso o Rufus no Windows 10.




6. Re: Problema com BOOT UEFI [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 18/08/2019 - 16:13h

Já pesquisei no Google, o dd sobrescrever a partição removendo o gpt, pelo dd não é possível.
Estou buscando outras soluções.
Se alguém souber deixa a dica aí.
Grato.


7. Re: Problema com BOOT UEFI [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 19/08/2019 - 15:05h

consegui
Tive de instalar o VirtualBox (que não foi nada fácil no Debian 10, o mesmo é incompatível).
Bom, continuando, criei uma máquina virtual com a ISO do Windows 10, baixei o Rufus e criei o pendrive GPT.
Funcionou 100%.
Só que é uma solução Windows, no Linux (pelo menos com o Debian 10) não encontrei solução para criar pendrive com partição GPT para usar em BIOS com UEFI. Todos que prometem removem a partição GPT e gravam em média. Não adianta em nada.




8. Re: Problema com BOOT UEFI [RESOLVIDO]

Robson Dantas
rdaguiar

(usa Debian)

Enviado em 19/08/2019 - 15:13h

Corrigindo:

Todos que prometem removem a partição GPT e gravam em msdos. Não adianta em nada.



9. Re: Mudar de DEBIAN para UBUNTU (UEFI)

Patrick
Freud_Tux

(usa Outra)

Enviado em 19/08/2019 - 19:54h

edps escreveu:


Até certo tempo atrás o dd me atendia, hoje também dá erro, então... seguuinte:

Se conseguir fazer (se tiver como usar um LiveCD)...

1. Crie uma partição mbr no pendrive, algo do tipo:

# cfdisk -z /dev/dispositivo 


Aí tu escolhe o MBR, cria uma nova partição (só cria não precisa formatar) e após salvar, saia do CFDISK e execute:

# dd if=camino-da-imagem.iso of=/dev/dispositivo bs=8M; sync 


Reinicie o PC e veja se ao menos tens acesso ao instalador.

* como aqui tem dado erro ao rodar o DD em pendrive com tabela GPT, uso o Rufus no Windows 10.



Edps!
Mas se é UEFI, não adianta nada jogar uma MBR, que não rola.
Salvo alguns casos, onde o fabricante faz um UEFI com modo de compatibilidade a MBR. O meu falecido notebook asus era assim. Só mostrava opções e boot UEFI, se a imagem do boot(gravada em cd, dvd, pendrive, cartão de memória...) fosse 64 bits e com suporte ao UEFI, ai, ele habilitava a opção de boot por UEFI.
Já alguns outros, permitem desativar o UEFI e usar uma emulação do BIOS. Digo emulação, pois, literalmente o BIOS é emulado dentro do UEFI.

rdaguiar escreveu:

Corrigindo:

Todos que prometem removem a partição GPT e gravam em msdos. Não adianta em nada.


Bem vindo ao clube hehehe.
Tem um que vem no linux mint (o Clodoaldo sabe o nome), que falam que grava via UEFI e GPT e o multibootusb ( http://multibootusb.org/ ), como pode ver, não tem criptografia na página desse projeto, use por sua conta e risco.
Todos que testei, também não funcionam, não testei o multibootusb.

Então pessoal!
Tem dois jeitos de fazer um pendrive bootável sem usar nenhum programa.
Claro, tem que criar a tabela de partição em GPT e formatar em FAT32.
O esquema do pendrive-cartão de memoria fica assim:

/dev/sdx - onde vai ficar a tabela de partição
/devsdx1 - onde vamos jogar a iso

1º Pelo Gnu/Linux:

A imagem iso, ou outra (img e etc...) não pode conter nenhum tipo de link ou link simbólico
Depois de baixar e conferir as hashs, descompacte a imagem baixada.
Espete e pendrive, e agora, basta copiar (tanto faz por modo texto ou usando um gerenciador de arquivos) o conteúdo para a partição /dev/sdx1. O contéudo, é toda a estrutura, tipo, isolinux, dists, readme, md5... Se copiar o diretório que foi criado ao descompactar, e dentro dele estiver os arquivos, não rola, tem que ser só os arquivos. Funcionou com o gparted
Se tiver links, você pode usar um rsync, que tem suporte a links, mas essa eu ainda não testei, por estar sem paciência mesmo.
O UEFI só entende FAT32 e NTFS, logo, não sei se copiar uma imagem com links para um pendrive em NTFS vá funcionar.

2º Pelo janelas do gates

Nada de usar qualquer tipo de programa.
Fiz um teste com o rufus e ele demorou quase 1 hora para copiar os arquivos de uma iso do debian 10 (3.6 GB) para o pendrive.Copiando foi mais rápido uns 20 minutos. Eo rufus, cria alguns arquivos que não sei bem para que servem,no final...
Basta baixara imagem, checar as hashs, descompactar com o 7zip. Espete o pendrive, já formatado em GPT e Fat32. Copie o conteúdo do diretório que o 7zip criou para o pendrive e pronto!
Vai funcionar que é uma beleza, pois, como o FAT é criado gates, rola uma compatibilidade e ele copia os arquivos com qualquer tipo de link, sem problemas.
E no final, temos um pendrive perfeito.
Só recomendo antes de darem boot, espetar em uma máquina com Gnu/Linux, verificarem o diretório oculto system information (ou é system volume information) e apagarem ele do pendrive.

T+





-------------------------------------------------------------------------------------------------------------------------------------------------
Noob: "[...]Sou muito noob ainda usando o terminal, então preciso de ajuda "mastigada", pra operá-lo."
zhushazang: "Sou velho e meus dentes desgastados. Estude linux www.guiafoca.org";


10. Re: Problema com BOOT UEFI [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 20/08/2019 - 19:23h


Freud_Tux escreveu:

Edps!
Mas se é UEFI, não adianta nada jogar uma MBR, que não rola.
Salvo alguns casos, onde o fabricante faz um UEFI com modo de compatibilidade a MBR. O meu falecido notebook asus era assim. Só mostrava opções e boot UEFI, se a imagem do boot(gravada em cd, dvd, pendrive, cartão de memória...) fosse 64 bits e com suporte ao UEFI, ai, ele habilitava a opção de boot por UEFI.
Já alguns outros, permitem desativar o UEFI e usar uma emulação do BIOS. Digo emulação, pois, literalmente o BIOS é emulado dentro do UEFI.
...


O que ocorre comigo não sei dizer, mas antes a mídia de instalação do Slackware quando gravada em pendrive (acho que a tabela de partição era MBR), apareciam 2 intens de inicialização quando eu teclava F8, a de UEFI e no padrão MBR, agora não mais.

O último teste que falta é eu jogar a iso numa partição FAT32 e ver se rola, a tabela é o GPT.

Quanto ao multiboot, vi que ele está disponível no SlackBuilds, vou instalar e testar também:

https://slackbuilds.org/repository/14.2/system/multibootusb/?search=multiboot



11. Re: Problema com BOOT UEFI [RESOLVIDO]

Patrick
Freud_Tux

(usa Outra)

Enviado em 20/08/2019 - 19:40h

edps escreveu:


Freud_Tux escreveu:

Edps!
Mas se é UEFI, não adianta nada jogar uma MBR, que não rola.
Salvo alguns casos, onde o fabricante faz um UEFI com modo de compatibilidade a MBR. O meu falecido notebook asus era assim. Só mostrava opções e boot UEFI, se a imagem do boot(gravada em cd, dvd, pendrive, cartão de memória...) fosse 64 bits e com suporte ao UEFI, ai, ele habilitava a opção de boot por UEFI.
Já alguns outros, permitem desativar o UEFI e usar uma emulação do BIOS. Digo emulação, pois, literalmente o BIOS é emulado dentro do UEFI.
...


O que ocorre comigo não sei dizer, mas antes a mídia de instalação do Slackware quando gravada em pendrive (acho que a tabela de partição era MBR), apareciam 2 intens de inicialização quando eu teclava F8, a de UEFI e no padrão MBR, agora não mais.

O último teste que falta é eu jogar a iso numa partição FAT32 e ver se rola, a tabela é o GPT.

Quanto ao multiboot, vi que ele está disponível no SlackBuilds, vou instalar e testar também:

https://slackbuilds.org/repository/14.2/system/multibootusb/?search=multiboot


O "BIOS" (coloquei entre aspas, pois desde lá 2006-2008 não vem mais BIOS puro, já vem o UEFI emulando o BIOS, mas em um modo de compatibilidade total, foi divido em 3 classes - se não me falha a memória - e o de terceira classe não vai mais emular o BIOS ai, já devia ser um UEFI mexido pelo fabricante da placa mãe, algo semelhante ao que era o do meu falecido Asus.
O seu de agora deve ser uma versão que ainda deve emular o BIOS, mas jogando pra modo legado (legacy).

Eu só não testei o multibootusb, pois, na pressa, não reparei que o download era jogado pro Github:

http://multibootusb.org/page_download/

Mas, não é melhor compilar direto o pacote .tar.gz ai no Slackware?
Pro Debian temporário, vou ter que compilar (><)

T+

-------------------------------------------------------------------------------------------------------------------------------------------------
Noob: "[...]Sou muito noob ainda usando o terminal, então preciso de ajuda "mastigada", pra operá-lo."
zhushazang: "Sou velho e meus dentes desgastados. Estude linux www.guiafoca.org";


12. Re: Problema com BOOT UEFI [RESOLVIDO]

edps
edps

(usa Slackware)

Enviado em 20/08/2019 - 20:53h


tá phooda!

formatei o pendrive:

$ sudo mkfs.vfat -F 32 -n MINIDISK -c /dev/sde1 


Copiei na primeira tentativa a iso do Debian Buster e na segunda a do Slack Current, ambas as vezes um item foi adicdionado na tela de seleção ao teclar F8, mas ao teclar ENTER sou levado ao SETUP da máquina.

Agora estou compilando esse multibootusb no Slack Current pra ver no que vai dar.



01 02 03



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts