Caixas de som não funcionam, mas headset funciona

1. Caixas de som não funcionam, mas headset funciona

Tiago de Souza Ribeiro
TiagoSouza

(usa Arch Linux)

Enviado em 20/02/2012 - 17:34h

Olá, eu usava windows xp antes de migrar para o ubuntu 10.10, e nele, tanto minhas caixas de som, quanto meu headset funcionavam normal, em conjunto. Eu uso o headset ligado na parte traseira do pc, pq a porta de entrada de áudio da frente está com problema, e a caixa de som é ligada na porta de saída na frente. Mas apenas o headset funciona, as caixas de som não são detectadas no ubuntu... Pensei que poderia ser o driver, mas está estranha a coisa aqui: no windows, ao instalar o driver de áudio, surgia um aplicativo VIA High Definition Audio onde era possível controlar algumas configurações de áudio, e eu achei que minhas caixas de som usavam driver da VIA, mas no ubuntu, ao usar o comando lspci, o resultado é o seguinte:

Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)

Procurei por driver desse modelo ae, mas não achei para linux, e não sei qual era exatamente o driver da VIA que era usado no windows, então não tem como eu procurar por ele.
Alguém pode me ajudar a fazer as caixas de som funcionarem normalmente juntamente com o headset? Lembrando que só posso usar o headset na parte traseira do pc por a porta de entrada de áudio dianteira estar com problemas.

No aguardo por respostas, obrigado! :D


  


2. Placa Mãe

Francisco Raimundo da Silva
chimico

(usa aptosid)

Enviado em 20/02/2012 - 17:52h

TsouzaR

As vezes tenho problema parecido, mas com apenas uma saída de áudio, que é uma placa integrada da VIA. Eu resolvo isso pegando um cotonete, removendo boa parte do algodão e colocando este no orifício da saída de áudio, e começo a girar apenas para um lado para remover a poeira que pode estar gerando mau contato. SE você girar em duas direções, o algodão se desprende dento da saída de áudio, aí você terá outro problema ao invés de solucioná-lo. Após a limpeza teste e veja se funciona. Caso não funcione rode o seguinte comando e cole aqui:

lspci -n


3. Re: Caixas de som não funcionam, mas headset funciona

Tiago de Souza Ribeiro
TiagoSouza

(usa Arch Linux)

Enviado em 20/02/2012 - 18:02h

Olá, não é problema com sujeira, pois no windows xp em dual boot aqui funcionam os dois normalmente.
Aqui o resultado do lspci -n:
00:00.0 0600: 8086:29c0 (rev 10)
00:02.0 0300: 8086:29c2 (rev 10)
00:1b.0 0403: 8086:27d8 (rev 01)
00:1c.0 0604: 8086:27d0 (rev 01)
00:1d.0 0c03: 8086:27c8 (rev 01)
00:1d.1 0c03: 8086:27c9 (rev 01)
00:1d.2 0c03: 8086:27ca (rev 01)
00:1d.3 0c03: 8086:27cb (rev 01)
00:1d.7 0c03: 8086:27cc (rev 01)
00:1e.0 0604: 8086:244e (rev e1)
00:1f.0 0601: 8086:27b8 (rev 01)
00:1f.1 0101: 8086:27df (rev 01)
00:1f.2 0101: 8086:27c0 (rev 01)
00:1f.3 0c05: 8086:27da (rev 01)
01:00.0 0200: 1969:2048 (rev a0)
02:02.0 0280: 1814:0301

O que pode ser?


4. Re: Caixas de som não funcionam, mas headset funciona

Francisco Raimundo da Silva
chimico

(usa aptosid)

Enviado em 20/02/2012 - 19:04h

@ TsouzaR

Eu lhe pedi a saída de 'lspci -n' porque há um site que verifica a saída deste comando e associa a um módulo do kernel. O site é este:

http://kmuto.jp/debian/hcl/

Veja o resultado:

PCI ID Works? Vendor Device Driver Kernel
808629c0 Yes Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller intel-agp
808629c2 Yes Intel Corporation 82G33/G31 Express Integrated Graphics Controller i915 v2.6.32-
808627d8 Yes Intel Corporation N10/ICH 7 Family High Definition Audio Controller snd-hda-intel v3.1.0-
808627d0 Intel Corporation N10/ICH 7 Family PCI Express Port 1
808627c8 Intel Corporation N10/ICH 7 Family USB UHCI Controller #1
808627c9 Intel Corporation N10/ICH 7 Family USB UHCI Controller #2
808627ca Intel Corporation N10/ICH 7 Family USB UHCI Controller #3
808627cb Intel Corporation N10/ICH 7 Family USB UHCI Controller #4
808627cc Intel Corporation N10/ICH 7 Family USB2 EHCI Controller
8086244e Yes Intel Corporation 82801 PCI Bridge i810_rng
808627b8 Yes Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge intel-rng,iTCO_wdt,leds-ss4200 v2.6.25-
808627df Yes Intel Corporation 82801G (ICH7 Family) IDE Controller ata_piix v2.6.25-
808627c0 Yes Intel Corporation N10/ICH7 Family SATA Controller [IDE mode] ata_piix v2.6.25-
808627da Yes Intel Corporation N10/ICH 7 Family SMBus Controller i2c-i801 v2.6.25-
19692048 Yes Atheros Communications Inc. L2 Fast Ethernet atl2 v2.6.29-
18140301 Yes Ralink corp. RT2561/RT61 802.11g PCI rt61pci v2.6.25-

Se você verificar na terceira linha, o driver da sua placa de som da Intel é o módulo 'snd-hda-intel'. Verifique se ele está sendo carregado no boot com 'lsmod | sort' , caso não esteja, adicione a /etc/modules e reinicie. Se não quiser reiniciar, rode o comando 'sudo modprobe snd-hda-intel'. Para você ter uma idéia, este módulo carrega na minha instalação que não tem nenhum hardware da Intel, logo o suporte existe, é necessário intervir nestes casos. Qualquer problema posta novamente.


5. Re: Caixas de som não funcionam, mas headset funciona

Tiago de Souza Ribeiro
TiagoSouza

(usa Arch Linux)

Enviado em 20/02/2012 - 19:08h

Esse módulo já está na inicialização, ao usar o comando, uma das linhas era a seguinte:

snd_hda_intel 22107 2

E esse mesmo módulo snd_hda_intel era citado em vários outros...


6. Re: Caixas de som não funcionam, mas headset funciona

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 20/02/2012 - 19:22h

-va em controle de som e configure a saida de som do seu pc


7. Re: Caixas de som não funcionam, mas headset funciona

Francisco Raimundo da Silva
chimico

(usa aptosid)

Enviado em 20/02/2012 - 19:26h

Verifica se há como configurar duas placas de som no painel de controle do GNOME (você usa Ubuntu). No KDE4, eu sei que é possível configurar quantas placas de som tiver, agora no GNOME não sei.
Veja estas dicas:

http://www.vivaolinux.com.br/dica/Como-configurar-2-placas-de-som-no-Ubuntu
http://www.htmlstaff.org/ver.php?id=21429



8. Re: Caixas de som não funcionam, mas headset funciona

Tiago de Souza Ribeiro
TiagoSouza

(usa Arch Linux)

Enviado em 20/02/2012 - 19:38h

clodoaldops: nas configurações de áudio do ubuntu, apenas aparece o meu headset, nem rastro das caixas de som.
chimico: não tem como adicionar não, ao menos não vi nada de adicionar nas configurações de áudio do ubuntu. E tentei seguir os links que você passou, mas nenhum dos dois resolveu nada, no primeiro, ao tentar instalar o libesd-alsa0, diz que o pacote não está disponível mas é referenciado por outro pacote, e que libesd-alsa0 não tem candidato para instalação, já no segundo link, consegui até instalar o asoundconf-gtk, mas quando tento usar o comando asoundconf list, diz que o comando asoundconf não existe.

Alguma outra solução? :(

Ah, uma coisa aqui sobre esse asoundconf-gtk, eu digitei asoundconf-gtk no terminal, só pra testar, e ele disse que /usr/bin/asoundconf não existe :s


9. Re: Caixas de som não funcionam, mas headset funciona

Roger
rootgerr

(usa Slackware)

Enviado em 20/02/2012 - 19:55h

Abra um terminal e digite:

$sudo alsamixer


Depois verifique os "canais" apresentados e suba o volume com a tecla direcional "cima", se por ventura algum deles conter a notação MM, significa que está em "mute", pressione a tecla "M" quando o mesmo estiver selecionado para liberar.

Quando terminar digite:

$sudo alsactl store para salvar



10. Re: Caixas de som não funcionam, mas headset funciona

Tiago de Souza Ribeiro
TiagoSouza

(usa Arch Linux)

Enviado em 20/02/2012 - 20:09h

rootgerr: não adiantou, a caixa agora tá até chiando um pouco, barulho normal de caixa ligada em volume máximo, mas não consigo ouvir áudio nenhum ainda, e no headset tá normal...


11. Re: Caixas de som não funcionam, mas headset funciona

Roger
rootgerr

(usa Slackware)

Enviado em 20/02/2012 - 20:16h

Ok, mas você, está desconectando o headset antes de testar as caixas?


12. Re: Caixas de som não funcionam, mas headset funciona

Tiago de Souza Ribeiro
TiagoSouza

(usa Arch Linux)

Enviado em 20/02/2012 - 20:50h

Acabei de ver aqui, as caixas de som funcionam normal se eu conectá-las na parte traseira da cpu. Já sei então que o problema não é driver nem as caixas. Porém nem o headset, nem as caixas funcionam nas entradas dianteiras, e isso é só no linux, no windows funcionava normal tanto as traseiras quanto as frontais.

E agora? alguma sujestão?



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts