Removi o Samba e agora dá erro ao reinstalar

1. Removi o Samba e agora dá erro ao reinstalar

Bryan Buzzi
thebuzzi

(usa Debian)

Enviado em 23/02/2021 - 18:59h

Bom.. removi o samba para reinstalar e agora estou com problemas.
removi o samba com o comando
#sudo apt-get autoremove samba samba-common

E instalei novamente:
#apt-get install samba

então recebo o seguinte erro... não consegui solucionar sozinho por meio de pesquisas

[email protected]:/# apt-get install samba
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
The following additional packages will be installed:
attr ibverbs-providers libboost-regex1.67.0 libcephfs2 libgfapi0 libgfrpc0
libgfxdr0 libglusterfs0 libibverbs1 librados2 libtirpc-common libtirpc3
python-dnspython samba-vfs-modules tdb-tools
Pacotes sugeridos:
bind9 bind9utils ctdb ldb-tools ntp | chrony smbldap-tools ufw
Os NOVOS pacotes a seguir serão instalados:
attr ibverbs-providers libboost-regex1.67.0 libcephfs2 libgfapi0 libgfrpc0
libgfxdr0 libglusterfs0 libibverbs1 librados2 libtirpc-common libtirpc3
python-dnspython samba samba-vfs-modules tdb-tools
0 pacotes atualizados, 16 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 0 B/15,9 MB de arquivos.
Depois desta operação, 48,5 MB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
A seleccionar pacote anteriormente não seleccionado python-dnspython.
(Lendo banco de dados ... 129828 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../00-python-dnspython_1.16.0-1_all.deb ...
A descompactar python-dnspython (1.16.0-1) ...
A seleccionar pacote anteriormente não seleccionado tdb-tools.
A preparar para desempacotar .../01-tdb-tools_1.3.16-2+b1_amd64.deb ...
A descompactar tdb-tools (1.3.16-2+b1) ...
A seleccionar pacote anteriormente não seleccionado samba.
A preparar para desempacotar .../02-samba_2%3a4.9.5+dfsg-5+deb10u1_amd64.deb ...
A descompactar samba (2:4.9.5+dfsg-5+deb10u1) ...
A seleccionar pacote anteriormente não seleccionado attr.
A preparar para desempacotar .../03-attr_1%3a2.4.48-4_amd64.deb ...
A descompactar attr (1:2.4.48-4) ...
A seleccionar pacote anteriormente não seleccionado libibverbs1:amd64.
A preparar para desempacotar .../04-libibverbs1_22.1-1_amd64.deb ...
A descompactar libibverbs1:amd64 (22.1-1) ...
A seleccionar pacote anteriormente não seleccionado ibverbs-providers:amd64.
A preparar para desempacotar .../05-ibverbs-providers_22.1-1_amd64.deb ...
A descompactar ibverbs-providers:amd64 (22.1-1) ...
A seleccionar pacote anteriormente não seleccionado libboost-regex1.67.0:amd64.
A preparar para desempacotar .../06-libboost-regex1.67.0_1.67.0-13+deb10u1_amd64.deb ...
A descompactar libboost-regex1.67.0:amd64 (1.67.0-13+deb10u1) ...
A seleccionar pacote anteriormente não seleccionado librados2:amd64.
A preparar para desempacotar .../07-librados2_12.2.11+dfsg1-2.1+b1_amd64.deb ...
A descompactar librados2:amd64 (12.2.11+dfsg1-2.1+b1) ...
A seleccionar pacote anteriormente não seleccionado libcephfs2:amd64.
A preparar para desempacotar .../08-libcephfs2_12.2.11+dfsg1-2.1+b1_amd64.deb ...
A descompactar libcephfs2:amd64 (12.2.11+dfsg1-2.1+b1) ...
A seleccionar pacote anteriormente não seleccionado libtirpc-common.
A preparar para desempacotar .../09-libtirpc-common_1.1.4-0.4_all.deb ...
A descompactar libtirpc-common (1.1.4-0.4) ...
A seleccionar pacote anteriormente não seleccionado libtirpc3:amd64.
A preparar para desempacotar .../10-libtirpc3_1.1.4-0.4_amd64.deb ...
A descompactar libtirpc3:amd64 (1.1.4-0.4) ...
A seleccionar pacote anteriormente não seleccionado libglusterfs0:amd64.
A preparar para desempacotar .../11-libglusterfs0_5.5-3_amd64.deb ...
A descompactar libglusterfs0:amd64 (5.5-3) ...
A seleccionar pacote anteriormente não seleccionado libgfxdr0:amd64.
A preparar para desempacotar .../12-libgfxdr0_5.5-3_amd64.deb ...
A descompactar libgfxdr0:amd64 (5.5-3) ...
A seleccionar pacote anteriormente não seleccionado libgfrpc0:amd64.
A preparar para desempacotar .../13-libgfrpc0_5.5-3_amd64.deb ...
A descompactar libgfrpc0:amd64 (5.5-3) ...
A seleccionar pacote anteriormente não seleccionado libgfapi0:amd64.
A preparar para desempacotar .../14-libgfapi0_5.5-3_amd64.deb ...
A descompactar libgfapi0:amd64 (5.5-3) ...
A seleccionar pacote anteriormente não seleccionado samba-vfs-modules:amd64.
A preparar para desempacotar .../15-samba-vfs-modules_2%3a4.9.5+dfsg-5+deb10u1_amd64.deb ...
A descompactar samba-vfs-modules:amd64 (2:4.9.5+dfsg-5+deb10u1) ...
Configurando libibverbs1:amd64 (22.1-1) ...
Configurando libboost-regex1.67.0:amd64 (1.67.0-13+deb10u1) ...
Configurando ibverbs-providers:amd64 (22.1-1) ...
Configurando attr (1:2.4.48-4) ...
Configurando samba-vfs-modules:amd64 (2:4.9.5+dfsg-5+deb10u1) ...
Configurando libtirpc-common (1.1.4-0.4) ...
Configurando tdb-tools (1.3.16-2+b1) ...
update-alternatives: a usar /usr/bin/tdbbackup.tdbtools para disponibilizar /usr/bin/tdbbackup (tdbbackup) em modo auto
Configurando python-dnspython (1.16.0-1) ...
Configurando samba (2:4.9.5+dfsg-5+deb10u1) ...
Samba is being run as an AD Domain Controller: Masking smbd.service nmbd.service
Please ignore the following error about deb-systemd-helper not finding those services.
(smbd.service already masked)
(nmbd.service already masked)
Job for samba-ad-dc.service failed because the control process exited with error code.
See "systemctl status samba-ad-dc.service" and "journalctl -xe" for details.
invoke-rc.d: initscript samba-ad-dc, action "start" failed.
● samba-ad-dc.service - Samba AD Daemon
Loaded: loaded (/lib/systemd/system/samba-ad-dc.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2021-02-23 18:39:35 -03; 12ms ago
Docs: man:samba(8)
man:samba(7)
man:smb.conf(5)
Process: 10626 ExecStart=/usr/sbin/samba --foreground --no-process-group $SAMBAOPTIONS (code=exited, status=1/FAILURE)
Main PID: 10626 (code=exited, status=1/FAILURE)

fev 23 18:39:35 debian-jop samba[10631]: task[ldapsrv][10631]: [2021/02/23 18:39:35.316558, 0] ../source4/lib/tls/tls_tstream.c:1232(tstream_tls_params_server)
fev 23 18:39:35 debian-jop samba[10631]: task[ldapsrv][10631]: TLS failed to initialise cafile /var/lib/samba/private/tls/ca.pem - Error while reading file.
fev 23 18:39:35 debian-jop samba[10631]: task[ldapsrv][10631]: [2021/02/23 18:39:35.316632, 0] ../source4/ldap_server/ldap_server.c:1173(ldapsrv_task_init)
fev 23 18:39:35 debian-jop samba[10631]: task[ldapsrv][10631]: ldapsrv failed tstream_tls_params_server - NT_STATUS_CANT_ACCESS_DOMAIN_INFO
fev 23 18:39:35 debian-jop samba[10631]: task[ldapsrv][10631]: [2021/02/23 18:39:35.316704, 0] ../source4/smbd/service_task.c:36(task_server_terminate)
fev 23 18:39:35 debian-jop samba[10631]: task[ldapsrv][10631]: task_server_terminate: task_server_terminate: [Failed to startup ldap server task]
fev 23 18:39:35 debian-jop samba[10631]: task[ldapsrv][10631]: [2021/02/23 18:39:35.316862, 0] ../source4/smbd/process_standard.c:81(sigterm_signal_handler)
fev 23 18:39:35 debian-jop samba[10631]: task[ldapsrv][10631]: sigterm_signal_handler: Exiting pid 10631 on SIGTERM
fev 23 18:39:35 debian-jop systemd[1]: samba-ad-dc.service: Failed with result 'exit-code'.
fev 23 18:39:35 debian-jop systemd[1]: Failed to start Samba AD Daemon.
dpkg: erro ao processar o pacote samba (--configure):
o subprocesso instalado, do pacote samba, o script post-installation retornou erro do status de saída 1
Configurando libtirpc3:amd64 (1.1.4-0.4) ...
Configurando librados2:amd64 (12.2.11+dfsg1-2.1+b1) ...
Configurando libcephfs2:amd64 (12.2.11+dfsg1-2.1+b1) ...
Configurando libglusterfs0:amd64 (5.5-3) ...
Configurando libgfxdr0:amd64 (5.5-3) ...
Configurando libgfrpc0:amd64 (5.5-3) ...
Configurando libgfapi0:amd64 (5.5-3) ...
A processar 'triggers' para systemd (241-7~deb10u6) ...
A processar 'triggers' para man-db (2.8.5-2) ...
A processar 'triggers' para libc-bin (2.28-10) ...
Erros foram encontrados durante o processamento de:
samba
E: Sub-process /usr/bin/dpkg returned an error code (1)


Como proceder?


  


2. Re: Removi o Samba e agora dá erro ao reinstalar

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 23/02/2021 - 20:24h

a principio esse comando está errado

sudo apt-get autoremove samba samba-common 


então vamos ver o que vc realmente fez aí ... manda aí pra gente ver

apt list samba* 



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Resposta

Bryan Buzzi
thebuzzi

(usa Debian)

Enviado em 24/02/2021 - 09:04h

Mauriciodez escreveu:

a principio esse comando está errado

sudo apt-get autoremove samba samba-common 


então vamos ver o que vc realmente fez aí ... manda aí pra gente ver

apt list samba* 



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------



Fala amigo, corrigindo... utilizei apt-get autoremove samba
fiz também apt-get remove --purge samba

Isso foi o que me retornou com apt list samba

[email protected]:~# apt list samba
Listing... Pronto
samba/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed]
N: There is 1 additional version. Please use the '-a' switch to see it
[email protected]:~# apt list -a samba
Listing... Pronto
samba/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed]
samba/stable 2:4.9.5+dfsg-5 amd64





4. Re: Removi o Samba e agora dá erro ao reinstalar

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 24/02/2021 - 10:18h

Tente desativar o serviço
systemctl mask samba-ad-dc.service
E depois remover o samba


5. Re: Removi o Samba e agora dá erro ao reinstalar

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 24/02/2021 - 10:28h

thebuzzi escreveu:
[email protected]:~# apt list samba
Listing... Pronto
samba/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed]
N: There is 1 additional version. Please use the '-a' switch to see it
[email protected]:~# apt list -a samba
Listing... Pronto
samba/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed]
samba/stable 2:4.9.5+dfsg-5 amd64



olha só ... no linux dar os comando corretamente é muito importante ... olha só .. te falei para dar esse comando
apt list samba* 
vc deu
apt list samba 
.. o asterisco serve para listar qualquer coisa depois de 'samba' ... nesse caso não interferiu em nada mas fica de alerta .

enfim


samba/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed]
samba/stable 2:4.9.5+dfsg-5 amd64


como vc pode ver aí vc tem duas versões do samba no repositório, uma está instalada e outra não .. então a grosso modo vc tem o samba instalado ainda !!!



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




6. Re: Removi o Samba e agora dá erro ao reinstalar

Bryan Buzzi
thebuzzi

(usa Debian)

Enviado em 24/02/2021 - 10:29h

leandropscardua escreveu:

Tente desativar o serviço
systemctl mask samba-ad-dc.service
E depois remover o samba


Desativei como você falou
#systemctl mask samba-ad-dc.service
#apt-get remove --purge samba

A remover samba (2:4.9.5+dfsg-5+deb10u1) ...
A processar 'triggers' para man-db (2.8.5-2) ...
A processar 'triggers' para libc-bin (2.28-10) ...
(Lendo banco de dados ... 130172 ficheiros e directórios actualmente instalados.)
A purgar os ficheiros de configuração para samba (2:4.9.5+dfsg-5+deb10u1) ...
dpkg: aviso: ao remover samba, o directório '/var/lib/samba/printers/x64' não estava vazio, por isso não foi removido
dpkg: aviso: ao remover samba, o directório '/var/lib/samba/printers/W32X86' não estava vazio, por isso não foi removido
A processar 'triggers' para systemd (241-7~deb10u6) ...
[email protected]:~# apt list -a samba
Listing... Pronto
samba/stable 2:4.9.5+dfsg-5+deb10u1 amd64
samba/stable 2:4.9.5+dfsg-5 amd64



7. Re: Removi o Samba e agora dá erro ao reinstalar

Bryan Buzzi
thebuzzi

(usa Debian)

Enviado em 24/02/2021 - 11:16h

Mauriciodez escreveu:

thebuzzi escreveu:
[email protected]:~# apt list samba
Listing... Pronto
samba/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed]
N: There is 1 additional version. Please use the '-a' switch to see it
[email protected]:~# apt list -a samba
Listing... Pronto
samba/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed]
samba/stable 2:4.9.5+dfsg-5 amd64



olha só ... no linux dar os comando corretamente é muito importante ... olha só .. te falei para dar esse comando
apt list samba* 
vc deu
apt list samba 
.. o asterisco serve para listar qualquer coisa depois de 'samba' ... nesse caso não interferiu em nada mas fica de alerta .

enfim


samba/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed]
samba/stable 2:4.9.5+dfsg-5 amd64


como vc pode ver aí vc tem duas versões do samba no repositório, uma está instalada e outra não .. então a grosso modo vc tem o samba instalado ainda !!!



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




Eu realmente esqueci do "*". Como faço para resolver esse problema entao?

Ai esta o apt list samba*

[email protected]:~# apt list samba
Listing... Pronto
samba/stable 2:4.9.5+dfsg-5+deb10u1 amd64
N: There is 1 additional version. Please use the '-a' switch to see it
[email protected]:~# apt list samba*
Listing... Pronto
samba-common-bin/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed,automatic]
samba-common/stable,now 2:4.9.5+dfsg-5+deb10u1 all [installed,automatic]
samba-dev/stable 2:4.9.5+dfsg-5+deb10u1 amd64
samba-dsdb-modules/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed,automatic]
samba-libs/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed,automatic]
samba-testsuite/stable 2:4.9.5+dfsg-5+deb10u1 amd64
samba-vfs-modules/stable,now 2:4.9.5+dfsg-5+deb10u1 amd64 [installed,auto-removable]
samba/stable 2:4.9.5+dfsg-5+deb10u1 amd64




8. Re: Removi o Samba e agora dá erro ao reinstalar

Marcos Fernandes
markirius

(usa Arch Linux)

Enviado em 24/02/2021 - 14:14h

ja tentou um:
sudo apt update
sudo apt install -f
sudo apt dist-upgrade
sudo apt install samba



9. Re: Removi o Samba e agora dá erro ao reinstalar

Bryan Buzzi
thebuzzi

(usa Debian)

Enviado em 24/02/2021 - 14:41h

markirius escreveu:

ja tentou um:
sudo apt update
sudo apt install -f
sudo apt dist-upgrade
sudo apt install samba


Tentei agora... me retornou o mesmo erro:
invoke-rc.d: initscript samba-ad-dc, action "start" failed.
● samba-ad-dc.service - Samba AD Daemon
Loaded: loaded (/lib/systemd/system/samba-ad-dc.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2021-02-24 14:40:00 -03; 20ms ago
Docs: man:samba(8)
man:samba(7)
man:smb.conf(5)
Process: 2404 ExecStart=/usr/sbin/samba --foreground --no-process-group $SAMBAOPTIONS (code=exited, status=1/FAILURE)
Main PID: 2404 (code=exited, status=1/FAILURE)

fev 24 14:40:00 debian-jop samba[2409]: task[ldapsrv][2409]: [2021/02/24 14:40:00.683465, 0] ../source4/lib/tls/tls_tstream.c:1232(tstream_tls_params_server)
fev 24 14:40:00 debian-jop samba[2409]: task[ldapsrv][2409]: TLS failed to initialise cafile /var/lib/samba/private/tls/ca.pem - Error while reading file.
fev 24 14:40:00 debian-jop samba[2409]: task[ldapsrv][2409]: [2021/02/24 14:40:00.683544, 0] ../source4/ldap_server/ldap_server.c:1173(ldapsrv_task_init)
fev 24 14:40:00 debian-jop samba[2409]: task[ldapsrv][2409]: ldapsrv failed tstream_tls_params_server - NT_STATUS_CANT_ACCESS_DOMAIN_INFO
fev 24 14:40:00 debian-jop samba[2409]: task[ldapsrv][2409]: [2021/02/24 14:40:00.683610, 0] ../source4/smbd/service_task.c:36(task_server_terminate)
fev 24 14:40:00 debian-jop samba[2409]: task[ldapsrv][2409]: task_server_terminate: task_server_terminate: [Failed to startup ldap server task]
fev 24 14:40:00 debian-jop samba[2409]: task[ldapsrv][2409]: [2021/02/24 14:40:00.683732, 0] ../source4/smbd/process_standard.c:81(sigterm_signal_handler)
fev 24 14:40:00 debian-jop samba[2409]: task[ldapsrv][2409]: sigterm_signal_handler: Exiting pid 2409 on SIGTERM
fev 24 14:40:00 debian-jop systemd[1]: samba-ad-dc.service: Failed with result 'exit-code'.
fev 24 14:40:00 debian-jop systemd[1]: Failed to start Samba AD Daemon.
dpkg: erro ao processar o pacote samba (--configure):
o subprocesso instalado, do pacote samba, o script post-installation retornou erro do status de saída 1
A processar 'triggers' para systemd (241-7~deb10u6) ...
A processar 'triggers' para man-db (2.8.5-2) ...
A processar 'triggers' para libc-bin (2.28-10) ...
Erros foram encontrados durante o processamento de:
samba
E: Sub-process /usr/bin/dpkg returned an error code (1)







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts