RAID 1 em HDs de 2TB [RESOLVIDO]

1. RAID 1 em HDs de 2TB [RESOLVIDO]

Marcelo Costa
marceloeng

(usa CentOS)

Enviado em 12/03/2013 - 12:44h

Olá,

Estou com um problema ao configurar RAID 1 via software. Utilizo o Ubuntu Server 10.04 x64.

Tenho um servidor com 2HDs de 2TB e pretendo utilizar RAID 1 (espelhamento).

Em cada HD, tenho 4 partições (Sistema, Home, Backup e Swap).

Na instalação, configurei o RAID da forma correta, mas não consigo ativar em nenhuma partição a flag de inicialização (boot flag). Com isso, o sistema não inicia.

Isso somente ocorre em HDs maiores que 1TB, pois em HDs de 1TB funciona ok


Alguém sabe como contornar esse problema?


Abraços,
Marcelo


  


2. Conseguiu Resolver?

Vinicius
pessotti5

(usa Ubuntu)

Enviado em 18/07/2013 - 10:15h

Olá marceloeng, gostaria de saber se você conseguiu resolver o problema, pois estou tendo um parecido aqui. Na Máquina Virtual com hds de 20 GB o Raid 1 Funciona perfeitamente, porem quando utilizo a CPU Real com 2 HDs de 2 TB o sistema só inicializa com o hd sda e sdb. Se retiro o sda ele não boota e fica reiniciando. Nem aparece o menu do grub. Já instalei o grub no /dev/sdb, (grub-install /dev/sdb ; update-grub /dev/sdb)sem sucesso.

Agradeço se puder ajudar.


3. Re: RAID 1 em HDs de 2TB [RESOLVIDO]

Marcelo Costa
marceloeng

(usa CentOS)

Enviado em 18/07/2013 - 10:34h

Olá,

Consegui resolver sim...É que coloquei essa questão em tantos lugares que esqueci de colocar a resposta no vivaolinux.

Esse problema ocorre pois em HDs de alta capacidade, o Ubuntu utiliza a tabela de partição GUID(GPT) ao invés da tradicional MBR e com isso, há uma pequena diferença na área de inicialização.

Com essa informação, criei uma partição de inicialização(bios_grub) com 32MB em cada HD. A estrutura ficou mais ou menos assim nos dois HDs:

partição 1: bios_grub (32MB) - Sem RAID
partição 2: \ (170GB) - RAID
partição 3: \home (950 GB) - RAID
partição 4: \Backup (850 GB) - RAID
partição 5: Swap (30 GB) - RAID

Com isso, a inicialização fica independente do RAID.

Há um tutorial (inglês) com imagens no seguinte endereço: http://stackful-dev.com/raid-install-ubuntu-server-on-a-large-hard-drive.html


Qualquer dúvida, dá um toque.

Abraço,
Marcelo


4. MUITO OBRIGADO

Péricles Guimarães Fortes
pgfortes

(usa Debian)

Enviado em 12/03/2014 - 17:15h

Muito obrigado marceloeng , depois de duas semanas quebrando a cabeça com sua dica consegui instalar com RAID.



5. Re: RAID 1 em HDs de 2TB [RESOLVIDO]

Marcelo Costa
marceloeng

(usa CentOS)

Enviado em 20/03/2014 - 12:41h

Legal...

Que bom que a informação ajudou.

Abraço,
Marcelo






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts