Erro ao conectar no AD Samba

1. Erro ao conectar no AD Samba

Jean Freitas
jeancesupa

(usa Debian)

Enviado em 20/10/2015 - 18:53h

Instalei o samba 4.1.13 com AD, DNS Bind9 e Kerberos.
Tudo funcionando.
Instalei o RSAT da Microsoft para poder configurar o AD, mas quando clico em Usuários e Computadores do Active Directory ocorre um erro " Não foi possível localizar informações de nomeação porque: Falha de Logon: nome de usuário desconhecido ou senha incorreta.
Me ajudem, please.


  


2. Re: Erro ao conectar no AD Samba

willian firmino
willian.firmino

(usa Slackware)

Enviado em 13/11/2015 - 16:52h

jeancesupa escreveu:

Instalei o samba 4.1.13 com AD, DNS Bind9 e Kerberos.
Tudo funcionando.
Instalei o RSAT da Microsoft para poder configurar o AD, mas quando clico em Usuários e Computadores do Active Directory ocorre um erro " Não foi possível localizar informações de nomeação porque: Falha de Logon: nome de usuário desconhecido ou senha incorreta.
Me ajudem, please.



Cara, estou com o mesmo problema, se resolver posta aqui por favor.



3. Re: Erro ao conectar no AD Samba

Carlos A. P. Cunha
Carlos_Cunha

(usa Arch Linux)

Enviado em 13/11/2015 - 18:52h

Primeira coisa vc esta usando uma versão do SAMBA 4, antiga , atualize para a 4.3.
Faça isso depois teste novamente.


#-------------------------------------------------------------------------------------#

"Linux é algo que me fez ter Gosto pela Informática, se tornou um Vicio" - Carlos A. P. Cunha


4. Re: Erro ao conectar no AD Samba

Jean Freitas
jeancesupa

(usa Debian)

Enviado em 13/11/2015 - 19:38h

Consegui corrigir, só q estou usando o samba 4.3.1 com o samba internal. Instale antes de tudo todas as dependências q o samba precisa conforme https://wiki.samba.org/index.php/Operating_system_requirements/Dependencies_-_Libraries_and_programs.


5. Re: Erro ao conectar no AD Samba

willian firmino
willian.firmino

(usa Slackware)

Enviado em 15/11/2015 - 11:50h

Preto_Cunha escreveu:

Primeira coisa vc esta usando uma versão do SAMBA 4, antiga , atualize para a 4.3.
Faça isso depois teste novamente.


#-------------------------------------------------------------------------------------#

"Linux é algo que me fez ter Gosto pela Informática, se tornou um Vicio" - Carlos A. P. Cunha



O meu já é a versão 4.3.1 e o erro de nomeação é: Sistema não operacional, engraçado q faço o login com o Administrator no domínio.



6. Re: Erro ao conectar no AD Samba

Jean Freitas
jeancesupa

(usa Debian)

Enviado em 15/11/2015 - 19:23h


O problema é no DNS. Qual VC está usando?


7. Re: Erro ao conectar no AD Samba

willian firmino
willian.firmino

(usa Slackware)

Enviado em 16/11/2015 - 08:43h

jeancesupa escreveu:


O problema é no DNS. Qual VC está usando?


Estou usando o BIND9 na mesma maquina, é o seguinte, na minha rede tenho um firewall linux que hoje faz papel de firewall, proxy, filter content, servidor DHCP e servidor DNS, e temos um servidor de arquivos samba com compartilhamento simples, como hoje estamos com + de 400 usuários vimos a necessidade de modificar esta infraestrutura, então estamos substituindo o firewall pelo PFSense, servidor de arquivos pelo samba4 configurando-o também como controlador de domínio, por isso configurei o DHCP e o BIND9 nesta máquina, então tem ideia do que pode ser?






8. Re: Erro ao conectar no AD Samba

Sergio Carlos Pagani
pagani

(usa Manjaro Linux)

Enviado em 16/11/2015 - 18:56h

A primeira coisa é verificar se localmente você consegue resolver os nomes. Verifique se as portas necessárias estão abertas no firewall. Abaixo coloco a relação de todas as portas que devem ser liberadas.

https://wiki.samba.org/index.php/Samba_AD_DC_port_usage




9. Re: Erro ao conectar no AD Samba

willian firmino
willian.firmino

(usa Slackware)

Enviado em 17/11/2015 - 15:05h

pagani escreveu:

A primeira coisa é verificar se localmente você consegue resolver os nomes. Verifique se as portas necessárias estão abertas no firewall. Abaixo coloco a relação de todas as portas que devem ser liberadas.

https://wiki.samba.org/index.php/Samba_AD_DC_port_usage



Em relação as portas abertas, eu desabilitei o firewalld e o selinux no centos 7 que onde esta minha instalação, muito estranho, estou fazendo testes que vejo na internet e tudo parece estar ok mas não funciona de jeito nenhum








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts