Sabayon querendo fazer Downgrades de pacotes [RESOLVIDO]

1. Sabayon querendo fazer Downgrades de pacotes [RESOLVIDO]

Maxwell
Ajaxguarany

(usa Slackware)

Enviado em 01/06/2018 - 14:46h

Atualizei alguns pacotes utilizando o portage, segui o passo a passo para configurar e poder utilizar o portage no sabayon. Inclusive em /etc/entropy/client.conf mudando de disable para enable "ignore-spm-downgrades = enable" .Agora o Entropy quer instalar pacotes da mesma versão que foram instalados pelo portage, e outros quer fazer Downgrades. Alguém poderia ajudar a solucionar esse problema:

sabayon /home/maxwell # equo u
╠ @@ Calculando Atualizações de Sistema:
╠ @@ Calculando dependências...
╠ ## [D] [spm-db->sabayon-weekly] dev-python/rdflib-4.2.2|0 [4.2.2|9999]
╠ ## [UR] [spm-db->sabayon-weekly] dev-python/certifi-2018.4.16|0 [2018.4.16|0]
╠ ## [UR] [spm-db->sabayon-weekly] dev-python/six-1.11.0|1 [1.11.0|1]
╠ ## [D] [spm-db->sabayon-weekly] dev-python/html5lib-0.999999999|2 [1.0.1|9999]
╠ ## [D] [spm-db->sabayon-weekly] dev-python/isodate-0.5.4|1 [0.6.0|9999]
╠ ## [UR] [spm-db->sabayon-weekly] dev-python/pyblake2-1.1.2|0 [1.1.2|0]
╠ ## [D] [spm-db->sabayon-weekly] sys-apps/portage-2.3.24-r1|0 [2.3.40|9999]
╠ ## [D] [spm-db->sabayon-weekly] media-libs/lv2-1.14.0-r1|0 [1.14.0-r1|9999]
╠ @@ Pacotes que precisam ser instalados/atualizados/rebaixados: 8
╠ @@ Pacotes que precisam ser removidos: 0
╠ @@ Tamanho de recebimento: 6.6MB
╠ @@ Espaço de disco liberado: 16.5MB
╠ @@ Você precisa de pelo menos: 1.5MB de espaço livre
╠ @@ Você precisa aceitar a licença abaixo:
╠ :: Licença: CC0-1.0, requisitado por:
╠ # [de:sabayon-weekly] dev-python/pyblake2-1.1.2
╠ Por favor, escolha uma opção
╠ (1) Ler a licença
╠ (2) Aceitar a licença (Eu já a li)
╠ (3) Aceitar a licença e não me pergunte mais (Eu já a li)
╠ (0) Sair
Sua escolha (digite um número e pressione enter): 0





  


2. MELHOR RESPOSTA

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 01/06/2018 - 20:16h

Ajaxguarany escreveu:
╠ ## [D] [spm-db->sabayon-weekly] dev-python/rdflib-4.2.2|0 [4.2.2|9999]
╠ ## [UR] [spm-db->sabayon-weekly] dev-python/certifi-2018.4.16|0 [2018.4.16|0]
╠ ## [UR] [spm-db->sabayon-weekly] dev-python/six-1.11.0|1 [1.11.0|1]
╠ ## [D] [spm-db->sabayon-weekly] dev-python/html5lib-0.999999999|2 [1.0.1|9999]
╠ ## [D] [spm-db->sabayon-weekly] dev-python/isodate-0.5.4|1 [0.6.0|9999]
╠ ## [UR] [spm-db->sabayon-weekly] dev-python/pyblake2-1.1.2|0 [1.1.2|0]
╠ ## [D] [spm-db->sabayon-weekly] sys-apps/portage-2.3.24-r1|0 [2.3.40|9999]
╠ ## [D] [spm-db->sabayon-weekly] media-libs/lv2-1.14.0-r1|0 [1.14.0-r1|9999]
╠ @@ Pacotes que precisam ser instalados/atualizados/rebaixados: 8


Acabo deolhar sua primeira mensagem..... de novo.pacotes com problemas são apenas 8....

o que eu tentaria? "forçava" a reinstalação e o downgrade:

# equo up && equo u -av 


vc ficaria com os mesmos pacotes, e agora apenas com portage e isodate dowgraded..... , depois eu forçava o upgrade do portage e do isodate com portage sem deps, assim:

# emerge -av --nodeps portage isodate 


Isso voltaria para as versões mais novas, só o portage e o isodate.....

agora tenta de novo:

#  equo u -av 


o problema deve sumir e aparecer "tudo atualizado".

sua mensagem 14,,,,

Seu Entropy É o MAIS NOVO E CORRETO, tanto no entropy como no portage.





¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.

3. Re: Sabayon querendo fazer Downgrades de pacotes [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 01/06/2018 - 15:41h

Tens que manter o portage e entropy em sincronia, então a cada coisa que você instalar pelo portage terá de "avisar" o entropy, assim:

 equo rescue spmsync --ask 



4. Re: Sabayon querendo fazer Downgrades de pacotes [RESOLVIDO]

Maxwell
Ajaxguarany

(usa Slackware)

Enviado em 01/06/2018 - 17:08h

pylm escreveu:

Tens que manter o portage e entropy em sincronia, então a cada coisa que você instalar pelo portage terá de "avisar" o entropy, assim:

 equo rescue spmsync --ask 


equo rescue spmsync --ask
╠ Nada para fazer
sabayon /home/maxwell # equo u
╠ @@ Calculando Atualizações de Sistema:
╠ @@ Calculando dependências...
╠ ## [D] [spm-db->sabayon-weekly] dev-python/isodate-0.5.4|1 [0.6.0|9999]
╠ ## [D] [spm-db->sabayon-weekly] media-libs/lv2-1.14.0-r1|0 [1.14.0-r1|9999]
╠ ## [D] [spm-db->sabayon-weekly] dev-python/rdflib-4.2.2|0 [4.2.2|9999]
╠ ## [UR] [spm-db->sabayon-weekly] dev-python/certifi-2018.4.16|0 [2018.4.16|0]
╠ ## [UR] [spm-db->sabayon-weekly] dev-python/six-1.11.0|1 [1.11.0|1]
╠ ## [D] [spm-db->sabayon-weekly] dev-python/html5lib-0.999999999|2 [1.0.1|9999]
╠ @@ Pacotes que precisam ser instalados/atualizados/rebaixados: 6
╠ @@ Pacotes que precisam ser removidos: 0
╠ @@ Tamanho de recebimento: 2.1MB
╠ @@ Espaço de disco liberado: 5.0MB
╠ @@ Você precisa de pelo menos: 14.0kB de espaço livre
╠ @@ Você precisa aceitar a licença abaixo:
╠ :: Licença: MPL-2.0, requisitado por:
╠ # [de:sabayon-weekly] dev-python/certifi-2018.4.16
╠ Por favor, escolha uma opção


Eu já tinha rodado o comando equo rescue spmsync anteriormente


5. Re: Sabayon querendo fazer Downgrades de pacotes

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 01/06/2018 - 17:18h

o problema é conhecido! Vc deve ter usado Portage em Sabayon, sem editar o arquivo /etc/entropy/client.conf
o sistema misturou entropy com portage.

Vc leu meu artigo sobre isso?

https://www.vivaolinux.com.br/dica/Usando-Portage-em-Sabayon-Linux-Metodo-Geral-Passo-a-Passo

veja também:

https://wiki.sabayon.org/index.php?title=HOWTO:_Safely_mix_Entropy_and_Portage

Observe que no seu caso, ele tá usando SPM downgrade e jogando os pacotes para o repositório weekly local, seu sistema tem agora Portage misturado com entropy

Tente isto:

edite o arquivo /etc/entropy/client.conf e procure pela linha: "Ignore SPM Pseudo Downgrades" e nela troque "disable" por "enable"....

a seguir, abra um terminal e execute:


# equo update --force
e SIMULE a atualização:
# equo -pv upgrade


só simule... ainda estão aparecendo downgrades? se sim, reporte aqui. Não rode a atualização ainda, só simule


¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


6. Re: Sabayon querendo fazer Downgrades de pacotes

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 01/06/2018 - 17:37h

Acabei de ver, vc disse que editou o client.conf.....

Por acaso, está usando repositório limbo ou sabayonlinux.org , junto com weekly? ou tentou instalar entropy com portage, ou vice versa? tipo:


# equo i -av portage
OU
# emerge -av equo entropy rigo


Poste as saídas destes comandos:


# equo repo list
# equo -s portage equo entropy rigo
# emerge -s portage equo entropy rigo
# cat /opt/sabayon-build/conf/intel/portage/00-sabayon-package.mask


Vejo que tem portage 2.3.40, esse é Portage do Gentoo, o do Sabayon é 2.3.24.
Pode ser que o 2.3.40 seja de outro SLOT ou exija profiles novos

Ao instalar deve ter usado emerge portage..... lembrou de usar opções sem deps, para não mudar o SLOT?

# emerge -av --oneshot --nodeps portage 


Sobre usar opção --nodeps, consulte:

https://forum.sabayon.org/viewtopic.php?f=76&t=32603
https://fusion809.github.io/package-management-on-sabayon/


Outras coisas que podem causar isso: vc usou opções de portage que são só para gentoo, como emerge com opções "world", ou revdep-rebuild?

outra coisa que vejo nas suas mensagens. varios de seus pacotes do Entropy, agora estão mascarados.

¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


7. Re: Sabayon querendo fazer Downgrades de pacotes [RESOLVIDO]

Maxwell
Ajaxguarany

(usa Slackware)

Enviado em 01/06/2018 - 18:21h

albfneto escreveu:

Acabei de ver, vc disse que editou o client.conf.....

Por acaso, está usando repositório limbo ou sabayonlinux.org , junto com weekly? ou tentou instalar entropy com portage, ou vice versa? tipo:


# equo i -av portage
OU
# emerge -av equo entropy rigo


Poste as saídas destes comandos:


# equo repo list
# equo -s portage equo entropy rigo
# emerge -s portage equo entropy rigo
# cat /opt/sabayon-build/conf/intel/portage/00-sabayon-package.mask


Outras coisas que podem causar isso: vc usou opções de portage que são só para gentoo, como emerge com opções "world", ou revdep-rebuild?

outra coisa que vejo nas suas mensagens. varios de seus pacotes do Entropy, agora estão mascarados.

¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


Sim, to usando os repo: sabayon-weekly e sabayon.linux.org juntos. Seria esse o problema?

equo repo list
* sabayon-weekly
Sabayon Linux Official Repository
sabayonlinux.org
Sabayon Linux Official Repository



8. Re: Sabayon querendo fazer Downgrades de pacotes

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 01/06/2018 - 18:38h

a priori, mais o limbo é que deveria dar problema com o weekly......

depois de checar a opção do client.conf e ver que está enable, continua o problema?

vamos testar uma coisa? SIMULE fazer downgrade do portage, só do portage, assim:

# emerge -pv =portage-2.3.24 


nessa simulação, (-p) observa que várias deps seriam downgraded?


e agora, com entropy?, simule:

# equo i -pv entropy equo rigo 


várias deps são modificadas?

......................................................................................................................................................

que perfil está ativo? (comando é "eselect profile list" )

.............................................................................................................................................................
saida dos outros comandos .... as versões entropy e portage estão diferentes? pacotes entropy estão masked? opção -s só procura, não instala nada


# equo -s portage equo entropy rigo
# emerge -s portage equo entropy rigo
# cat /opt/sabayon-build/conf/intel/portage/00-sabayon-package.mask


mais uma coisa, quando usou portage, editou o make.conf?
se sim, editou o make.conf correto? pq o do sabayon é /opt/sabayon-build/conf/intel/portage/make.conf.amd64 , pq no sabayon, o /etc/portage/make.conf é link simbólico.

............................................................................................................................................................................

estou atualizando o meu, e o meu está normal, mas estou com portage 24 e não o 40.


......................................................................................................................................................................................

ex. Numa de suas atualizações:

[spm-db->sabayon-weekly] dev-python/isodate-0.5.4|1 [0.6.0|9999]

Observe que vc tem isodate 0.6.0 e ele quer fazer downgrade para 0.5.4, pq tem aqueles 4 noves.... isso indica que seu pacote versão 0.6.0 do entropy tá mascarado!


¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


9. Re: Sabayon querendo fazer Downgrades de pacotes

Maxwell
Ajaxguarany

(usa Slackware)

Enviado em 01/06/2018 - 19:04h

albfneto escreveu:

a priori, mais o limbo é que deveria dar problema com o weekly......

depois de checar a opção do client.conf e ver que está enable, continua o problema?

vamos testar uma coisa? SIMULE fazer downgrade do portage, só do portage, assim:

# emerge -pv =portage-2.3.24 


nessa simulação, (-p) observa que várias deps seriam downgraded?

que perfil está ativo? (comando é "eselect profile list" )

saida dos outros comandos .... as versões entropy e portage estão diferentes? pacotes entropy estão masked? opção -s só procura, não instala nada


# equo -s portage equo entropy rigo
# emerge -s portage equo entropy rigo
# cat /opt/sabayon-build/conf/intel/portage/00-sabayon-package.mask


estou atualizando o meu, e o meu está normal, mas estou com portage 24 e não o 40.


¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


Sim, configurei o client conf:

# Ignore SPM (Portage) pseudo-downgrades
# USE AT YOUR OWN RISK, IF YOU DON'T KNOW WHAT'S THIS OPTION
# !!!!!!!!!!!!!!!!!! SKIP IT !!!!!!!!!!!!!!!!!!
# !!!!!!!!!!!!!!!!!! SKIP IT !!!!!!!!!!!!!!!!!!
# !!!!!!!!!!!!!!!!!! SKIP IT !!!!!!!!!!!!!!!!!!
# !!!!!!!!!!!!!!!!!! SKIP IT !!!!!!!!!!!!!!!!!!
# This option permits to skip packages with Entropy revision 9999
# from being treaten as downgrades. This usually happens when
# migrating from Portage to Entropy
# Valid parameters: disable, enable, true, false, disabled, enabled, 0, 1
# Default parameter if unset: disable
ignore-spm-downgrades = enable

Rodando o comando "equo repo list" só aparece os repo "sabayonlinux.org" e "sabayon-wekly" mas no diretório /etc/entropy/repositories.conf.d aparece o repo "sabayon-limbo"

/etc/entropy/repositories.conf.d/_entropy_sabayon-limbo
/etc/entropy/repositories.conf.d/_entropy_sabayon-limbo.example
/etc/entropy/repositories.conf.d/entropy_sabayonlinux.org
/etc/entropy/repositories.conf.d/entropy_sabayonlinux.org.example
/etc/entropy/repositories.conf.d/entropy_sabayon-weekly
/etc/entropy/repositories.conf.d/entropy_server.example


10. Re: Sabayon querendo fazer Downgrades de pacotes

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 01/06/2018 - 19:16h

Seu repo Limbo está inativo.... isso está indicado por aquela linha underline antes.

por isso não deveria dar problema....
Mas pq não experimenta por um momento inativar o Weekly e deixar só o sabayolinux.org? Isso pode ser feito na interface gráfica do rigo, ou com comando....

mas ainda acho que seu problema está na versão das deps do portage-2.3.40... o que dá se vc tenta simular downgrade só do pacote portage, assim mesmo com "-p" e sinal de igual?

# emerge -pv =portage-2.3.24 


as mensagens mostram um montão de dependências "voltando"?

Geralmente, só editar o client.conf e reatualizar já resolve, mas no seu caso parece que não.... para checar tudo, eu teria de estar no seu micro, mas dê uma olhada (com gerenciador de arquivos) na pasta

/opt/sabayon-build/conf/intel/portage/

o que vc tem dentro dos arquivos de extensão .mask ; . unmask e package.use

e em:

/opt/sabayon-build/conf/intel/repo/sabayonlinux.org/packages.db.mask

e /opt/sabayon-build/conf/intel/repo/weekly/packages.db.mask

?
Ou seja, vc tem mensagens de que seu sistema mascarou varios pacotes entropy.



¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


11. Re: Sabayon querendo fazer Downgrades de pacotes

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 01/06/2018 - 19:31h

o meu acaba de atualizar tudo OK, vou testar umas coisas no meu, sobre o portage e já volto....
vou tentar simular upgrade do portage ao 2.3.40 e ver como ficam as deps....

Já fiz a simulação... olha ele iria a portage 2.3.40, mas com apenas 3 pacotes novos que não estão no entropy... veja como ficaria:


emerge -pv --oneshot portage

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild N ] app-crypt/openpgp-keys-gentoo-release-20180530::gentoo 47 KiB
[ebuild N ] dev-python/bz2file-0.98::gentoo PYTHON_TARGETS="python2_7 -pypy" 12 KiB
[ebuild N ] app-portage/gemato-13.0::gentoo USE="blake2 bzip2 gpg -lzma -sha3 {-test} -tools" PYTHON_TARGETS="python2_7 python3_5 -pypy -python3_4 -python3_6" 66 KiB
[ebuild U ] sys-apps/portage-2.3.40::gentoo [2.3.24-r1::gentoo] USE="(ipc) native-extensions rsync-verify* xattr -build -doc -epydoc -gentoo-dev (-selinux)" PYTHON_TARGETS="python2_7 python3_5 -pypy -python3_4 -python3_6" 972 KiB

Total: 4 packages (1 upgrade, 3 new), Size of downloads: 1.095 KiB


veja, ele iria:
sys-apps/portage-2.3.40::gentoo [2.3.24-r1::gentoo]

ao mesmo portage seu, mas tudo indica não interação com o entropy... Parece que voltamos à "vaca fria", seu problema não parece ser na versão do portage....

tente mais uma coisa. tem pacote eix instalado? se não tiver cheque as versões do equo entropy e rigo, no entropy e no portage:


equo s entropy equo rigo
emerge -s entropy equo rigo


são diferentes as saídas? Esperado, sejam iguais e a versão mais nova é a 311.


¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


12. Re: Sabayon querendo fazer Downgrades de pacotes [RESOLVIDO]

Maxwell
Ajaxguarany

(usa Slackware)

Enviado em 01/06/2018 - 19:51h

albfneto escreveu:

Seu repo Limbo está inativo.... isso está indicado por aquela linha underline antes.

por isso não deveria dar problema....
Mas pq não experimenta por um momento inativar o Weekly e deixar só o sabayolinux.org? Isso pode ser feito na interface gráfica do rigo, ou com comando....

mas ainda acho que seu problema está na versão das deps do portage-2.3.40... o que dá se vc tenta simular downgrade só do pacote portage, assim mesmo com "-p" e sinal de igual?

# emerge -pv =portage-2.3.24 


as mensagens mostram um montão de dependências "voltando"?

Geralmente, só editar o client.conf e reatualizar já resolve, mas no seu caso parece que não.... para checar tudo, eu teria de estar no seu micro, mas dê uma olhada (com gerenciador de arquivos) na pasta

/opt/sabayon-build/conf/intel/portage/

o que vc tem dentro dos arquivos de extensão .mask ; . unmask e package.use

e em:

/opt/sabayon-build/conf/intel/repo/sabayonlinux.org/packages.db.mask

e /opt/sabayon-build/conf/intel/repo/weekly/packages.db.mask

?
Ou seja, vc tem mensagens de que seu sistema mascarou varios pacotes entropy.



¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.



sabayon /home/maxwell # USE=python_targets_python3_5 emerge -pv =portage-2.3.24-r1

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild UD ] dev-python/setuptools-36.7.2::gentoo [38.5.1::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4* python3_5 -pypy -pypy3 -python3_6" 0 KiB
[ebuild R ] dev-python/pyblake2-1.1.2::gentoo PYTHON_TARGETS="python2_7 python3_4* python3_5 -pypy -pypy3 -python3_6" 0 KiB
[ebuild R ] sys-apps/portage-2.3.24-r1::gentoo USE="(ipc) native-extensions xattr -build -doc -epydoc -gentoo-dev -rsync-verify (-selinux)" PYTHON_TARGETS="python2_7 python3_4* python3_5 -pypy -python3_6" 937 KiB

Total: 3 packages (1 downgrade, 2 reinstalls), Size of downloads: 937 KiB

!!! The following installed packages are masked:
- dev-lang/python-3.4.8-r1::gentoo (masked by: package.mask)
/etc/portage/package.mask/00-sabayon.package.mask:
# 2017-09-15 Joost Ruis: Prevent Python 3.4 downgrade

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.






01 02