Erro de idioma no Sabayon KDE plasma 5.12.1 [RESOLVIDO]

1. Erro de idioma no Sabayon KDE plasma 5.12.1 [RESOLVIDO]

felipe alexandre siqueira arcanjo
felipealexandre

(usa Sabayon)

Enviado em 23/02/2018 - 22:40h

Boa noite,

Alguém que usa Sabayon está com esse problema depois de algumas atualizações?

invalid filesystem encoding ANSI_X3.4-1968, must be UTF-8.
Make sure to set LC_ALL, LANG, LANGUAGE to valid UTF-8 values.
Please execute:
LC_ALL=en_US.UTF-8 /usr/bin/equo install plasma-desktop-5.12.0
Trying to force en_US.UTF-8.

Sempre que eu instalo um pacote essa mensagem aparece. Já executei o comando conforme sugerido e não tive sucesso.
Também Executei o comando locale como root e a saída foi a seguinte:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=pt_BR.UTF-8
LC_CTYPE="pt_BR.UTF-8"
LC_NUMERIC="pt_BR.UTF-8"
LC_TIME="pt_BR.UTF-8"
LC_COLLATE="pt_BR.UTF-8"
LC_MONETARY="pt_BR.UTF-8"
LC_MESSAGES="pt_BR.UTF-8"
LC_PAPER="pt_BR.UTF-8"
LC_NAME="pt_BR.UTF-8"
LC_ADDRESS="pt_BR.UTF-8"
LC_TELEPHONE="pt_BR.UTF-8"
LC_MEASUREMENT="pt_BR.UTF-8"
LC_IDENTIFICATION="pt_BR.UTF-8"
LC_ALL=

Também executei sudo LC_ALL=pt_BR.UTF-8 /usr/bin/equo upgrade e a saída do comando foi a seguinte:

invalid filesystem encoding ANSI_X3.4-1968, must be UTF-8.
Make sure to set LC_ALL, LANG, LANGUAGE to valid UTF-8 values.
Please execute:
LC_ALL=en_US.UTF-8 /usr/bin/equo upgrade
Trying to force en_US.UTF-8.
╠ @@ Calculating System Updates:
╠ @@ Nothing to update.
╠ @@ Nothing to remove.
╠ @@ Scanning configuration files to updatesh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
╠ @@ No configuration files to update.
☛ Há 2 bibliotecas preservadas no Sistema
╠ /usr/lib64/libgdbm.so.4.0.0 [libgdbm.so.4:2 -> sys-libs/gdbm-1.13-r2]
╠ /usr/lib64/libgdbm.so.4 [libgdbm.so.4:2 -> sys-libs/gdbm-1.13-r2]

Desde já agradeço!



  


2. Re: Erro de idioma no Sabayon KDE plasma 5.12.1 [RESOLVIDO]

Matheus
pylm

(usa Gentoo)

Enviado em 23/02/2018 - 22:44h

Tem cara de instalação cagada da glibc, tente reinstala-la.


3. Resolvido

felipe alexandre siqueira arcanjo
felipealexandre

(usa Sabayon)

Enviado em 23/02/2018 - 23:12h

pylm escreveu:

Tem cara de instalação cagada da glibc, tente reinstala-la.


Boa noite pylm!

Primeiramente obrigado pela dica e pela rapidez com que se dispôs a ajudar. Consegui resolver o problema seguindo as instruções contidas no link https://www.vivaolinux.com.br/dica/Alterando-o-idioma-do-Sabayon feito pelo Gabriel Henrique. Achei a solução após mudar minha forma de pensar ao procurar a solução do problema. :)