Wifi não funcionou no Debian 10 [RESOLVIDO]

1. Wifi não funcionou no Debian 10 [RESOLVIDO]

Alexandre China
xandechina

(usa Ubuntu)

Enviado em 25/08/2019 - 03:06h

Boa noite, gostaria de uma ajuda se possível, pois instalei o Debian 10 em meu notebook HP Probook 440G2 mas o mesmo não reconheceu a placa de rede wifi ficando sem o funcionamento da mesma.

Obs:. Antes eu tinha o Ubuntu instalado com tudo em funcionamento, mas gostaria de utilizar o Debian.

Aguardo ajuda e desde já agradeço.


Att. XandeChina.


  


2. Re: Wifi não funcionou no Debian 10

asdfg
ppa-DO_MAL

(usa Slackware)

Enviado em 25/08/2019 - 08:30h

provavelmente é por falta de firmware
vai no terminal como root e digita apt install firmware-linux-free ( depois reinicie )
se não funcionar digite nano /etc/apt/sources.list
e vejá se a linha

deb http://deb.debian.org/debian buster main <--- está assim,se estiver significa que está habilitado só os repositórios livres dodo debian

acrescente as palavras contrib non-free ficando assim

deb http://deb.debian.org/debian buster main contrib non-free

depois de um apt update && apt install firmware-linux

para entender melhor https://wiki.debian.org/pt_BR/SourcesList




3. Re: Wifi não funcionou no Debian 10 [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 25/08/2019 - 11:19h

Poste saída comando: lspci




4. Resposta lspci

Alexandre China
xandechina

(usa Ubuntu)

Enviado em 26/08/2019 - 02:01h

Boa noite, abaixo informo o resultado do comando lspci:



root@Alexandre:/home/alexandre# lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 2 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.6 Signal processing controller: Intel Corporation 8 Series Thermal (rev 04)
07:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
09:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
root@Alexandre:/home/alexandre#




Obs:. Já fiz os passos acima descritos pelo colega ppa-DO_MAL mas mesmo assim a placa wifi ainda não funcionou.

Agradeço se puderem continuar me ajudando.

Obrigado.

Att. XandeChina.




5. Wifi resolvido

Alexandre China
xandechina

(usa Ubuntu)

Enviado em 26/08/2019 - 03:24h

Boa noite pessoal, um amigo me repassou estas explicações do link abaixo e consegui resolver o problema da wifi.


https://linuxdicasesuporte.blogspot.com/2016/06/instalar-driver-wireless-no-debian.html


Agradeço a todos pelas explicações e disponibilidade em ajudar.

Linux na veia sempre!


Abraços.


Att. XandeChina.


6. Re: Wifi não funcionou no Debian 10 [RESOLVIDO]

asdfg
ppa-DO_MAL

(usa Slackware)

Enviado em 26/08/2019 - 13:36h


tenho um notebook da lenovo que precisa do firmware-iwlwifi

ainda bem que você resolveu,agora marca como resolvido tchau \(oo)






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts