Adaptador de rede não reconhecido (Atheros) [RESOLVIDO]

1. Adaptador de rede não reconhecido (Atheros) [RESOLVIDO]

Vinícius Nascimento de Oliveira
vinioliveira

(usa Linux Mint)

Enviado em 10/08/2018 - 20:52h

Olá,
Antes de criar este tópico eu procurei sobre problemas relacionados, infelizmente esbarrei alguns problemas que não sou capaz de resolver (Newbie de 1a viagem no Linux), mas de antemão tenho algumas informações que podem ser úteis (referências no final).
Instalei o Linux Mint 19 e minha placa/adaptor de rede sem fio não foi reconhecido/habilitado.
Com
 inxi -Fxz 

Tenho de volta:
System: Host: vinicius-pc Kernel: 4.15.0-20-generic x86_64
bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara
Machine: Device: laptop System: Acer product: Aspire E5-573 v: V3.72 serial: N/A
Mobo: Acer model: ZORO_BH v: Type2 - A01 Board Version serial: N/A
UEFI: Insyde v: V1.25 date: 07/15/2015
CPU: Dual core Intel Core i5-5200U (-MT-MCP-)
arch: Broadwell rev.4 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8799
clock speeds: max: 2700 MHz 1: 1024 MHz 2: 1008 MHz 3: 1173 MHz
4: 1117 MHz
Graphics: Card: Intel HD Graphics 5500 bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes
Audio: Card-1 Intel Broadwell-U Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0
Card-2 Intel Wildcat Point-LP High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
driver: r8168 v: 8.045.08-NAPI port: 3000 bus-ID: 02:00.0
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
bus-ID: 03:00.0
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 500.1GB (2.0% used)
ID-1: /dev/sda model: WDC_WD5000LPVX size: 500.1GB
Partition: ID-1: / size: 73G used: 9.3G (14%) fs: ext4 dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 45.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 193 Uptime: 58 min Memory: 1790.8/3860.3MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

Apesar de suspeitar que o problema seja com o card 2, primeiramente busquei instalar o do card 1 (provavelmente o mesmo do c2?), daí achei a ref.1, onde tive problema no passo make install, recebo a seguinte mensagem:
- SSL error:02001002:system library:fopen:No such file or directory: ../crypto/bio/bss_file.c:74
- SSL error:2006D080:BIO routines:BIO_new_file:no such file: ../crypto/bio/bss_file.c:81
sign-file: certs/signing_key.pem: No such file or directory
DEPMOD 4.15.0-20-generic

E tentando fazer algo a respeito do card 2, achei a ref.2, que envolve uma compilação de kernel, que eu até comecei a tentar fazer, mas achei estranho pois o .config do kernel atual já estava da maneira pedida na ref.

referência 1 : https://www.unixblogger.com/the-pain-of-an-realtek-rtl8111rtl8168-ethernet-card/
referência 2 : https://wireless.wiki.kernel.org/en/users/drivers/ath9k


  


2. Re: Adaptador de rede não reconhecido (Atheros) [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 10/08/2018 - 21:15h

adaptador é uma daquelas anteninhas USB para Wifi? geralmente elas são reconhecidas direto.

no Sabayon e no openSUSE, a minha é reconhecida direto, é só plugar ela.

sua rede tem cabeada, também? ela acessa, é só a WiFi que dá problema?
o pacote linux-firmware está instalado.

Olha, para iniciante, não é muito fácil recompilar kernel.
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


3. Re: Adaptador de rede não reconhecido (Atheros) [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 10/08/2018 - 21:38h

Vc está usando adaptador wi-fi USB?

Vc já tentou habilitar seu adaptador usando gerenciador de drivers do LinuxMint


4. Re: Adaptador de rede não reconhecido

Vinícius Nascimento de Oliveira
vinioliveira

(usa Linux Mint)

Enviado em 10/08/2018 - 21:48h

albfneto escreveu:

adaptador é uma daquelas anteninhas USB para Wifi? geralmente elas são reconhecidas direto.

no Sabayon e no openSUSE, a minha é reconhecida direto, é só plugar ela.

sua rede tem cabeada, também? ela acessa, é só a WiFi que dá problema?
o pacote linux-firmware está instalado.

Olha, para iniciante, não é muito fácil recompilar kernel.

Obrigado pela resposta.
Acho que omiti o fato de que estou num notebook, o adaptador wireless faz parte da placa de rede do note, não tem nenhum periférico. A placa funciona com a entrada Ethernet, inclusive estou conectado neste momento, o problema é que o wi-fi não está sendo reconhecido/habilitado, inclusive nessas minhas pesquisas, vi um comando que no qual ele deveria ser listado
rfkill

E só aparace o bluetooth.
Quanto ao kernel, eu consegui entrar na parte do make menuconfig e ver o que deveria estar habilitado e a priori estava tudo certo. Mas foi só, não cheguei de fato a recompilar, e nem sei se seria essa a solução, dado que aparentemente está certo.



5. Re: Adaptador de rede não reconhecido (Atheros) [RESOLVIDO]

Vinícius Nascimento de Oliveira
vinioliveira

(usa Linux Mint)

Enviado em 10/08/2018 - 21:53h

clodoaldops escreveu:

Vc já tentou habilitar seu adaptador usando gerenciador de drivers do LinuxMint


Olá, após o gerenciador carregar, aparece uma lista vazia e :

No proprietary drivers are in use


Já fiz atualizações no Update Manager também.


6. Re: Adaptador de rede não reconhecido (Atheros) [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 11/08/2018 - 02:09h

.
.
.
.
https://googleweblight.com/i?u=https://ubuntuforums.org/showthread.php?t%3D2393252&hl=pt-BR

------------------------------------------| Linux User #621728 |-----------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------| Linux User #621728 |-----------------------------------------



7. Re: Adaptador de rede não reconhecido (Atheros) [RESOLVIDO]

Vinícius Nascimento de Oliveira
vinioliveira

(usa Linux Mint)

Enviado em 11/08/2018 - 11:45h



Desculpe mas você me mandou uma thread sem reply, só com o post do autor (na verdade agora tem a minha reply, já que consegui por conta própria resolver o problema). Achei um tópico em outro fórum no qual fiquei sabendo que deveria ser um problema relacionado com a bios da placa-mãe, depois de tentar todas as configurações possíveis, resolvi atualizar a bios e para minha felicidade o wi-fi foi reconhecido.

Obrigado a quem se dispôs à ajudar.







Patrocínio

Site hospedado pelo provedor HostGator.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Viva o Android

Tópicos

Top 10 do mês

Scripts