PROBLEMAS SERIOS COM HOTPLUG

1. PROBLEMAS SERIOS COM HOTPLUG

Andre Luis Lacerda Vanderlei Silva
SUPERANDRE

(usa Debian)

Enviado em 04/07/2006 - 08:18h

EU SOU UM NOVATO NO CONECTIVA LINUX E PARA MINHA DECEPÇAO DEPOIS DE INSTALADO (JA POSSUIA O XP NO HD QUE PRETENDO ME LIVRAR)EU ESCOLHO NA TELA DE GRUB O LINUX. ATE AI BEM, MAS QUANDO ELE ESTA DANDO O BOOT (QUANDO AQULE MONTE DE PALAVRAS PASSA SUBINDO)ELE TENTA INICIAR OS DISPOSITIVOS DE HOTPLUG E TRAVA E TENHO QUE REINICIAR O SISTEMA , POREM SE EU APERTO O BOTÀO ''I'' EU DOU BOOT INTERATIVO SEGUNDO O LINUX INFORMA, E POSSO PULAR ISSO MAS FICO SEMPRE SEM OS USB.Q QUE EU FAÇO SERA QUE MEU PC E RUIM????


  


2. Re: PROBLEMAS SERIOS COM HOTPLUG

Fernando Dettoni
fdettoni

(usa Arch Linux)

Enviado em 04/07/2006 - 09:04h

Primeiramente, não precisa gritar, ninguém é surdo aqui.

Vc já localizou a origem o problema, e isto é o primeiro passo a fazer sempre. Agora vc tem que localizar a causa.

O linux tem um ótimo sistema de logs. Dê uma olhada no arquivo /var/log/syslog e verifique o que ele diz sobre o hotplug.

Pode tentar iniciar o hotplug manualmente e ver se ele trava sem computador, ou apenas não inicia.

Se vc nao entender nada do que diz o log, dá uma pesquisada no google, se mesmo assim continuar boiando, posta aqui o que achar relevante.

[]'s


3. Cara eu nao sabia

Andre Luis Lacerda Vanderlei Silva
superandre

(usa Debian)

Enviado em 04/07/2006 - 09:49h

Foi Mal eu nao sabia que letras maiusculas tem a ver com tom de mas useias para destacar o problema apenas.por ai vc tira quanto eu to novo nessa onda de Linux.


4. HOT PLUG

Andre Luis Lacerda Vanderlei Silva
SUPERANDRE

(usa Debian)

Enviado em 04/07/2006 - 11:46h

Eu consegui observar que pelo Windows os dispositivos hotplug trabalham com normalidade e eu nao consegui fazer nada pelo google haja vista que nao conheco uma maneira de achar os arquivos var/log/syslog no sistema ...entretanto o fato de o PC congelar quando tenta inicializar dispositivos hotplug quer dizer algo,nào?? eu acredito que eles (dispositivos)ao tentar iniciar dao bug ou sei la por que algo ta mal configurado,sei que nào to ajudando muito masse der diga-me um passo a passo de coisas que posso tentar , por exemplo como iniar hotplugs manualmente?????????


5. Re: PROBLEMAS SERIOS COM HOTPLUG

Fernando Dettoni
fdettoni

(usa Arch Linux)

Enviado em 04/07/2006 - 12:26h

Claro que o fato de ele travar no hotplug quer dizer algo. Por isso é interessante olhar os logs, pois lá vai estar mais detalhado sobre o problema que está acontecendo.

para iniciar o serviço, acho que pode usar o comando
#service hotplug start

Para ver o log em terminal, pode digitar:
cat /var/log/syslog

[]'s


6. Mais Info!?

Marcus Fazzi
anunakin

(usa Gentoo)

Enviado em 04/07/2006 - 12:33h

Que distribuição LInux você está usando?
Já procurou ler alguma documentação para iniciantes?
Linux não é de graça? o preço é o aprendizado aprenda a ser livre!
Bom as letrinhas passando na maioria dos Linuxes existentes por ai já nem se vê isso.
Quanto ao problema com o hotplug, bom podem ser tantos os problema que acarretariam isso que não saberia lhe ajudar, para começar, informe-nos o seguinte:
1- Qual distribuição você usa (Debian, Kurumin, Unbunto, SuSE etc...)
2- Se é a sua primeira vez em Linux sujiro que use Unbunto ou SuSE
3- Você consegue carregar a máquina com o Linux?
4- Se sim, execute o comando dmesg no modo texto e poste o resultado, se não sabes nem por onde vai isso, instale SuSE ou Unbunto.


7. Mais Informação

Andre Luis Lacerda Vanderlei Silva
SUPERANDRE

(usa Debian)

Enviado em 04/07/2006 - 13:10h

Eu estou usando o Conectiva Linux 10.Essas letras a que me refiro sao frases acompanhados de "Chaves" com um [ OK ] dentro, exceto o ok do hotplug...Bem a documentação mais ideal aonde encontrar??Tendo em vista a papelada que ja baixei da internet com liçòes que geralmente ultrapassam meu curto conhecimento,qual fonte me sugere anunakim?


8. vou tentar

Andre Luis Lacerda Vanderlei Silva
SUPERANDRE

(usa Debian)

Enviado em 04/07/2006 - 13:12h

fdetonni, obrigado, eu vou tentar e logo digo o resultado.


9. Re: PROBLEMAS SERIOS COM HOTPLUG

Marcus Fazzi
Anunakin

(usa Gentoo)

Enviado em 04/07/2006 - 14:09h

Apesar do conectiva estar todo em português, sujiro que você instale Unbunto ou SuSE, são bem mais modernos, o conectiva foi inclusive descontinuado e comprado pela Mandrake e agora se chama Mandriva...

Esse travamanto do hotplug, após isso para de funcionar? trava? pois se for isso pode ser algum problema do conectiva e não do Linux... Eu particularmente nunca gostei do conectiva sempre tive problemas com ele.


10. Tamnbem tenho problemas

Jean Marcel
jeanmarcel

(usa Kurumin)

Enviado em 18/07/2006 - 10:27h

ola...eu uso o kurumin e tambem tenho esses problemas, segui os passos de vcs e encontrei isso:

pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x1001
hw_random: RNG not detected
shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x1001

porem eu n sei interpreta-los
sao esses erros q aparecem no INIT...nao sei se tem a v mas antes de comecar o meu INIT,o meu pc fica pensando uns 3 min pra pode comeca...
tenho um pentium 4 1.9 (antes q perg se e um 386)


11. Informações relevantes


jalexandre

(usa Debian)

Enviado em 18/07/2006 - 12:28h

Assim como o anunakin disse, precisamos de algumas informações como:
Versão do Kernel (obtido com um uname -a)
Hardware instalado (obtido com lspci)
Mensagens de log e inicialização (cat /var/log/algo que pareça relevante e dmesg, respectivamente)
Isso é a informação básica.
Tente não colocar muitos blocos de informação, coloque apenas o que achar necessário e, se for necessário, a pessoa que esta te ajudando te dira o que precisa exatamente.
Dica - Tive problemas com hotplug/udev ao colocar uma placa wireless em um kernel um pouco antigo...
Ah... atualizar o kernel para uma versão acima da 2.6.12 pode ser problemático pra quem usa hotplug, pois a partir desta versão, o que passa a detectar os dispositivos é o senhor udev :)
Outra dica! Conectiva é problemático por natureza... já tive varios problemas com ele...


12. Re: PROBLEMAS SERIOS COM HOTPLUG

Jean Marcel
jeanmarcel

(usa Kurumin)

Enviado em 18/07/2006 - 14:06h

entao...o meu e o knoppix 2.7.alguma coisa
eu uso o kurumin e pelo q li ele usa o tal do udev pra detectar...mas mesmo assim na inicializacao aparece algo do tp(sintesizing hotplug)
tentei akele comando pra desativar o hotplug mas esse local n existe
/etc/rc.d/rc.hotplug
tentei axar o arquivo /etc/module mas so tem 3 palavras dentro...e q n estou em casa agora...
isso aki ja ajuda?




01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts