Problema para estalar o astha no fedora 22 [RESOLVIDO]

1. Problema para estalar o astha no fedora 22 [RESOLVIDO]

Ramon Lima
DarkLinnux

(usa openSUSE)

Enviado em 30/07/2015 - 23:52h

Boa noite VOL !

Estou tentando estala o astha_community, mas não tou conseguindo porque ta dizendo que meu java ta desatualizado mas ele está na ultima versão.

[[email protected] ramon]# dnf install /home/ramon/Downloads/astah-community-7.0.0.846701-0.noarch.rpm
Last metadata expiration check performed 0:05:09 ago on Thu Jul 30 23:17:04 2015.
Error: nothing provides jdk >= 1.7.0 needed by astah_community-7.0.0.846701-0.noarch

[[email protected] ramon]# java -version
openjdk version "1.8.0_45"
OpenJDK Runtime Environment (build 1.8.0_45-b14)
OpenJDK 64-Bit Server VM (build 25.45-b02, mixed mode)


  


2. Re: Problema para estalar o astha no fedora 22 [RESOLVIDO]

Hugo Cerqueira
hrcerq

(usa Outra)

Enviado em 31/07/2015 - 13:22h

Boa tarde, Ramon.

O motivo de você não conseguir instalar o Astah, é porque a instalação por RPM dele tem o jdk-1.7 como dependência, mas o Fedora já não usa mais essa versão do java, só usa o 1.8.

Uma solução para você, portanto, seria baixar a versão zip:
http://astah.net/download/community?http%3A//cdn.astah.net/downloads/astah-community-7_0_0-846701.zi...

Basta descompactar num diretório de sua escolha e executar o script "astah" (lembre-se de tornar o script executável primeiro). Independente da versão do Java que você tiver instalado, ele vai executar. Se o Astah for compatível com a versão 1.8 (e creio que seja), não haverá qualquer problema.

---

Atenciosamente,
Hugo Cerqueira


3. Re: Problema para estalar o astha no fedora 22 [RESOLVIDO]

Ramon Lima
DarkLinnux

(usa openSUSE)

Enviado em 31/07/2015 - 14:18h

hrcerq escreveu:

Boa tarde, Ramon.

O motivo de você não conseguir instalar o Astah, é porque a instalação por RPM dele tem o jdk-1.7 como dependência, mas o Fedora já não usa mais essa versão do java, só usa o 1.8.

Uma solução para você, portanto, seria baixar a versão zip:
http://astah.net/download/community?http%3A//cdn.astah.net/downloads/astah-community-7_0_0-846701.zi...

Basta descompactar num diretório de sua escolha e executar o script "astah" (lembre-se de tornar o script executável primeiro). Independente da versão do Java que você tiver instalado, ele vai executar. Se o Astah for compatível com a versão 1.8 (e creio que seja), não haverá qualquer problema.

---

Atenciosamente,
Hugo Cerqueira


Acho que o problema ta e no java, não estou conseguindo executar meus arquivo.jar sempre volta esse retorno.

2015-07-31 14:10:53,076 [AWT-EventQueue-0] JP.co.esm.caddies.jomt.Jude <ERROR> - error has occurred.
java.lang.NullPointerException: null
at JP.co.esm.caddies.jomt.jview.swing.g.a(X:187) ~[astah-community.jar:na]
at JP.co.esm.caddies.jomt.jview.swing.g.c(X:77) ~[astah-community.jar:na]
at JP.co.esm.caddies.jomt.jview.ez.e(X:360) ~[astah-community.jar:na]
at JP.co.esm.caddies.jomt.jview.ez.a(X:624) ~[astah-community.jar:na]
at JP.co.esm.caddies.jomt.jview.ez.a(X:602) ~[astah-community.jar:na]
at JP.co.esm.caddies.jomt.jview.ak.<init>(X:22) ~[astah-community.jar:na]
at JP.co.esm.caddies.jomt.jview.swing.SwingJomtWidgetFactory.z(X:175) ~[astah-community.jar:na]
at JP.co.esm.caddies.jomt.Jude.f(X:675) [astah-community.jar:na]
at JP.co.esm.caddies.jomt.Jude.d(X:601) [astah-community.jar:na]
at JP.co.esm.caddies.jomt.Jude.a(X:70) [astah-community.jar:na]
at JP.co.esm.caddies.jomt.c.run(X:590) [astah-community.jar:na]
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311) [na:1.8.0_45]
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756) [na:1.8.0_45]
at java.awt.EventQueue.access$500(EventQueue.java:97) [na:1.8.0_45]
at java.awt.EventQueue$3.run(EventQueue.java:709) [na:1.8.0_45]
at java.awt.EventQueue$3.run(EventQueue.java:703) [na:1.8.0_45]
at java.security.AccessController.doPrivileged(Native Method) [na:1.8.0_45]
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75) [na:1.8.0_45]
at java.awt.EventQueue.dispatchEvent(EventQueue.java:726) [na:1.8.0_45]
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201) [na:1.8.0_45]
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116) [na:1.8.0_45]
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105) [na:1.8.0_45]
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101) [na:1.8.0_45]
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93) [na:1.8.0_45]
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82) [na:1.8.0_45]





4. Re: Problema para estalar o astha no fedora 22 [RESOLVIDO]

Ramon Lima
DarkLinnux

(usa openSUSE)

Enviado em 01/08/2015 - 14:50h

Conseguir resolver meu problema desinstalei o openjdk que veio no fedora e dexei so o jdk da oracle.
Ae rodou de boa.