Nao consigo instalar o nginx (ultilizo o CentOS 7), alguém poderia me ajudar ? [RESOLVIDO]

1. Nao consigo instalar o nginx (ultilizo o CentOS 7), alguém poderia me ajudar ? [RESOLVIDO]

Gabriel Hiury Martinez Sangi
gabrielhiury

(usa Outra)

Enviado em 06/11/2020 - 10:16h

Toda vez que eu vou efetuar o processo de instalação me gera esse erro
[[email protected] ~]# sudo yum install nginx
Plugins carregados: fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.unicamp.br
* epel: mirror.globo.com
* extras: ftp.unicamp.br
* updates: mirror.ufscar.br
Resolvendo dependências
--> Executando verificação da transação
---> O pacote nginx.x86_64 0:1.10.3-1.el6 será instalado
--> Processando dependência: nginx-all-modules = 1.10.3-1.el6 para o pacote: nginx-1.10.3-1.el6.x86_64
--> Processando dependência: nginx-filesystem = 1.10.3-1.el6 para o pacote: nginx-1.10.3-1.el6.x86_64
--> Processando dependência: libpcre.so.0()(64bit) para o pacote: nginx-1.10.3-1.el6.x86_64
--> Executando verificação da transação
---> O pacote nginx.x86_64 0:1.10.3-1.el6 será instalado
--> Processando dependência: nginx-filesystem = 1.10.3-1.el6 para o pacote: nginx-1.10.3-1.el6.x86_64
--> Processando dependência: libpcre.so.0()(64bit) para o pacote: nginx-1.10.3-1.el6.x86_64
---> O pacote nginx-all-modules.noarch 0:1.10.3-1.el6 será instalado
--> Processando dependência: nginx-mod-http-geoip = 1.10.3-1.el6 para o pacote: nginx-all-modules-1.10.3-1.el6.noarch
--> Processando dependência: nginx-mod-http-image-filter = 1.10.3-1.el6 para o pacote: nginx-all-modules-1.10.3-1.el6.noarch
--> Processando dependência: nginx-mod-http-perl = 1.10.3-1.el6 para o pacote: nginx-all-modules-1.10.3-1.el6.noarch
--> Processando dependência: nginx-mod-http-xslt-filter = 1.10.3-1.el6 para o pacote: nginx-all-modules-1.10.3-1.el6.noarch
--> Processando dependência: nginx-mod-mail = 1.10.3-1.el6 para o pacote: nginx-all-modules-1.10.3-1.el6.noarch
--> Processando dependência: nginx-mod-stream = 1.10.3-1.el6 para o pacote: nginx-all-modules-1.10.3-1.el6.noarch
--> Executando verificação da transação
---> O pacote nginx.x86_64 0:1.10.3-1.el6 será instalado
--> Processando dependência: nginx-filesystem = 1.10.3-1.el6 para o pacote: nginx-1.10.3-1.el6.x86_64
--> Processando dependência: libpcre.so.0()(64bit) para o pacote: nginx-1.10.3-1.el6.x86_64
---> O pacote nginx-mod-http-geoip.x86_64 0:1.10.3-1.el6 será instalado
---> O pacote nginx-mod-http-image-filter.x86_64 0:1.10.3-1.el6 será instalado
---> O pacote nginx-mod-http-perl.x86_64 0:1.10.3-1.el6 será instalado
--> Processando dependência: perl(:MODULE_COMPAT_5.10.1) para o pacote: nginx-mod-http-perl-1.10.3-1.el6.x86_64
---> O pacote nginx-mod-http-xslt-filter.x86_64 0:1.10.3-1.el6 será instalado
---> O pacote nginx-mod-mail.x86_64 0:1.10.3-1.el6 será instalado
---> O pacote nginx-mod-stream.x86_64 0:1.10.3-1.el6 será instalado
--> Resolução de dependências finalizada
Error: Pacote: nginx-1.10.3-1.el6.x86_64 (epel)
Requer: libpcre.so.0()(64bit)
Error: Pacote: nginx-1.10.3-1.el6.x86_64 (epel)
Requer: nginx-filesystem = 1.10.3-1.el6
Instalados: 1:nginx-filesystem-1.16.1-2.el7.noarch (@epel)
nginx-filesystem = 1:1.16.1-2.el7
Disponível: nginx-filesystem-1.10.3-1.el6.noarch (epel)
nginx-filesystem = 1.10.3-1.el6
Error: Pacote: nginx-mod-http-perl-1.10.3-1.el6.x86_64 (epel)
Requer: perl(:MODULE_COMPAT_5.10.1)
Você pode tentar usar o parâmetro --skip-broken para contornar o problema
Você pode tentar executar: rpm -Va --nofiles --nodigest
[[email protected] ~]# base: centos.mirror.constant.com
-bash: base:: comando não encontrado
[[email protected] ~]# ewr.edge.kernel.org
-bash: ewr.edge.kernel.org: comando não encontrado
[[email protected] ~]# centos.mirror.constant.com
-bash: centos.mirror.constant.com: comando não encontrado



  


2. Re: Nao consigo instalar o nginx (ultilizo o CentOS 7), alguém poderia me ajudar ? [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 06/11/2020 - 14:10h


tem certeza que tu esta usando o centos 7 ?
pois o pacote é da versão 6

nginx.x86_64 0:1.10.3-1.el6

esse "el6" é referente ao Centos 6


3. Re: Nao consigo instalar o nginx (ultilizo o CentOS 7), alguém poderia me ajudar ? [RESOLVIDO]

Gabriel Hiury Martinez Sangi
gabrielhiury

(usa Outra)

Enviado em 07/11/2020 - 09:30h

danniel-lara escreveu:


tem certeza que tu esta usando o centos 7 ?
pois o pacote é da versão 6

nginx.x86_64 0:1.10.3-1.el6

esse "el6" é referente ao Centos 6


Sim sim, nao estava instalando de forma alguma, eu tive que formatar essa maquina novamente depois de formatar eu executei o comando de instalacao e ocorreu tudo normalmente, muito obrigado pela ajuda