Instalar Opera no Ubuntu 16.04

1. Instalar Opera no Ubuntu 16.04

Gabriel Augusto Martins
GabrielAugusto

(usa Ubuntu)

Enviado em 05/11/2020 - 09:50h

Eu utilizo o linux 16.04, e segui algumas instruções aqui do Fórum e de outras fontes da internet para baixar e instalar o navegador opera, essas instruções se resumem basicamente a:

wget -qO- https://deb.opera.com/archive.key | sudo apt-key add -
echo "deb https://deb.opera.com/opera-stable/ stable non-free" | sudo tee /etc/apt/sources.list.d/opera-stable.list
sudo apt-get update
sudo apt-get install -y opera-stable

E a seguinte mensagem me aparece ao apertar enter no comando sudo apt-get install -y opera-stable:

--------------------------------------------------------------------------------------------------------------------------------------------------------

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
opera-stable : Depende: libgtk-3-0 (>= 3.19.12) mas 3.18.9-1ubuntu3.3 está para ser instalado
Depende: libxcb1 (>= 1.12) mas 1.11.1-1ubuntu1 está para ser instalado
Recomenda: pepperflashplugin-nonfree mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

--------------------------------------------------------------------------------------------------------------------------------------------------------

Alguém consegue me ajudar a entender o que esta acontecendo e como eu posso resolver isso?


  


2. Re: Instalar Opera no Ubuntu 16.04

Walker Luiz de Freitas
WalkerPR

(usa KDE Neon)

Enviado em 05/11/2020 - 10:16h


Abaixo o site oficial do Opera onde é só clicar no link "Baixar Agora".
https://www.opera.com/pt-br

Irá baixar um arquivo .deb o qual é só executar o comando de instalação:

Com a opção sudo:
$ sudo dpkg -i opera-stable_72.0.3815.200_amd64.deb

Ou com a opção root, onde digitar o comando "su" o qual pedirá a senha do root, e depois executar o comando de instalação:
# dpkg -i opera-stable_72.0.3815.200_amd64.deb

--------------------------------------------------------------
"Linux: several flavors, one way: - Freedom of choice!"


3. Re: Instalar Opera no Ubuntu 16.04

Rogerio Leiro Fontan
RLFontan

(usa Fedora)

Enviado em 05/11/2020 - 10:18h

Aparentemente a sua versão antiga de Ubuntu não está oferecendo dependências novas o suficiente de pacotes para instalar o Opera. A solução mais fácil provavelmente é instalar o Snap oficial do Opera:

sudo snap install opera 





4. Re: Opera

Gabriel Augusto Martins
GabrielAugusto

(usa Ubuntu)

Enviado em 05/11/2020 - 10:36h

RLFontan escreveu:

Aparentemente a sua versão antiga de Ubuntu não está oferecendo dependências novas o suficiente de pacotes para instalar o Opera. A solução mais fácil provavelmente é instalar o Snap oficial do Opera:

sudo snap install opera 




Interessante, eu utilizei esse comando e estou com o opera agora, mas que diferença faz esse "snap"?, oque eu achei mais interessante é que quando eu escrevo "firefox" ele abre o firefox, mas ao escrever "opera", ele abre o opera e as seguintes mensagens no terminal:

[12731:12731:1105/102916.524769:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
[12480:12684:1105/102943.312440:ERROR:registration_request.cc(263)] Registration response error message: PHONE_REGISTRATION_ERROR
[12480:12684:1105/102943.317119:ERROR:registration_request.cc(263)] Registration response error message: PHONE_REGISTRATION_ERROR
[12480:12684:1105/102943.435855:ERROR:mcs_client.cc(706)] Error code: 500 Error message: Cannot parse data.
[12480:12684:1105/102943.435882:ERROR:mcs_client.cc(708)] Failed to log in to GCM, resetting connection.


Eu fiquei curioso pq quando eu acesso o dpkg --list eu não encontro o opera.

Posso utilizar o opera desse jeito? Que diferença isso tem pra outras formas de baixar o opera?
De qualquer forma, muito obrigado




5. Re: Instalar Opera no Ubuntu 16.04

Xerxes
xerxeslins

(usa Devuan)

Enviado em 05/11/2020 - 10:46h


GabrielAugusto escreveu:

RLFontan escreveu:

Aparentemente a sua versão antiga de Ubuntu não está oferecendo dependências novas o suficiente de pacotes para instalar o Opera. A solução mais fácil provavelmente é instalar o Snap oficial do Opera:

sudo snap install opera 




Interessante, eu utilizei esse comando e estou com o opera agora, mas que diferença faz esse "snap"?, oque eu achei mais interessante é que quando eu escrevo "firefox" ele abre o firefox, mas ao escrever "opera", ele abre o opera e as seguintes mensagens no terminal:

[12731:12731:1105/102916.524769:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
[12480:12684:1105/102943.312440:ERROR:registration_request.cc(263)] Registration response error message: PHONE_REGISTRATION_ERROR
[12480:12684:1105/102943.317119:ERROR:registration_request.cc(263)] Registration response error message: PHONE_REGISTRATION_ERROR
[12480:12684:1105/102943.435855:ERROR:mcs_client.cc(706)] Error code: 500 Error message: Cannot parse data.
[12480:12684:1105/102943.435882:ERROR:mcs_client.cc(708)] Failed to log in to GCM, resetting connection.


Posso utilizar o opera desse jeito? Que diferença isso tem pra outras formas de baixar o opera?
De qualquer forma, muito obrigado


Snap é uma nova maneira de instalar pacotes que pretende ser "universal". Assim como o Flatpak (outra maneira). Existe um grande debate se o Snap é ruim ou não, pois é mais lento e ocupa mais espaço. Mas tem a vantagem de funcionar no Ubuntu ou em qualquer outra distribuição.

Eu só uso Snap quando não tem jeito.

Tente abrir com o comando:

snap run opera


Se quiser, procure sobre corrigir pacotes quebrados par solucionar o erro que apareceu.

Sobre Opera, pode baixar direto do site o pacote ".deb" e instalar.

Lamento não fornecer mais explicações, pois no momento não estou usando Ubuntu e sim Void.

Abraço.

--
"There are lots of Linux users who don't care how the kernel works, but only want to use it. That is a tribute to how good Linux is." - Linus Torvalds



6. Re: Instalar Opera no Ubuntu 16.04

Ruan
ru4n

(usa Debian)

Enviado em 05/11/2020 - 10:50h

GabrielAugusto escreveu:

Eu fiquei curioso pq quando eu acesso o dpkg --list eu não encontro o opera.



Pacotes snap vc lista com:
snap list 





7. Re: Opera

Gabriel Oliveira
LinuxerMinter

(usa Linux Mint)

Enviado em 05/11/2020 - 11:15h

Cara, acho que é melhor você baixar pelo site oficial deles, lá já está tudo no esquema: https://www.opera.com/pt-br/download. Eu uso esse navegador, é bom ele, só baixei do site e já está tudo no esquema de instalação.


8. Re: Instalar Opera no Ubuntu 16.04

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 05/11/2020 - 11:27h

Step 1: Download and Install Opera + Step 2: Install Opera Web Browser
https://websiteforstudents.com/how-to-install-the-official-opera-web-browser-on-ubuntu-16-04-18-04/



9. Re: Instalar Opera no Ubuntu 16.04

Gabriel Augusto Martins
GabrielAugusto

(usa Ubuntu)

Enviado em 05/11/2020 - 11:28h

Primeiramente agradeço a todos pela colocação.
Meu objetivo em baixar o opera é apenas utilizar ele para testar o código de alguns sites e como navegador padrão. Eu tentei instalar pelo site oficial utilizando dpkg para .deb, mas ando tendo MUITOS problemas com pacotes quebrados.
Agora eu baixei utilizando o snap e vou ver aonde vai, eu acho que preciso apenas investigar mais como lidar com os problemas de quebra de pacote e por fim, quais as implicações da utilizaçõa do snap.


10. Re: Instalar Opera no Ubuntu 16.04

Ruan
ru4n

(usa Debian)

Enviado em 05/11/2020 - 11:35h

GabrielAugusto escreveu:
Agora eu baixei utilizando o snap e vou ver aonde vai, eu acho que preciso apenas investigar mais como lidar com os problemas de quebra de pacote e por fim, quais as implicações da utilizaçõa do snap.


É como o RLFontan comentou, a versão 16.04 do Ubuntu foi lançada em 2016, ou seja, os pacotes desse sistema são bem antigos. É comum dar esse tipo de problema em versões antigas.
opera-stable : Depende: libgtk-3-0 (>= 3.19.12) mas 3.18.9-1ubuntu3.3 está para ser instalado
Depende: libxcb1 (>= 1.12) mas 1.11.1-1ubuntu1 está para ser instalado


O ideal seria atualizar para o Ubuntu 20.04.


11. Re: Instalar Opera no Ubuntu 16.04

skjdeecedcnfncvnrfcnrncjvnjrnfvjcnjrjvcjrvcj
Londreslondres

(usa Parabola)

Enviado em 05/11/2020 - 11:44h

GabrielAugusto escreveu:
Os pacotes a seguir têm dependências desencontradas:
opera-stable : Depende: libgtk-3-0 (>= 3.19.12) mas 3.18.9-1ubuntu3.3 está para ser instalado
Depende: libxcb1 (>= 1.12) mas 1.11.1-1ubuntu1 está para ser instalado
Recomenda: pepperflashplugin-nonfree mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Baixe as dependências e instale-as:
http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+3.0/libgtk-3-0_3.22.30-1ubuntu1_amd64.deb
http://mirrors.kernel.org/ubuntu/pool/main/libx/libxcb/libxcb1_1.13-1_amd64.deb



12. Re: Instalar Opera no Ubuntu 16.04

Rogerio Leiro Fontan
RLFontan

(usa Fedora)

Enviado em 05/11/2020 - 13:38h

Londreslondres escreveu:

GabrielAugusto escreveu:
Os pacotes a seguir têm dependências desencontradas:
opera-stable : Depende: libgtk-3-0 (>= 3.19.12) mas 3.18.9-1ubuntu3.3 está para ser instalado
Depende: libxcb1 (>= 1.12) mas 1.11.1-1ubuntu1 está para ser instalado
Recomenda: pepperflashplugin-nonfree mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Baixe as dependências e instale-as:
http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+3.0/libgtk-3-0_3.22.30-1ubuntu1_amd64.deb
http://mirrors.kernel.org/ubuntu/pool/main/libx/libxcb/libxcb1_1.13-1_amd64.deb


Posso estar errado, mas acho que isso é má prática. A instalação independente das dependências vai formando um sistema frankstein não suportado. Penso que em distribuições modernas com repositórios grandes e resoluções de dependências, fugir da árvore de pacotes do repositório principal deve ser um recurso pontual, específico e preferencialmente para uso de pacotes menos interdependentes.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts