Problemas para usar o programa do IR no Linux Mint [RESOLVIDO]

1. Problemas para usar o programa do IR no Linux Mint [RESOLVIDO]

Luc
arksdf

(usa Manjaro Linux)

Enviado em 05/03/2021 - 21:03h

Estou tentando usar a versão multiplataforma, e segui o tutorial que alguns outros usuarios mostraram aqui: https://www.vivaolinux.com.br/topico/Multimidia/IMPOSTO-DE-RENDA-2021

mas quando eu uso o comando
java -jar irpf.jar 


eu recebo esse erro:

Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: serpro/ppgd/app/IRPFPGD has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:756)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:468)
at java.net.URLClassLoader.access$100(URLClassLoader.java:74)
at java.net.URLClassLoader$1.run(URLClassLoader.java:369)
at java.net.URLClassLoader$1.run(URLClassLoader.java:363)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:362)
at java.lang.ClassLoader.loadClass(ClassLoader.java:418)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352)
at java.lang.ClassLoader.loadClass(ClassLoader.java:351)


a versão do jdk é a 1.8

openjdk version "1.8.0_282"
OpenJDK Runtime Environment (build 1.8.0_282-8u282-b08-0ubuntu1~18.04-b08)
OpenJDK 64-Bit Server VM (build 25.282-b08, mixed mode)




  


2. Re: Problemas para usar o programa do IR no Linux Mint [RESOLVIDO]

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 06/03/2021 - 01:02h

arksdf escreveu:
a versão do jdk é a 1.8

openjdk version "1.8.0_282"
OpenJDK Runtime Environment (build 1.8.0_282-8u282-b08-0ubuntu1~18.04-b08)
OpenJDK 64-Bit Server VM (build 25.282-b08, mixed mode)


Segundo o Synaptic a versão mais recente é openjdk-11-jre (11.0.10+9-0ubuntu1~18.04).
obs: Ainda não instalei o IRPF-2011.



3. Re: Problemas para usar o programa do IR no Linux Mint [RESOLVIDO]

Severino do Ramo Lemos
galena

(usa KDE Neon)

Enviado em 06/03/2021 - 06:59h


Baixe e instale o programa IRPF2021Linux-x86_64v1.1.bin que já vem com java pré-instalado.


4. Re: Problemas para usar o programa do IR no Linux Mint [RESOLVIDO]

Paulo Jr
Pebis

(usa Debian)

Enviado em 06/03/2021 - 08:16h


galena escreveu:


Baixe e instale o programa IRPF2021Linux-x86_64v1.1.bin que já vem com java pré-instalado.


Aqui foi instalar e usar... Funciona perfeitamente.


5. Re: Problemas para usar o programa do IR no Linux Mint [RESOLVIDO]

Luc
arksdf

(usa Manjaro Linux)

Enviado em 06/03/2021 - 13:54h


ricardogroetaers escreveu:

Segundo o Synaptic a versão mais recente é openjdk-11-jre (11.0.10+9-0ubuntu1~18.04).
obs: Ainda não instalei o IRPF-2011.


Eu atualizei a versão do java e agora ele funcionou, vlw






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts