Instalando FluidSynth e QSynth....Qt5 não encontrado

1. Instalando FluidSynth e QSynth....Qt5 não encontrado

lindberg
lindbergluiz

(usa Slackware)

Enviado em 03/03/2017 - 22:38h

Já instalei o fluidSynth, mas ao tentar instalar o Qsynth, o compillador retorna:

checking for Qt library version >= 4.2... no; Qt 4.2 or greater is required


mas o qt5 já está instalado, porém não retorna nada com

which qt5 


ou com

qt --version 


porém a pasta

/usr/lib64/qt5 existe.

Como posso indicar a localização da pasta para o compilador?


  


2. Re: Instalando FluidSynth e QSynth....Qt5 não encontrado

Eric
Grinder

(usa Slackware)

Enviado em 03/03/2017 - 23:29h

Não é garantido, mas não custa tentar

rode esse comando e então manda compilar
. /etc/profile.d/qt5.sh 

- - - - -
www.github.com/ericfernandesferreira


3. Re: Instalando FluidSynth e QSynth....Qt5 não encontrado

lindberg
lindbergluiz

(usa Slackware)

Enviado em 04/03/2017 - 00:52h

Grinder escreveu:

Não é garantido, mas não custa tentar

rode esse comando e então manda compilar
. /etc/profile.d/qt5.sh 

- - - - -
www.github.com/ericfernandesferreira


Erro ainda persiste:

checking for Qt library version >= 4.2... no; Qt 4.2 or greater is required


onde encontro o arquivo com essa informação "Qt library version"?


4. Re: Instalando FluidSynth e QSynth....Qt5 não encontrado

Eric
Grinder

(usa Slackware)

Enviado em 04/03/2017 - 02:03h

lindbergluiz escreveu:

Grinder escreveu:

Não é garantido, mas não custa tentar

rode esse comando e então manda compilar
. /etc/profile.d/qt5.sh 

- - - - -
www.github.com/ericfernandesferreira


Erro ainda persiste:

checking for Qt library version >= 4.2... no; Qt 4.2 or greater is required


onde encontro o arquivo com essa informação "Qt library version"?


Como eu tenho aqui o QT5 instalado, vou tentar compilar esse qsynth e já tento te ajudar, calma lá.
- - - - -
www.github.com/ericfernandesferreira


5. Re: Instalando FluidSynth e QSynth....Qt5 não encontrado

lindberg
lindbergluiz

(usa Slackware)

Enviado em 05/03/2017 - 01:12h

Grinder escreveu:

lindbergluiz escreveu:

Grinder escreveu:

Não é garantido, mas não custa tentar

rode esse comando e então manda compilar
. /etc/profile.d/qt5.sh 

- - - - -
www.github.com/ericfernandesferreira


Erro ainda persiste:

checking for Qt library version >= 4.2... no; Qt 4.2 or greater is required


onde encontro o arquivo com essa informação "Qt library version"?


Como eu tenho aqui o QT5 instalado, vou tentar compilar esse qsynth e já tento te ajudar, calma lá.
- - - - -
www.github.com/ericfernandesferreira


OK.

aguardando...


6. Re: Instalando FluidSynth e QSynth....Qt5 não encontrado

lindberg
lindbergluiz

(usa Slackware)

Enviado em 05/03/2017 - 01:22h

pensei em, de repente, colocar um link simbólico do qt no lugar onde o Cmake está procurando ele, mas não sei onde seria....


7. Re: Instalando FluidSynth e QSynth....Qt5 não encontrado

lindberg
lindbergluiz

(usa Slackware)

Enviado em 09/03/2017 - 10:28h

Grinder escreveu:

lindbergluiz escreveu:

Grinder escreveu:

Não é garantido, mas não custa tentar

rode esse comando e então manda compilar
. /etc/profile.d/qt5.sh 

- - - - -
www.github.com/ericfernandesferreira


Erro ainda persiste:

checking for Qt library version >= 4.2... no; Qt 4.2 or greater is required


onde encontro o arquivo com essa informação "Qt library version"?


Como eu tenho aqui o QT5 instalado, vou tentar compilar esse qsynth e já tento te ajudar, calma lá.
- - - - -
www.github.com/ericfernandesferreira


conseguistes?






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts