Conexõa IPv4 caindo [RESOLVIDO]

1. Conexõa IPv4 caindo [RESOLVIDO]

Lucas
lukebz

(usa Ubuntu)

Enviado em 21/10/2021 - 17:18h

Pessoal, boa tarde.

Estou com o seguinte problema e talvez alguém consiga me ajudar.

Tenha um mikrotik na loja e outro no escritorio, tenho também uma EOIP entre a loja e o escritorio. Acontece que no mikrotik da loja as vezes algumas maquinas estão parando de acessar sites que somente aceitam IPv4 e so abrem sites em IPv6, o problema acontece aleatoriamente em uma maquina enquanto outras funcionam normalmente e depois de um tempo volta a funcionar normalmente mesmo sem fazer nada, o problema é resolvido também desativando e ativando a placa de rede da maquina com problema, este problema não aconte no escritorio e apenas na Loja.

A rede interna da loja está configurada m 192.168.1... já a do escritorio em 192.168.0... Na loja temos um roteador google WIFI na rede 192.168.86... e quanto conectado nele o problema não acontece (mesmo ele estando ligado ao mikrotik e saindo por ele), o problema acontece apenas nos computadores cabeados. Na bridge que fiz no mikrotik está marcado como trusted apenas a porta do DHCP do mikrotik enquanto a porta do roteador não está marcada como trusted para que não haja disputa de servidores DHCP na rede.

Alguém sabe me dizer o porque isso pode estar ocorrendo? Deixei alguns prints da bridge, das interfaces do mikrotik e da EOIP. Caso precise de mais alguma informações basta me perguntar que posto aqui.

Desde já agradeço. Muito obrigado!


  


2. Re: Conexõa IPv4 caindo [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 21/10/2021 - 18:05h


Esse é um trabalho para o traceroute via conexão tcp


3. Re: Conexõa IPv4 caindo [RESOLVIDO]

Lucas
lukebz

(usa Ubuntu)

Enviado em 21/10/2021 - 19:21h


leandropscardua escreveu:


Esse é um trabalho para o traceroute via conexão tcp


Quando acontece o problema, a maquina não consegue realizar tracerout ou ping para IPv4, apenas IPv6. Quando o problema é resolvido sozinho após um tempinho ou desativando e ativando a placa de rede da maquina, o tracerout chega ao destino normalmente.




4. Re: Conexõa IPv4 caindo [RESOLVIDO]

Leandro Silva
LSSilva

(usa Outra)

Enviado em 21/10/2021 - 21:54h


Desativar IPv6 na máquina com problema?


5. Re: Conexõa IPv4 caindo [RESOLVIDO]

Lucas
lukebz

(usa Ubuntu)

Enviado em 22/10/2021 - 15:49h


LSSilva escreveu:


Desativar IPv6 na máquina com problema?


Tentei, mas sem sucesso também ;(


6. Re: Conexõa IPv4 caindo [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 22/10/2021 - 19:24h


lukebz escreveu:


leandropscardua escreveu:


Esse é um trabalho para o traceroute via conexão tcp


Quando acontece o problema, a maquina não consegue realizar tracerout ou ping para IPv4, apenas IPv6. Quando o problema é resolvido sozinho após um tempinho ou desativando e ativando a placa de rede da maquina, o tracerout chega ao destino normalmente.


Mas em que até onde os pacotes vão? O endereço é resolvido?
Se a interface estiver caindo isso deve ser visto no dmesg (dmesg | grep enp0s1 - colocar o nome correto da interface)



7. Re: Conexõa IPv4 caindo [RESOLVIDO]

Lucas
lukebz

(usa Ubuntu)

Enviado em 26/10/2021 - 15:56h


leandropscardua escreveu:


lukebz escreveu:


leandropscardua escreveu:


Esse é um trabalho para o traceroute via conexão tcp


Quando acontece o problema, a maquina não consegue realizar tracerout ou ping para IPv4, apenas IPv6. Quando o problema é resolvido sozinho após um tempinho ou desativando e ativando a placa de rede da maquina, o tracerout chega ao destino normalmente.


Mas em que até onde os pacotes vão? O endereço é resolvido?
Se a interface estiver caindo isso deve ser visto no dmesg (dmesg | grep enp0s1 - colocar o nome correto da interface)


Infelizmente estou afastado do escritorio agora por um curto tempo, mas creio que não consiga sair da maquina já que quando problema ocorre, os pings do mikrotik para a maquina não ocorrem, vou testar assim que possível e retorno com a informação. obrigado!


8. Resolvido

Lucas
lukebz

(usa Ubuntu)

Enviado em 04/11/2021 - 12:30h

Pessoal, agradeço a atenção de todos que se disponibilizaram a responder o tópico e tentar me ajudar, mas consegui identificar e resolver o problema...

Acontece que havia um switch entre as maquinas e o mikrotik e neste switch estava sendo fexado algum tipo de loop fazendo com que a maquina parasse de responder conexão IPv4, após isolar o switch, o problema foi resolvido.

Mias uma vez obrigado a todos!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts