Problema com dependências desencontradas

1. Problema com dependências desencontradas

Francine Guimarães
Francine

(usa Ubuntu)

Enviado em 14/12/2019 - 01:21h

Gente, tô enfrentando um problema com dependências e não sei mais o que fazer. Não consigo atualizar, baixar ou remover qualquer coisa.
O problema sempre se dá relacionado a um pacote do python.
Eis o que aparece quando tento fazer quase qualquer coisa no terminal:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
libpython3.7-stdlib : Depende: libpython3.7-minimal (= 3.7.4-1+xenial2) mas 3.7.5-2~18.04 está para ser instalado
python3.7 : Depende: libpython3.7-stdlib (= 3.7.5-2~18.04) mas 3.7.4-1+xenial2 está para ser instalado
synaptic : Depende: libept1.5.0 mas não será instalado
Recomenda: rarian-compat mas não será instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).

Além disso, meu touchpad parou de funcionar do nada, assim que começou a aparecer esses problemas de dependência, não sei se tem algo a ver.



  


2. Re: Problema com dependências desencontradas

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 14/12/2019 - 02:24h


Você tentou o comando que o próprio APT sugeriu?

O comando é:

sudo apt --fix-broken install 



3. Re: Problema com dependências desencontradas

augusto
marimbondo

(usa Outra)

Enviado em 14/12/2019 - 09:11h

Desinstale esses pacotes bugados que usam as dependencias libpython3.7-stdlib e python3.7 que vc deve ter instalado..


4. Re: Problema com dependências desencontradas

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 14/12/2019 - 17:43h


marimbondo escreveu:

Desinstale esses pacotes bugados que usam as dependencias libpython3.7-stdlib e python3.7 que vc deve ter instalado..


O comando APT com a opção "--fix-broken" vai encontrar a melhor solução, que pode ser remover os pacotes problemáticos ou instalar dependências para eles.


5. Re: Problema com dependências desencontradas

Francine Guimarães
Francine

(usa Ubuntu)

Enviado em 14/12/2019 - 18:13h

pinduvoz escreveu:


Você tentou o comando que o próprio APT sugeriu?

O comando é:

sudo apt --fix-broken install 


@pinduvoz Já tentei sim e o resultado é o seguinte:

A preparar para desempacotar .../libpython3.7-stdlib_3.7.5-2~18.04_amd64.deb ...
A descompactar libpython3.7-stdlib:amd64 (3.7.5-2~18.04) sobre (3.7.4-1+xenial2) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libpython3.7-stdlib_3.7.5-2~18.04_amd64.deb (--unpack):
a tentar sobre-escrever '/usr/lib/python3.7/distutils/__init__.py', que também está no pacote python3.7-distutils 3.7.4-1+xenial2
dpkg-deb: erro: colar subprocess was killed by signal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/libpython3.7-stdlib_3.7.5-2~18.04_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)






6. Re: Problema com dependências desencontradas

Francine Guimarães
Francine

(usa Ubuntu)

Enviado em 14/12/2019 - 18:16h

marimbondo escreveu:

Desinstale esses pacotes bugados que usam as dependencias libpython3.7-stdlib e python3.7 que vc deve ter instalado..

Quais pacotes exatente? já tentei desinstalar o libpython3.7-stdlib mas não dá, na verdade não consigo usar nada que envolva o comando apt aparentemente.



7. Re: Problema com dependências desencontradas

Francine Guimarães
Francine

(usa Ubuntu)

Enviado em 14/12/2019 - 18:16h

pinduvoz escreveu:


marimbondo escreveu:

Desinstale esses pacotes bugados que usam as dependencias libpython3.7-stdlib e python3.7 que vc deve ter instalado..


O comando APT com a opção "--fix-broken" vai encontrar a melhor solução, que pode ser remover os pacotes problemáticos ou instalar dependências para eles.


Mas não dá de usar esse comando, dá erro.




8. Re: Problema com dependências desencontradas

augusto
marimbondo

(usa Outra)

Enviado em 14/12/2019 - 22:45h

Tem que ver extamente quais pacotes você isntalou que usam essas duas libs.

Primeor tente:
sudo apt-get autoremove 


Esse comando vai tentar desinstalar deps que você não precisa mais...

Se ainda assim não der certo, acho que você pode tentar desinstalar o python3, fazer o update, reiniciar e tal, e depois vc tenta reinstalar o python3 e os módulos dele que você precisa...


9. Re: Problema com dependências desencontradas

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 14/12/2019 - 23:09h

Você tem o Synaptic instalado?

Se tiver tente a opção de corrigir pacotes quebrados dele (Synaptic).

Mais info aqui:

https://www.vivaolinux.com.br/artigo/O-Synaptic/

Você também pode tentar remover os pacotes quebrados usando "força bruta", assim:

sudo dpkg --remove --force-remove-reinstreq nome-do-pacote

Troque "nome-do-pacote" pelo nome real do pacote problemático.

Tente também as outras opções do meu antigo artigo:

https://www.vivaolinux.com.br/artigo/Instalacao-de-Programas-no-Ubuntu-(atualizacao)/


10. Re: Problema com dependências desencontradas

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 14/12/2019 - 23:13h


Deixando mastigado:

sudo dpkg --remove --force-remove-reinstreq libpython3.7-stdlib

Teste aí.


11. Re: Problema com dependências desencontradas

Francine Guimarães
Francine

(usa Ubuntu)

Enviado em 15/12/2019 - 12:09h

pinduvoz escreveu:


Deixando mastigado:

sudo dpkg --remove --force-remove-reinstreq libpython3.7-stdlib

Teste aí.

Eis o resultado:
dpkg: problemas com dependências previnem a remoção de libpython3.7-stdlib:amd64:
python3.7 depende de libpython3.7-stdlib (= 3.7.5-2~18.04).

dpkg: erro ao processar o pacote libpython3.7-stdlib:amd64 (--remove):
problemas de dependência - não removendo
Erros foram encontrados durante o processamento de:
libpython3.7-stdlib:amd64






12. Re: Problema com dependências desencontradas

Francine Guimarães
Francine

(usa Ubuntu)

Enviado em 15/12/2019 - 12:10h

marimbondo escreveu:

Tem que ver extamente quais pacotes você isntalou que usam essas duas libs.

Primeor tente:
sudo apt-get autoremove 


Esse comando vai tentar desinstalar deps que você não precisa mais...

Se ainda assim não der certo, acho que você pode tentar desinstalar o python3, fazer o update, reiniciar e tal, e depois vc tenta reinstalar o python3 e os módulos dele que você precisa...

O problema é que eu não consigo usar o remove, nem o autoremove, nem nada. Simplesmente da erro.




01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts