Problema ao instalar PHP 7.3 no Linux Mint 19 LMDE

1. Problema ao instalar PHP 7.3 no Linux Mint 19 LMDE

Maicon de Oliveira Silva
Nordc

(usa Linux Mint)

Enviado em 15/11/2019 - 20:54h

Boa noite pessoal, tudo bem?
Estou com um problema que já vem me perturbando faz dias. Estou tentando configurar o meu ambiente para poder programar em PHP e usar alguns frameworks. Porém, não consigo de maneira nenhuma fazer o download do PHP 7.3. Segui todos os tutoriais que eu vi, e os mesmos sempre diziam para adicionar uma ppa no sistema para poder baixar de um repositório que tinha essa versão mais atual do PHP, porém, o meu sistema diz que não suporta PPA. Tentei também instalando o XAMPP(LAMPP), com ele eu consigo usar o php na versão mais atual, porém, os comandos do php não funcionam no terminal, e dessa forma, eu não consigo instalar outras dependências que necessitam executar o php via terminal. Sempre que vou executar o PHP no terminal, ele diz "arquivo ou diretório não encontrado", e o bash me dá o caminho do arquivo que é o executável do php: /opt/lampp/bin/php. Se eu digitar esse caminho diretamente no terminal, e informar os comandos que quero executar, como um -v para verificar a versão, ele retorna tudo certinho. Então, criei uma variável de ambiente para tentar contornar o problema, mas para usa-la é necessário o prefixo $ antes da variável, então fica difícil trabalhar assim. Alguém pode me ajudar?


  


2. Re: Problema ao instalar PHP 7.3 no Linux Mint 19 LMDE

augusto
marimbondo

(usa Outra)

Enviado em 15/11/2019 - 20:59h

Não uso o mint, mas você já olhou essa dica?
Para usar o ppa no mint:

sudo apt install software-properties-common

https://www.osradar.com/install-php-7-3-ubuntu-18-04-linux-mint-19/


3. Problema ao instalar PHP 7.3 no Linux Mint 19 LMDE

Maicon de Oliveira Silva
Nordc

(usa Linux Mint)

Enviado em 16/11/2019 - 16:37h

marimbondo escreveu:

Não uso o mint, mas você já olhou essa dica?
Para usar o ppa no mint:

sudo apt install software-properties-common

https://www.osradar.com/install-php-7-3-ubuntu-18-04-linux-mint-19/


Sim, eu já fiz todos esses passos e mesmo assim ele diz que a adição de PPA não é suportada.




4. Re: Problema ao instalar PHP 7.3 no Linux Mint 19 LMDE

Adalberto Nobre
Borg_Atomic

(usa Linux Mint)

Enviado em 16/11/2019 - 19:44h

Se você digitar: sudo apt search php, você verá que a versão mais recente no repositório é a 7.2, essa versão funciona perfeitamente nas versões mais recentes dos framework que uso: Codeigniter e symfony

Eu também não entendo por que o linux não oferece a versão mais recente, ainda mais porque essa linguagem é super utilizada e em constante evolução, já existem notícias dizendo que o Php 8 será ainda mais rápido

De qualquer forma aqui está:
PHP 7.4 - https://computingforgeeks.com/how-to-install-php-on-ubuntu/
PHP 7.3 - https://www.cloudbooklet.com/how-to-install-php-7-3-on-ubuntu-18-04/


5. Re: Problema ao instalar PHP 7.3 no Linux Mint 19 LMDE

Maicon de Oliveira Silva
Nordc

(usa Linux Mint)

Enviado em 16/11/2019 - 20:07h

Borg_Atomic escreveu:

Se você digitar: sudo apt search php, você verá que a versão mais recente no repositório é a 7.2, essa versão funciona perfeitamente nas versões mais recentes dos framework que uso: Codeigniter e symfony

Eu também não entendo por que o linux não oferece a versão mais recente, ainda mais porque essa linguagem é super utilizada e em constante evolução, já existem notícias dizendo que o Php 8 será ainda mais rápido

De qualquer forma aqui está:
PHP 7.4 - https://computingforgeeks.com/how-to-install-php-on-ubuntu/
PHP 7.3 - https://www.cloudbooklet.com/how-to-install-php-7-3-on-ubuntu-18-04/


Meu Linux Mint está todo atualizado, e a única versão disponível que eu consigo é a 7.0. Como eu vou trabalhar com Laravel, preciso de no minimo da 7.3. Agradeço a tua colaboração, mas como disse acima, não consigo adicionar PPAs no sistema, porque diz que não é suportado, sendo que já fiz todos esses métodos acima descritos e não funcionou.


6. Re: Problema ao instalar PHP 7.3 no Linux Mint 19 LMDE

Adalberto Nobre
Borg_Atomic

(usa Linux Mint)

Enviado em 16/11/2019 - 22:06h

Nordc escreveu:
Meu Linux Mint está todo atualizado, e a única versão disponível que eu consigo é a 7.0. Como eu vou trabalhar com Laravel, preciso de no minimo da 7.3. Agradeço a tua colaboração, mas como disse acima, não consigo adicionar PPAs no sistema, porque diz que não é suportado, sendo que já fiz todos esses métodos acima descritos e não funcionou.


Creio que esse Link deve ajudar : https://github.com/gitKearney/php7-from-scratch
Trata-se de como compilar e instalar o PHP a partir de arquivos binários do site https://www.php.net/downloads.php, não é difícil, apenas mude o 7.3.4 para 7.3.11 no comando wget








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts