Erro de pacotes Mint Olive

1. Erro de pacotes Mint Olive

Maiko Charles de Souza Trindade
maiko trindade

(usa Linux Mint)

Enviado em 03/01/2014 - 10:38h

Tenho Linux Mint 15 Olive.
Executei um apt-get upgrade e resultaram nos seguintes erros:

Erros foram encontrados durante o processamento de:
man-db
samba-common
winbind
libnss-winbind:amd64
libpam-winbind:amd64
samba-common-bin
samba
smbclient
debhelper
phonon:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)


Como posso solucionar isso? já tentei reinstalar os pacotes mas não resultaram em nenhuma alteração e não consigo fazer o upgrade para o Mint 16 Petra.


  


2. Re: Erro de pacotes Mint Olive

Maiko Charles de Souza Trindade
maiko trindade

(usa Linux Mint)

Enviado em 03/01/2014 - 10:46h

Erro de pacotes Mint Olive


3. Re: Erro de pacotes Mint Olive

Luis R. C. Silva
luisrcs

(usa Linux Mint)

Enviado em 03/01/2014 - 10:53h

Tente isto:

$ sudo apt-get autoremove
$ sudo apt-get update
$ sudo apt-get -f install
$ sudo apt-get upgrade


Ou:

$ sudo apt-get -f install
$ sudo apt-get autoremove
$ sudo apt-get update
$ sudo apt-get upgrade


4. Re: Erro de pacotes Mint Olive

Maiko Charles de Souza Trindade
maiko trindade

(usa Linux Mint)

Enviado em 03/01/2014 - 11:02h

rei_astro ainda não funcionou em nenhuma das opções. A saída é:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 3 não atualizados.
10 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 44, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in -e at /usr/share/perl5/Debconf/DbDriver/File.pm line 46, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/DbDriver/File.pm line 47, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value $directory in -d at /usr/share/perl5/Debconf/DbDriver/File.pm line 48, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value $directory in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 49, <DEBCONF_CONFIG> chunk 3.
debconf: DbDriver "config": mkdir :No such file or directory
Configurando man-db (2.6.3-3) ...
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 44, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in -e at /usr/share/perl5/Debconf/DbDriver/File.pm line 46, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/DbDriver/File.pm line 47, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value $directory in -d at /usr/share/perl5/Debconf/DbDriver/File.pm line 48, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value $directory in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 49, <DEBCONF_CONFIG> chunk 3.
debconf: DbDriver "config": mkdir :No such file or directory
dpkg: erro ao processar man-db (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Configurando samba-common (2:3.6.18-1ubuntu3.1) ...
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 44, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in -e at /usr/share/perl5/Debconf/DbDriver/File.pm line 46, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/DbDriver/File.pm line 47, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value $directory in -d at /usr/share/perl5/Debconf/DbDriver/File.pm line 48, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value $directory in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 49, <DEBCONF_CONFIG> chunk 3.
debconf: DbDriver "config": mkdir :No such file or directory
dpkg: erro ao processar samba-common (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas com dependências impedem a configuração de winbind:
winbind depende de samba-common (= 2:3.6.18-1ubuntu3.1); porém:
Pacote samba-common não está configurado ainda.

dpkg: erro ao processar winbind (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libnss-winbind:amd64:
libnss-winbind:amd64 depende de winbind (= 2:3.6.18-1ubuntu3.1); porém:
Pacote winbind não está configurado ainda.
libnss-winbind:amd64 depende de samba-common (= 2:3.6.18-1ubuntu3.1); porém:
Pacote samba-common não está configurado ainda.

dpkg: erro ao processar libnss-winbind:amd64 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de libpam-winbind:amd64:
libpam-winbind:amd64 depende de winbind (= 2:3.6.18-1ubuntu3.1); porém:
Pacote winbind não está configurado ainda.
libpam-winbind:amd64 depende de samba-common (= 2:3.6.18-1ubuntu3.1); porém:
Pacote samba-common não está configurado ainda.

dpkg: erro ao processar libpam-winbind:amd64 (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de samba-common-bin:
samba-common-bin depende de samba-common (>= 2:3.4.0~pre1-2); porém:
Pacote samba-common não está configurado ainda.

dpkg: erro ao processar samba-common-bin (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de samba:
samba depende de samba-common (= 2:3.6.18-1ubuntu3.1); porém:
Pacote samba-common não está configurado ainda.
samba depende de samba-common-bin; porém:
Pacote samba-common-bin não está configurado ainda.

dpkg: erro ao processar samba (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de smbclient:
smbclient depende de samba-common (= 2:3.6.18-1ubuntu3.1); porém:
Pacote samba-common não está configurado ainda.

dpkg: erro ao processar smbclient (--configure):
problemas de dependência - deixando desconfigurado
dpkg: problemas com dependências impedem a configuração de debhelper:
debhelper depende de man-db (>= 2.5.1-1); porém:
Pacote man-db não está configurado ainda.

dpkg: erro ao processar debhelper (--configure):
problemas de dependência - deixando desconfigurado
Configurando phonon:i386 (4:4.7.0really4.6.0-0ubuntu2) ...
Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 44, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in -e at /usr/share/perl5/Debconf/DbDriver/File.pm line 46, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/DbDriver/File.pm line 47, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value $directory in -d at /usr/share/perl5/Debconf/DbDriver/File.pm line 48, <DEBCONF_CONFIG> chunk 3.
Use of uninitialized value $directory in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 49, <DEBCONF_CONFIG> chunk 3.
debconf: DbDriver "config": mkdir :No such file or directory
dpkg: erro ao processar phonon:i386 (--configure):
sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
man-db
samba-common
winbind
libnss-winbind:amd64
libpam-winbind:amd64
samba-common-bin
samba
smbclient
debhelper
phonon:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)



5. Re: Erro de pacotes Mint Olive

Lisandro Guerra
Lisandro

(usa Linux Mint)

Enviado em 03/01/2014 - 11:54h

Tá tentando UPGRADE no Mint como se ele fosse Debian ou Ubuntu!!!
Não é assim.
Veja aqui: http://forums.linuxmint.com/viewtopic.php?f=46&t=150582

ATENÇÃO: NÃO ESQUEÇA DE FAZER BACKUP ANTES.

Abraço
Lisandro


6. Re: Erro de pacotes Mint Olive

Murilo Augusto
devauxcl

(usa Manjaro Linux)

Enviado em 03/01/2014 - 12:08h

Sugiro que voce troque pelo Petra, pois o Olivia vai perder suporte esse mes


7. Re: Erro de pacotes Mint Olive

Maiko Charles de Souza Trindade
maiko trindade

(usa Linux Mint)

Enviado em 03/01/2014 - 12:34h

LisandroGuerra escreveu:

Tá tentando UPGRADE no Mint como se ele fosse Debian ou Ubuntu!!!
Não é assim.
Veja aqui: http://forums.linuxmint.com/viewtopic.php?f=46&t=150582

ATENÇÃO: NÃO ESQUEÇA DE FAZER BACKUP ANTES.

Abraço
Lisandro



Lisandro, ainda continua com esse erro após seguir o tutorial.

Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/linux-image-3.8.0-35-generic_3.8.0-35.50_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



8. Re: Erro de pacotes Mint Olive

Maiko Charles de Souza Trindade
maiko trindade

(usa Linux Mint)

Enviado em 07/01/2014 - 10:57h

Mais alguém tem alguma sugestão?