WSL2, XRDP não funciona graficamente

1. WSL2, XRDP não funciona graficamente

Luciano de Melo Garrido
garrido

(usa Nenhuma)

Enviado em 02/06/2020 - 00:34h

Boa ..., instalei o WSL2, debian e mate. Abriu a tela grafica do XRDP para login e senha. Funcionou, porém muito vazio. Depois instalei o kde e desinstalei o mate. Tudo nessa ordem. Continuou abrindo a tela grafica do XRDP para login e senha, mas depois disso volta para linha de comando. Digito...

startx e...

X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
Current Operating System: Linux DESKTOP-RN4J8B2 4.19.104-microsoft-standard #1 SMP Wed Feb 19 06:37:35 UTC 2020 x86_64
Kernel command line: initrd=\initrd.img panic=-1 pty.legacy_count=0 nr_cpus=8
Build Date: 05 March 2019 08:11:12PM
xorg-server 2:1.20.4-1 (https://www.debian.org/support)
Current version of pixman: 0.36.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Tue Jun 2 00:20:54 2020
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
(EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
[email protected]:/home/garrido#

O arquivo de log em /var/log/Xorg.1.log

[ 10400.920]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[ 10400.920] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[ 10400.920] Current Operating System: Linux DESKTOP-RN4J8B2 4.19.104-microsoft-standard #1 SMP Wed Feb 19 06:37:35 UTC 2020 x86_64
[ 10400.921] Kernel command line: initrd=\initrd.img panic=-1 pty.legacy_count=0 nr_cpus=8
[ 10400.921] Build Date: 05 March 2019 08:11:12PM
[ 10400.921] xorg-server 2:1.20.4-1 (https://www.debian.org/support)
[ 10400.921] Current version of pixman: 0.36.0
[ 10400.921] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 10400.921] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 10400.921] (==) Log file: "/var/log/Xorg.1.log", Time: Tue Jun 2 00:21:28 2020
[ 10400.922] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 10400.922] (==) No Layout section. Using the first Screen section.
[ 10400.922] (==) No screen section available. Using defaults.
[ 10400.922] (**) |-->Screen "Default Screen Section" (0)
[ 10400.922] (**) | |-->Monitor "<default monitor>"
[ 10400.922] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[ 10400.922] (==) Automatically adding devices
[ 10400.922] (==) Automatically enabling devices
[ 10400.922] (==) Automatically adding GPU devices
[ 10400.922] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 10400.923] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[ 10400.923] Entry deleted from font path.
[ 10400.923] (==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
built-ins
[ 10400.923] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 10400.923] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 10400.923] (II) Loader magic: 0x562dac54de20
[ 10400.923] (II) Module ABI versions:
[ 10400.923] X.Org ANSI C Emulation: 0.4
[ 10400.923] X.Org Video Driver: 24.0
[ 10400.923] X.Org XInput driver : 24.1
[ 10400.923] X.Org Server Extension : 10.0
[ 10400.944] (EE) dbus-core: error connecting to system bus: org.freedesktop.DBus.Error.FileNotFound (Failed to connect to socket /var/run/dbus/system_bus_socket: No s$[ 10400.944] (--) using VT number 2

[ 10400.944] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 10400.944] (II) no primary bus or device found
[ 10400.944] (II) LoadModule: "glx"
[ 10400.945] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 10400.946] (II) Module glx: vendor="X.Org Foundation"
[ 10400.946] compiled for 1.20.4, module version = 1.0.0
[ 10400.946] ABI class: X.Org Server Extension, version 10.0
[ 10400.946] (==) Matched modesetting as autoconfigured driver 0
[ 10400.946] (==) Matched fbdev as autoconfigured driver 1
[ 10400.946] (==) Matched vesa as autoconfigured driver 2
[ 10400.946] (==) Assigned the driver to the xf86ConfigLayout
[ 10400.946] (II) LoadModule: "modesetting"
[ 10400.947] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 10400.947] (II) Module modesetting: vendor="X.Org Foundation"
[ 10400.947] compiled for 1.20.4, module version = 1.20.4
[ 10400.947] Module class: X.Org Video Driver
[ 10400.947] ABI class: X.Org Video Driver, version 24.0
[ 10400.947] (II) LoadModule: "fbdev"
[ 10400.947] (WW) Warning, couldn't open module fbdev
[ 10400.947] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 10400.947] (II) LoadModule: "vesa"
[ 10400.947] (WW) Warning, couldn't open module vesa
[ 10400.947] (EE) Failed to load module "vesa" (module does not exist, 0)
[ 10400.947] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 10400.948] (WW) Falling back to old probe method for modesetting
[ 10400.948] (EE) open /dev/dri/card0: No such file or directory
[ 10400.948] (WW) Falling back to old probe method for modesetting
[ 10400.948] (EE) open /dev/dri/card0: No such file or directory
[ 10400.948] (EE) No devices detected.
[ 10400.948] (EE)
Fatal server error:
[ 10400.948] (EE) no screens found(EE)
[ 10400.948] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 10400.948] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[ 10400.948] (EE)
[ 10400.948] (EE) Server terminated with error (1). Closing log file.

Agradeço quem poder me ajudar.


  






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts