Erro ao iniciar a interface gráfica no Slackware 13.37 [RESOLVIDO]

1. Erro ao iniciar a interface gráfica no Slackware 13.37 [RESOLVIDO]

João Henrique Dalben
jhdalben

(usa Slackware)

Enviado em 04/10/2011 - 09:15h

Bom dia, pessoal.

Sou novo aqui no fórum (primeiro post) e usuário iniciante de Linux. Estive instalando minha primeira distro nesta madrugada: o Slackware (obrigado pelo belo tutorial, Gedimar!). Estou fazendo testes numa VM antes de colocar definitivamente. É, cansei do Ruindows!

Enfim, instalei o Slack, configurei tudo bonitinho, mas ao iniciar a interface gráfica pelo 'startx', ele carrega alguns ícones do KDE, e no terceiro~quarto ícone ele trava e retorna uma mensagem de erro. Segue screenshot:

http://imageshack.us/photo/my-images/148/erro1o.jpg/

Alguém pode me ajudar, por favor? E se possível, me explicar o que está dando errado, pois eu quero aprender pra poder ajudar futuros slackianos aqui no fórum! :}

P.S.: Existe um jeito melhor de apresentar erros aqui no fórum? À primeira vista pensei em upar uma SS no imageshack e postar o link. Durante a instalação aceitei algo a respeito de ativar copiar e colar na 'tela preta'. Como faço uso deste recurso para copiar, por exemplo, toda a mensagem de um erro que recebo?

Grato desde já!


  


2. Re: Erro ao iniciar a interface gráfica no Slackware 13.37 [RESOLVIDO]

Natanael Henrique
n4t4n

(usa Arch Linux)

Enviado em 04/10/2011 - 10:01h

Bom dia, bem vindo ao VoL e ao Linux.

Ao que tudo indica o problema é que o D-Bus não foi instalado ou iniciado.

Faça o seguinte

Navegue até a pasta /etc/rc.d

cd /etc/rc.d

Re-execute o arquivo rc.d-bus (não lembro bem se é esse o nome)

./rc.d-bus restart

Caso você não encontre o dbus nessa pasta, então terá que instalá-lo

procure no cd de instalação e instale ele com o comando

installpkg /local/do/dbus.txz

ou pelo slackpkg caso tenha instalado

slackpkg install nomedopacote

Obs.: para usar o slackpkg pela primeira vez você precisará editar a lista de mirrors em /etc/slackpkg/mirrors e descomentar um (e somente um) mirror. A partir disso faça slackpkg update para atualizar a lista de pacotes e então pode instalar os pacotes que quiser


A opção que você selecionou para copiar e colar na tela preta faz parte da instalação do slack, porém você também precisa ativar o recurso de "capturar mouse" do virtualbox.
Feito isso, basta usar o mouse dentro da tela preta do slack que você verá o (quase) ponteiro do mouse (um quadrado). Para copiar você clica e arrasta e para colar você clica com o botão direito.

O recurso de captura do mouse do virtualbox permite que você cole o que copiou da VM na máquina host, então você pode colar o resultado aqui, de preferencia entre as tags [ code]seu texto aqui[/ code] (sem os espaços).


3. Re: Erro ao iniciar a interface gráfica no Slackware 13.37 [RESOLVIDO]

João Henrique Dalben
jhdalben

(usa Slackware)

Enviado em 04/10/2011 - 13:17h

Muito obrigado pelas respostas.

Realmente o D-Bus não está instalado, mas pra baixar os pacotes tenho que configurar internet, e tou apanhando um pouco pra isso. Tou conectado via cabo DHCP, e na hora de fazer download do mirror que eu descomentei dá erro, o que indica que eu não tou conectado, provavelmente.


Já usei netconfig bonitinho, mas nada ainda, e sem slackpkg update eu não consigo progredir.


Alguma dica?


4. Re: Erro ao iniciar a interface gráfica no Slackware 13.37 [RESOLVIDO]

João Henrique Dalben
jhdalben

(usa Slackware)

Enviado em 04/10/2011 - 15:03h

Minha interface de rede estava definida como eth1, e isso tava gerando conflitos com a contagem do Linux, que começa a partir do 0. Editei /etc/udev/rules.d/70-persistent-net.rules e arrumei o parametro pra minha interface ser chamada de eth0 e funfou a net :D

Agora posso usar slackpkg update e vou tentar arrumar o DBus.

EDIT:

Usei

slackpkg search dbus

e retornaram 4 pacotes, que já estavam previamente instalados. Creio que D-Bus não é o problema.

Alguma outra sugestão?

EDIT2:

Descobri o problema ao ler este tópico: http://www.linuxquestions.org/questions/slackware-14/kde-crashes-in-slackware-13-37-a-885306/

e segui a sugestão de uma das respostas, que dizia:

Try this from http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT
Quote:
Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection


Ou seja, o problema consistia basicamente em desabilitar a Composite extension criando um arquivo de texto em /etc/X11/xorg.conf.d chamado disable-composite.conf, contendo:

Section "Extensions"
Option "Composite" "Disable"
EndSection

Espero que ajude quem está passando por isso também!


5. Re: Erro ao iniciar a interface gráfica no Slackware 13.37 [RESOLVIDO]

Natanael Henrique
n4t4n

(usa Arch Linux)

Enviado em 05/10/2011 - 11:49h

Muito bom, continue assim. Aprendendo e ensinando vamos longe.


6. Congratulations rsrs

Anonymous
Zirou

(usa Debian)

Enviado em 11/05/2012 - 17:03h

Estava com o mesmo problema e a dica do amigo me ajudo muito. Obrigado e vamos estudar o sistema livre, bons estudos a todos.

Abraços.








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts