PHP [RESOLVIDO]

1. PHP [RESOLVIDO]

Felipe
felipefv

(usa Debian)

Enviado em 12/11/2009 - 14:08h

Boa tarde galera!

Dúvida rápida: como faço pra abrir uma home direto no index.php, e não procurar direto index.htm? Instalei o Joomla e, ao pedir o endereço http://ip-da-maquina/sitejoomla/ ele não abre direto no php... aparece pra baixar um arquivo, inclusive. Mas, se eu coloco direto http://ip-da-maquina/sitejoomla/index.php ele abre.

Alguém pode me dizer o que deixei pra trás? Valeu!


  


2. Re: PHP [RESOLVIDO]

César...
cesar

(usa CentOS)

Enviado em 12/11/2009 - 15:33h

Você configurou o arquivo httpd.conf para index.php ?


3. Re: PHP [RESOLVIDO]

Felipe
felipefv

(usa Debian)

Enviado em 12/11/2009 - 15:45h

E ai cesar!
Não configurei... me esqueci como fazer e na net achei algumas coisas, mas não ajudaram. Poderias me dizer como fazer? Valeu!


4. Re: PHP [RESOLVIDO]

César...
cesar

(usa CentOS)

Enviado em 12/11/2009 - 15:58h

Cara faz tempo que eu fiz isso,

Mas se eu não me engano no httpd.conf tem estas linhas

<IfModule mod_dir.c>
DirectoryIndex index.html
</IfModule>



MUDE PARA

<IfModule mod_dir.c>
DirectoryIndex index.php
</IfModule>


Só foi alterado o index.html para index.php, feito isto reinicie o apache.

[]'s


5. Re: PHP [RESOLVIDO]

Felipe
felipefv

(usa Debian)

Enviado em 12/11/2009 - 16:11h

cesar,

O problema é que meu httpd.conf está em branco... ele existe, mas está em branco.

Alguma sugestão?


6. Re: PHP [RESOLVIDO]

César...
cesar

(usa CentOS)

Enviado em 12/11/2009 - 16:19h

Cara muito estranho isto!

Ah alguma coisa na máquina utilizando o apache? se não tiver nada rodando apache ainda, tente reinstala-lo!

[]'s


7. Re: PHP [RESOLVIDO]

Felipe
felipefv

(usa Debian)

Enviado em 12/11/2009 - 16:47h

vou fazer isso mesmo...
só uma ultima duvida:

o processo é simplesmente baixar os pacotes do mysaql, apache2 e php e largar o joomla dentro do www, certo?


8. Re: PHP [RESOLVIDO]

Felipe
felipefv

(usa Debian)

Enviado em 12/11/2009 - 19:23h

Reinstalei o Linux do zero e o problema foi resolvido. Creio que tenha sido a configuração mesmo.


9. Re: PHP [RESOLVIDO]

César...
cesar

(usa CentOS)

Enviado em 13/11/2009 - 06:11h

Isso aí!

Qual a distro que você está utilizando?

[]'s




10. Re: PHP [RESOLVIDO]

Felipe
felipefv

(usa Debian)

Enviado em 13/11/2009 - 07:18h

E ai Cesar,

Debian.

Dessa vez, ao reinstalar, pedi Sistema Básico e Desktop + Servidor Web e Mysql. Creio que, ao instalar "do zero" e junto com os demais pacotes, a configuração tenha sido feita automaticamente. Mas vc estava certo... era algo que eu deveria alterar em alguma configuração, mas dessa vez eu não sabia onde, tendo em vista que o httpd.conf, por exemplo, estava em branco. Sobrava o apache2.conf que seria minha próxima tentativa... mas achei melhor reinstalar.

Valeu a força!


11. PENSEI que tinha resolvido...

Felipe
felipefv

(usa Debian)

Enviado em 13/11/2009 - 07:37h


Olha... eu devo tá numa maré de azar... o problema voltou. Simplesmente ao entrar no site ele me oferece um arquivo "application/x-httpd-php" pra ser baixado. To sentindo que essa configuração deve ser feita... mas onde? Será no apache2.conf?


12. Re: PHP [RESOLVIDO]

César...
cesar

(usa CentOS)

Enviado em 13/11/2009 - 09:38h

Sim,

veja se no arquivo apache2.conf tem as linhas que mencionei acima.

[]'s



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts