Tinha 3 grubs e sobrou um, como recupero os outros 2

1. Tinha 3 grubs e sobrou um, como recupero os outros 2

João C. Agostini
joagostini

(usa Arch Linux)

Enviado em 14/05/2021 - 09:22h

Oi

Este título esquisito explica o que aconteceu, mas não sei se alguém entende. Comecei a experimentar o LInux. Tentei instalar o Kubunto e não consegui. Ai tentei o Ubunto e ele se instalou. Grub 1. Baixei o KDE Plasma, e ele se instalou normal e o Ubunto se auto transformou em Kubunto, Grub 2. Em outra partição instalei o Arch Linux Garuda, funcionou ok, Grub 3. Tudo isso em um mesmo laptop Samsung, que ainda conta com um windows 10. Tudo funcionava com o belo Grud do Garuda.
Ontem comecei a ter problemas com a internet, o meu vim não conseguia acessar o github quando mandava instalar plugins, via PlugInstall. Mudei minhas conexões, 2,4 Ghz e 5 Ghz e tb nada. Fui para o win, para ver se era problema de máquina, não era. Lá estava ok. Sai do win e fui para o kubunto, mesmo problema de internet. Mas o serviço de internet era intermitente, ou seja, volta e outra, funcionava bem, e em um desses intervalos bons, o KDE do Kubunto disse que havia uma atualização a fazer e a fiz. Nada mudou, a internet novamente voltou a oscilar. Tentei voltar ao Garuda, mas ai um daemon, cujo nome não guardei, não deixava o Kubunto se desligar. Fiquei um bom tempo tentando desligá-lo e nada. Consegui desligar o laptop no botão.
Ao ligar de novo o laptop, surgiu um grub diferente do normal, contendo apenas as opções Ubunto e Windows! O grub 1! O Kubunto e o Garuda desapareceram!
Bom, como faço para recuperar o que havia? Entro no Ubunto e tento fazer o que se segue:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair

sudo add-apt-repository ppa:yannubuntu/boot-repair -r -y
sudo apt-get remove boot-repair --auto-remove


Ou tenho que agir de outra forma?
Posso perder tudo, até o win 10?
Obrigado por qualquer ajuda.



  


2. Re: Tinha 3 grubs e sobrou um, como recupero os outros 2

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 14/05/2021 - 09:49h

Entre no Ubuntu... Instale e rode grub-customizer... E veja quais sistemas vc tem instalado no PC



3. Re: Tinha 3 grubs e sobrou um, como recupero os outros 2

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 14/05/2021 - 10:38h


joagostini escreveu:

Oi

Este título esquisito explica o que aconteceu, mas não sei se alguém entende. Comecei a experimentar o LInux. Tentei instalar o Kubunto e não consegui. Ai tentei o Ubunto e ele se instalou. Grub 1. Baixei o KDE Plasma, e ele se instalou normal e o Ubunto se auto transformou em Kubunto, Grub 2. Em outra partição instalei o Arch Linux Garuda, funcionou ok, Grub 3. Tudo isso em um mesmo laptop Samsung, que ainda conta com um windows 10. Tudo funcionava com o belo Grud do Garuda.
Ontem comecei a ter problemas com a internet, o meu vim não conseguia acessar o github quando mandava instalar plugins, via PlugInstall. Mudei minhas conexões, 2,4 Ghz e 5 Ghz e tb nada. Fui para o win, para ver se era problema de máquina, não era. Lá estava ok. Sai do win e fui para o kubunto, mesmo problema de internet. Mas o serviço de internet era intermitente, ou seja, volta e outra, funcionava bem, e em um desses intervalos bons, o KDE do Kubunto disse que havia uma atualização a fazer e a fiz. Nada mudou, a internet novamente voltou a oscilar. Tentei voltar ao Garuda, mas ai um daemon, cujo nome não guardei, não deixava o Kubunto se desligar. Fiquei um bom tempo tentando desligá-lo e nada. Consegui desligar o laptop no botão.
Ao ligar de novo o laptop, surgiu um grub diferente do normal, contendo apenas as opções Ubunto e Windows! O grub 1! O Kubunto e o Garuda desapareceram!
Bom, como faço para recuperar o que havia? Entro no Ubunto e tento fazer o que se segue:

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair

sudo add-apt-repository ppa:yannubuntu/boot-repair -r -y
sudo apt-get remove boot-repair --auto-remove


Ou tenho que agir de outra forma?
Posso perder tudo, até o win 10?
Obrigado por qualquer ajuda.

Essa sequência de comandos instala e logo a seguir desinstala o boot-repair. Vc tem de rodar ele nesse intervalo mas acho q seria melhor por uma liveusb



4. Resumindo

João C. Agostini
joagostini

(usa Arch Linux)

Enviado em 14/05/2021 - 11:22h


clodoaldops escreveu:

Entre no Ubuntu... Instale e rode grub-customizer... E veja quais sistemas vc tem instalado no PC

leandropscardua escreveu:
Essa sequência de comandos instala e logo a seguir desinstala o boot-repair. Vc tem de rodar ele nesse intervalo mas acho q seria melhor por uma liveusb


Ola clodoaldodops e leandropscardua
obrigado pro responderem.
Vou tentar juntar as respostas de vcs.
Entro no Ubunto e rodo o grub-customizer para ver o que eu tenho instalado.

Depois, em um liveusb, rodo os comandos que indiquei acima. Como bem observou o leandro, o que escrevi só descreve a instalação e desinstalação do boot-repair, é necessário rodá-lo. Dai é ficar torcendo?

Vcs concordam com o que escrevi? Ou pensam outra coisa? Novamente obrigado.





5. Resolvendo a perdad e dois grubs

João C. Agostini
joagostini

(usa Arch Linux)

Enviado em 15/05/2021 - 21:57h


joagostini escreveu:


clodoaldops escreveu:

Entre no Ubuntu... Instale e rode grub-customizer... E veja quais sistemas vc tem instalado no PC

leandropscardua escreveu:
Essa sequência de comandos instala e logo a seguir desinstala o boot-repair. Vc tem de rodar ele nesse intervalo mas acho q seria melhor por uma liveusb


Ola clodoaldodops e leandropscardua
obrigado pro responderem.
Vou tentar juntar as respostas de vcs.
Entro no Ubunto e rodo o grub-customizer para ver o que eu tenho instalado.

Depois, em um liveusb, rodo os comandos que indiquei acima. Como bem observou o leandro, o que escrevi só descreve a instalação e desinstalação do boot-repair, é necessário rodá-lo. Dai é ficar torcendo?


Resolvi meio sem querer o problema.
1º tentei, entrando no Ubunto, instalar e rodar o grub-customizer. A primeira surpresa é que o que parece como Ubunto no grub de incialização é, qdo se entra, o kubunto perdido. Ele continua em ordem e funcionando. Mas o grup-customizer não identifica o garuda, assim, desisti dele.
2º tentativa, usando o liveusb do garuda, que o usei para instalá-lo, tentei rodá-lo para tentar usar o boot-repair. Segunda surpresa, o computador acessou o pendrive e entrou no garuda instalado e não no 'live' do penderive! Este também estava funcionando bem. Tentei usar o repair, mas ele entrava em conflito com o grub-garuda e me perguntou se queria tirar o grub-garuda. Disse não e fiquei tentando ver se havia outros comandos para o grub e achei grubup. Rodei e ele releu a partição de boot e parecia haver restaurado o grub original. Reinicie o computador e tudo voltou ao normal.

Mão sei qual o aprendizado desse processo, já que a solução foi acidental, apenas digo, não desista, pois reinstalar e reconfigurar o linux não é tarefa agradável. Ainda mais quando são dois. Lição verdadeira: faça backup!!

Parece que o meu crash com a atualização feita no kubunto tem alguma relação com a versão 21.04 do Ubunto. Quem tiver Ubunto vá atrás para ver se é bom atualizar o seu 20.04 para o 21 (a recomendação parece dizer não e minha experiência parece confirmar isso), pois há algum problema com o UFI. Quem tem o 18 lts pode atualizar sem problemas.

Obrigado.








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts