Instalação do HPLIP

1. Instalação do HPLIP

Thais de Souza da Costa
costhais95

(usa elementary OS)

Enviado em 18/12/2019 - 13:42h

Boa tarde,

Estou tentando instalar minha impressora no meu notebook, que agora possui o sistema Elementary OS, acontece que seguindo esse tutorial a chave de tudo é justamento o HPLIP que não estou conseguindo completar a instalação.
Bom, de início já aparece um erro:
error: Auto installation is not supported for 'unknown' distro so all dependencies may not be installed. 
Please install manually as mentioned in 'http://hplipopensource.com/hplip-web/install/manual/index.html' web-site

Porém pergunta se eu desejo continuar e é possível prosseguir...
Depois pede a versão do linux e como o elementary vem do Ubuntu foi essa a opção que escolhi e quando pede a versão do Ubuntu, nessa hora eu coloquei "0" que é a opção: "0 Unknown or not listed ", Depois disso me pede a senha:
 ENTER ROOT/SUPERUSER PASSWORD

Gente essa era pra ser a minha senha né?
Please enter the root/superuser password: 
error: Password incorrect. 2 attempt(s) left.
Please enter the root/superuser password:
error: Password incorrect. 1 attempt(s) left.
Please enter the root/superuser password:
error: Password incorrect.
error: 3 incorrect attempts. (or) Insufficient permissions(i.e. try with sudo user).
Exiting.

Já tentei iniciar o processo usando sudo mas não adianta, nessa etapa sempre me pede essa senha e a minha dá erro o tempo todo.
Não sei o que fazer se o erro é mesmo com a senha ou se o principal é com o sistema operacional, aff.
Esse elementary tá difícil de manter.


  


2. Re: Instalação do HPLIP

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 19/12/2019 - 17:17h

Qual impressora?

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


3. Resposta

Thais de Souza da Costa
costhais95

(usa elementary OS)

Enviado em 20/12/2019 - 14:18h

É a HP deskjet Ink Advantage 3635


4. Re: Instalação do HPLIP

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 20/12/2019 - 17:02h

A sua distribuição não esta listada na lista
Logo você precisa instalar a versão "HPLIP tar package" baixado do site.
Você pode entrar no site e baixar ou pode usar este comando:
cd ~ $$ wget https://ufpr.dl.sourceforge.net/project/hplip/hplip/3.19.12/hplip-3.19.12.tar.gz 

Vai baixar na sua "home" com o nome de "hplip-3.19.12.tar.gz".
Faça o download e descompacte e compile o código fonte baixado.
Precisa do Python version is 2.6 ou superior instalado.
Verifica os demais requerimento de compilação.
Se não sabe compilar recomendo mudar para uma das distros listadas no site.
Boa sorte moça.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


5. hplip padrão da distro (versão 3.19.6)

Marcelo Utida
utida

(usa Ubuntu)

Enviado em 16/01/2020 - 23:41h

aguamole escreveu:

A sua distribuição não esta listada na lista
Logo você precisa instalar a versão "HPLIP tar package" baixado do site.
Você pode entrar no site e baixar ou pode usar este comando:
cd ~ $$ wget https://ufpr.dl.sourceforge.net/project/hplip/hplip/3.19.12/hplip-3.19.12.tar.gz 

Vai baixar na sua "home" com o nome de "hplip-3.19.12.tar.gz".
Faça o download e descompacte e compile o código fonte baixado.
Precisa do Python version is 2.6 ou superior instalado.
Verifica os demais requerimento de compilação.
Se não sabe compilar recomendo mudar para uma das distros listadas no site.
Boa sorte moça.

CPU i5-8400 GTX 750 SofRaid 4xSSD 16GB DDR4 mesmo assim uso Lubuntu.


Olá,

Estou com um problema diferente para instalar essa impressora HP Laserjet Professional P1102w com o hplip.

Confesso que fiz algumas pesquisas em alguns sites de língua portuguesa e em inglês, mas não obtive sucesso.

Venho com esse problema desde o Ubuntu 18.04 e agora se mantém no 19.10.

Com o CUPS vai de boa, mas não possui todas as funcionalidades que o driver proprietário diz possuir.

Abaixo segue o log extraído após rodar o hp-check na última tentativa:

Saving output in log file: /home/utida/hp-check.log

HP Linux Imaging and Printing System (ver. 3.19.6)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball
(.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb,
.rpm, etc) or an already built HPLIP supplied tarball has the proper dependencies installed to
successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above
cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
OK
MISSING - Missing Dependency or Permission or Plug-in
INCOMPAT - Incompatible dependency-version or Plugin-version


---------------
| SYSTEM INFO |
---------------

Kernel: 5.3.0-26-generic #28-Ubuntu SMP Wed Dec 18 05:37:46 UTC 2019 GNU/Linux
Host: utida
Proc: 5.3.0-26-generic #28-Ubuntu SMP Wed Dec 18 05:37:46 UTC 2019 GNU/Linux
Distribution: ubuntu 19.10
Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.19.6
HPLIP-Home: /usr/share/hplip

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.19.6

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.19.6
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no


Current contents of '/var/lib/hp/hplip.state' file:
[plugin]
installed = 1
eula = 1
version = 3.19.6



Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[fax]
email_address =
voice_phone =

[installation]
date_time = 01/16/20 19:40:23
version = 3.19.6

[last_used]
device_uri =
printer_name =
working_dir = /home/utida/Downloads/linux-install/hplip/3.19.6/hplip-3.19.6-plugin.run

[polling]
device_list =
enable = false
interval = 5

[refresh]
enable = false
rate = 30
type = 1

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1579134381
notify_upgrade = false
pending_upgrade_time = 0


<Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------

error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'
gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.27 OK -
xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
error: dbus DBus - Message bus system REQUIRED - 1.12.14 MISSING 'DBUS may not be installed or not running'
policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
network network -wget OPTIONAL - 1.20.3 OK -
avahi-utils avahi-utils OPTIONAL - 0.7 OK -

------------------------
| General Dependencies |
------------------------

error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'
error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'
error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'
libpthread libpthread - POSIX threads library REQUIRED - b'2.30' OK -
error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
sane SANE - Scanning library REQUIRED - - OK -
error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 MISSING 'libcrypto needs to be installed'
python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.7.5 OK -
python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'
error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'
python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.12 OK -
python3-xml Python XML libraries REQUIRED - 2.2.7 OK -
error: python3-devel Python devel - Python development files REQUIRED 2.2 3.7.5 MISSING 'python3-devel needs to be installed'


Na utilização do hp-setup a instalação para depois que o plugin é instalado e obtenho uma mensagem de que há a necessidade do binário do plugin (acho que entendi isso), segue mensagem capturada pelo terminal;
error:  The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins.  Please run 'hp-plugin' as normal user to install plug-ins.   Visit  http://hplipopensource.com  for more infomation.  


Parece que esse erro é recorrente em quase todas as distribuições ubuntu.

Quanto ao erro encontrado no log do hp-check, parece que é a falta de links para as bibliotécas, porém ainda não testei.

Você tem alguma idéia do que causa esses erros?

Inclusive já instalei manualmente a última versão do hplip e problema com o plugin continua. O resultado de tando fuças foi a quebra do SO como um todo, tendo que fazer uma nova instalação da Distro, que no caso foi do 18.04 para o 19.10.








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts