Sem acesso a Rede

1. Sem acesso a Rede

felipeejunges
felipeejunges

(usa Debian)

Enviado em 30/11/2016 - 10:53h

Bom dia,
Estou montando um servidor em Debian para a empresa e o mesmo instala e atualiza e todos os aplicativos atraves do apt-get e baixa conteudos atraves do wget
Mas quando coloco pra dar um ping para o servidor ou do servidor para qualquer lugar, ele nao funciona.
Estou usando Hyper V no Windows Server 2008 R2, com Distro Debian 8.


  


2. Re: Sem acesso a Rede

Diego França
dtgfranca

(usa Debian)

Enviado em 30/11/2016 - 12:02h

felipeejunges escreveu:

Bom dia,
Estou montando um servidor em Debian para a empresa e o mesmo instala e atualiza e todos os aplicativos atraves do apt-get e baixa conteudos atraves do wget
Mas quando coloco pra dar um ping para o servidor ou do servidor para qualquer lugar, ele nao funciona.
Estou usando Hyper V no Windows Server 2008 R2, com Distro Debian 8.



Bom dia !
Já conifigurou a rede no Hyper V ? Talvez esse tutorial possa lhe ajudar em algo.
http://www.fabiobmed.com.br/como-configurar-a-rede-maquina-virtual-hyper-v-no-windows-2012-server/




3. Re: Sem acesso a Rede

felipeejunges
felipeejunges

(usa Debian)

Enviado em 30/11/2016 - 12:14h

Bom dia, há outros 3 servidores configurados no Hyper V, sendo que estão usando a mesma placa de rede externa.


4. Re: Sem acesso a Rede

Diego França
dtgfranca

(usa Debian)

Enviado em 30/11/2016 - 13:29h

felipeejunges escreveu:

Bom dia, há outros 3 servidores configurados no Hyper V, sendo que estão usando a mesma placa de rede externa.


Primeiramente verifique a placa de rede da VM , se ele estiver como NAT passa para BRIGDE e também verifique as regras de firewall.




5. Re: Sem acesso a Rede

felipeejunges
felipeejunges

(usa Debian)

Enviado em 30/11/2016 - 14:42h

Rodei o comando:
iptables -L 

Resposta:
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


E a placa já esta em Bridge (Hyper V/Servidor Windows)


6. Re: Sem acesso a Rede

Edward Ramos
EdwardRamos

(usa Fedora)

Enviado em 01/12/2016 - 01:17h

Verifica se nao estar bloqueado o ping no Debian e nas outras maquinas, por motivos de seguranca o correto e bloquear o ping. devido a isso as vezes o firewall bloqueia. Verifique suas configuracoes, antes de mais nada, faca testes em outras maquinas, para saber se estar pigando para maquina que voce deseja...


7. Re: Sem acesso a Rede

felipeejunges
felipeejunges

(usa Debian)

Enviado em 01/12/2016 - 08:18h

Bom dia,
Então, não sei se está certo, mas rodei o comando:
iptables -I FORWARD -p ICMP -j ACCEPT 

Após isso rodei o comando:
iptables -L 

E foi acrescentado a linha no Chain FORWARD (policy ACCEPT) a linha:

ACCEPT icmp -- anywhere anywhere

Meu IP: .117
IP do Servidor de Virtualização: .243
IP do Debian: .5


Pings que funcionam:

.117 para .243
.243 para 117


Não funcionam:

.5 para .243
.5 para .117
.243 para .5
.117 para .5



Configuração do /etc/network/interfaces
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet static
address X.X.X.5
netmask 255.255.255.0
network X.X.X.X.0
broadcast X.X.X.255
gateway X.X.X.1

dns-nameservers X.X.X.1
dns-search dominiodaempresa.net







8. Re: Sem acesso a Rede

felipeejunges
felipeejunges

(usa Debian)

Enviado em 02/12/2016 - 09:18h

Mudei o Resolv.conf e ainda nada

search dominiodaempresa.net
nameserver X.X.X.242
nameserver X.X.X.1
nameserver X.X.X.99



9. Re: Sem acesso a Rede

Dr Ferumbras
drferumbras

(usa CentOS)

Enviado em 02/12/2016 - 10:32h

Amigo,
Se o ping funciona somente entre a sua VM e o Servidor, significa que a placa de rede está configurada erroneamente. Mexer em DNS não irá te ajudar em nada.

Verifique se você está utilizando a placa de rede correta para o Debian, e definindo IP para a placa correta também.


10. Re: Sem acesso a Rede

felipeejunges
felipeejunges

(usa Debian)

Enviado em 02/12/2016 - 11:02h

Vamos lá.

Consigo baixar pacotes, tanto pelo wget quanto pelo apt-get ...
Beleza, funciona a rede nesse caso.

Minha VM não consegue pingar e nem receber ping tanto do meu servidor, quanto do meu computador.
Mas há a comunicação (ping) entre o servidor e meu computador (tanto que estou conectado ao servidor de virtualização por MSTSC)

A Placa de rede, funciona em outra virtualização (mas não é Linux, não tenho acesso a ela), não sei se é o caso, já que esta sendo usada.E de acordo superior a placa já esta em BRIDGE


11. Re: Sem acesso a Rede

Dr Ferumbras
drferumbras

(usa CentOS)

Enviado em 02/12/2016 - 11:27h

Se você está saindo para a internet normalmente, então sua VM provavelmente está em NAT ou fora do range do seu computador/servidor.



12. Re: Sem acesso a Rede

felipeejunges
felipeejunges

(usa Debian)

Enviado em 05/12/2016 - 08:31h

O IP está fixo dentro do padrão da empresa.
Como eu faço esta verificação que você esta falando, e com o ajustar, caso esteja errado ?



01 02