Não consigo instalar o pgadmin4 [RESOLVIDO]

1. Não consigo instalar o pgadmin4 [RESOLVIDO]

ijoaovictor76@gmail.com
pekka0202

(usa Linux Mint)

Enviado em 22/10/2020 - 15:33h

Olá, eu tentei instalar o Postgresql manualmente pelo site porém não consegui. Então eu fui na loja de aplicativos do linux mint 20 (Cinnamon). Depois depois disso eu consegui usar o postgres (12.4) mas só no terminal. Eu quero usa-lo com o pgadmin. Ja tentei usando essas dicas (https://www.edivaldobrito.com.br/pgadmin4-no-ubuntu/) mas a mensagem que sempre é retornada é essa: E: O pacote 'pgadmin4' não tem candidato para instalação
Por favor é urgente. Obrigado.


  


2. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 22/10/2020 - 16:30h

acho q tem o pgadmin3. Use apt-cache search pgadmin p ver as opções


3. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

ijoaovictor76@gmail.com
pekka0202

(usa Linux Mint)

Enviado em 22/10/2020 - 18:57h

Eu fiz o que vc disse mas não de certo. apareceu isso:


4. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 22/10/2020 - 21:18h

pekka0202 escreveu:

Eu fiz o que vc disse mas não de certo. apareceu isso:


Está faltando um traço. É apt-cache search pgadmin


5. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

ijoaovictor76@gmail.com
pekka0202

(usa Linux Mint)

Enviado em 22/10/2020 - 23:53h

Funcionou, realmente o pg3 esta instalado. Como faço para retirar o 3 e colocar o 4 ?




6. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

ijoaovictor76@gmail.com
pekka0202

(usa Linux Mint)

Enviado em 23/10/2020 - 00:00h

Ué eu fui desinstalar e falou que eu não tenho pgadmin3.
Agora eu to confuso.


7. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

ijoaovictor76@gmail.com
pekka0202

(usa Linux Mint)

Enviado em 23/10/2020 - 00:03h

dei esse comando. não sei se ajuda.


8. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 23/10/2020 - 00:12h

pekka0202 escreveu: Como faço para retirar o 3 e colocar o 4 ?

Use o Synaptic (pesquise por pgadmin) ou, na linha de comando, digite o nome correto do pacote.
Acho que é "pgadmin4_4.25-1.pgdg20.04+1_amd64", mas não tenho certeza pois não tenho Linux Mint 20.



9. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

ijoaovictor76@gmail.com
pekka0202

(usa Linux Mint)

Enviado em 23/10/2020 - 00:17h

No Synpatic só tem o pgadmin3.

digitei o nome do pacote e não deu em nada, deve ser pelo estar errado vou tentar achar o nome correto. Obrigado



10. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 23/10/2020 - 08:04h

pekka0202 escreveu:

No Synpatic só tem o pgadmin3.

digitei o nome do pacote e não deu em nada, deve ser pelo estar errado vou tentar achar o nome correto. Obrigado

P ver os pacotes instalados no seu computador rode
apt list --installed | grep pgadmin
o apt-cache mostra os pacotes q a distro disponibiliza p instalação. No seu caso sua distro não tem a versão 4. Então ou vc instala a versão 3 ou tenta baixar a v4 no site do desenvolvedor e instala separado



11. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

ijoaovictor76@gmail.com
pekka0202

(usa Linux Mint)

Enviado em 23/10/2020 - 12:57h

as tentativas anteriores de instalar o pg4 deram os erros que eu coloquei no inicio do post. Tem como instalar p pg3 e ai atualizar para o 4 ?



12. Re: Não consigo instalar o pgadmin4 [RESOLVIDO]

ijoaovictor76@gmail.com
pekka0202

(usa Linux Mint)

Enviado em 23/10/2020 - 14:09h

Já solucionei o problema. Obrigado quem ajudou.

O site que encontrei a solução. https://medium.com/@ogunyemijeremiah/installing-pgadmin-4-on-linux-mint-20-ulyana-741b941479c9



01 02