Comandos Não funcionam no editor VI [RESOLVIDO]

1. Comandos Não funcionam no editor VI [RESOLVIDO]

Nathan
Kumk

(usa Linux Mint)

Enviado em 14/01/2020 - 16:36h

Olá! estou tentando editar um arquivo no vi, porem os comandos como: :q, :w e :wq não estão funcionando, quando aperto as teclas aparece escrito recording @q

Por que isto esta ocorrendo?

Grato!!

(estou usando o debian 10)


  


2. Re: Comandos Não funcionam no editor VI [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 14/01/2020 - 17:48h


Kumk escreveu:

Olá! estou tentando editar um arquivo no vi, porem os comandos como: :q, :w e :wq não estão funcionando, quando aperto as teclas aparece escrito recording @q

Por que isto esta ocorrendo?

Grato!!

(estou usando o debian 10)


digita só a letra "q" para parar a gravação !!


------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Re: Comandos Não funcionam no editor VI [RESOLVIDO]

Stanislaus K
StanislausK

(usa Debian)

Enviado em 14/01/2020 - 17:55h

Ola,

se voce quer salvar algo no arquivo, clique em ESC, e depois, ZZ para fechar e salvar, ou ZQ para fechar e não salvar...

ou também, clique em ESC, e depois em : e q! para fechar e não salvar ou wq para fechar e salvar...

voce consegue fazer isso? Seria esse o problema:

What is vim recording and how can it be disabled?
https://stackoverflow.com/questions/1527784/what-is-vim-recording-and-how-can-it-be-disabled





4. Re: Comandos Não funcionam no editor VI

guga lara
marimbondo2

(usa Outra)

Enviado em 14/01/2020 - 21:58h

Acho que ao invés de digitar ' :q ' você deve estar digitando ' ;q '


5. Re: Comandos Não funcionam no editor VI [RESOLVIDO]

Nathan
Kumk

(usa Linux Mint)

Enviado em 15/01/2020 - 03:23h


marimbondo2 escreveu:

Acho que ao invés de digitar ' :q ' você deve estar digitando ' ;q '


Acho que era isso mesmo, funcionou!!

Muito Obrigado!






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts