Office WPS no Centos 6.8_64 [RESOLVIDO]

1. Office WPS no Centos 6.8_64 [RESOLVIDO]

Carlos Cesar
ccsar

(usa CentOS)

Enviado em 20/10/2016 - 11:29h

Ola Pessoal.

Estou tentando instalar o Office WPS no meu Centos 6.8_64 mas tá dando os seguintes erros:
- Com a versão wps-office_10.1.0.567~a21_x86_64.tar.xz
O erro é este: - ./office6/wps: /lib/libc.so.6: version GLIBC_2.14 not found

Com versão .rpm o erro é este:
Requires: libc.so.6(GLIB_2.15)(64bits)

Procurei a libc.so.6 e ela esta no sistema em /lib e em /lib/i686/nosegneg
Alguém conseguiu rodar o Office WPS no Centos 64?

Obrigado.
César


  


2. Re: Office WPS no Centos 6.8_64 [RESOLVIDO]

johnf
johnf

(usa Slackware)

Enviado em 20/10/2016 - 12:11h

Quando eu tentei instalar no Slack deu um erro parecido.

Resolvi instalando algumas libs.

Instale o pacote de libs libpng-legacy12 ou o equivalente à sua distro.

Valeu!


3. Re: Office WPS no Centos 6.8_64 [RESOLVIDO]

Carlos Cesar
ccsar

(usa CentOS)

Enviado em 20/10/2016 - 12:20h

Oi John,

Tentei agora algumas libpng(s) mas o erro continua.

Obrigado pela resposta.


4. Re: Office WPS no Centos 6.8_64 [RESOLVIDO]

Fernando T. Da Silva
nandosilva

(usa Lubuntu)

Enviado em 20/10/2016 - 22:23h

libc.so.6 é apenas um link para a lib principal que pode ser para libc.so de versão 14, 20, 22 etc...relacionado ao pacote glibc, nem tente instalar um pacote desta libc (glibc) que não faz parte da sua versão que você danificará o teu sistema. A versão do WPS tem ser compilada com a mesma versão do teu glibc, senão não rodara de jeito nenhum. Tenta obter o sources e compile no teu sistema.

Nota:
Se o wps requer uma glibc superior a sua instalada, você pode então tentar usar uma mais antiga que talvez tenha sido compilada com a versão do teu glibc. Exemplo, se a versão atual do wps é 5, tente achar um pacote da versão 4 ou 3 instale para ver se funciona.


5. Re: Office WPS no Centos 6.8_64 [RESOLVIDO]

Carlos Cesar
ccsar

(usa CentOS)

Enviado em 21/10/2016 - 12:24h

O Fato é que não encontro mais as verões anteriores para baixar.

Valeu pela dica.

Eu instalei em máquinas com Ubuntu e gostei muito....
Mas no Centos 6_64 não consegui mesmo.
Por hora vou continuar usando o Libre Office mesmo, ele me serve bem.

Obrigado