Emerge - Nothing to sync... returning (Só por Curiosidade) [RESOLVIDO]

1. Emerge - Nothing to sync... returning (Só por Curiosidade) [RESOLVIDO]

Kowalski
kowalskii

(usa Arch Linux)

Enviado em 07/10/2017 - 16:27h

Boa tarde galera, tudo certo?
Estou abrindo esse tópico mais por curiosidade, não terei tempo de dar sequencia a instalação do Funtoo por enquanto, mas gostaria de saber o que causa isso para a próxima vez, visto que não é a primeira vez que tento e isto ocorre.

Estava mais cedo tentando intalar o funtoo através do System Rescue CD.
Criei partição, havia montado os diretórios certinho, data estava certa, tinha descompactado o stage3, feito chroot, rede comunicando, resolvendo DNS normalmente, mas quando executo o emerge --sync retorna a mensagem:

(Chroot) sysresccd / # emerge --sync
Nothing to sync... returning


Fiz uma breve pesquisa e não achei nada... acabei abandonando por hora, mas... Alguém sabe o que pode ter causado isso?
Abraço


  


2. MELHOR RESPOSTA

carlos reis
slblxs

(usa Funtoo)

Enviado em 08/10/2017 - 06:07h

kowalskii escreveu:

Sim, o link que eles indicam para baixar e descompactar não funciona: http://ftp.osuosl.org/pub/funtoo/funtoo-current/snapshots/portage-latest.tar.xz
Forbidden

You don't have permission to access /pub/funtoo/funtoo-current/snapshots/portage-latest.tar.xz on this server.

-----------------------------------------
---- Linux Counter #606350 ----


Caro @kowalski não é esse o comando. Tem existido algumas alterações nos repositórios e até na forma de sincronizar os repos, o comando que tem que sincronizar é este;

 
(chroot) # ego sync
(chroot) # emerge -auDN @world


Aqui tens essa alteração na wiki de instalação http://www.funtoo.org/Install#Downloading_the_Portage_tree e aqui para quem já tenha instalado tem que seguir esses passos http://www.funtoo.org/News:Kits_Are_Go_(And_Ego_Needs_a_Manual_Bump)

3. Re: Emerge - Nothing to sync... returning (Só por Curiosidade) [RESOLVIDO]

Mashn
Mashn

(usa Outra)

Enviado em 07/10/2017 - 17:36h

Como está seu make.conf?


4. Re: Emerge - Nothing to sync... returning (Só por Curiosidade) [RESOLVIDO]

Kowalski
kowalskii

(usa Arch Linux)

Enviado em 07/10/2017 - 18:35h

Mashn escreveu:

Como está seu make.conf?


Vazio amigo, nao fiz nenhuma alteracao nele. Segui os passos da wiki: http://www.funtoo.org/Install/pt-br#Downloading_the_Portage_tree

-----------------------------------------
---- Linux Counter #606350 ----


5. Re: Emerge - Nothing to sync... returning (Só por Curiosidade)

Mashn
Mashn

(usa Outra)

Enviado em 07/10/2017 - 18:44h

kowalskii escreveu:

Mashn escreveu:

Como está seu make.conf?


Vazio amigo, nao fiz nenhuma alteracao nele. Segui os passos da wiki: http://www.funtoo.org/Install/pt-br#Downloading_the_Portage_tree

-----------------------------------------
---- Linux Counter #606350 ----


Tentou este método? http://www.funtoo.org/Installing_Portage_From_Snapshot


6. Re: Emerge - Nothing to sync... returning (Só por Curiosidade) [RESOLVIDO]

Kowalski
kowalskii

(usa Arch Linux)

Enviado em 07/10/2017 - 22:16h

Sim, o link que eles indicam para baixar e descompactar não funciona: http://ftp.osuosl.org/pub/funtoo/funtoo-current/snapshots/portage-latest.tar.xz
Forbidden

You don't have permission to access /pub/funtoo/funtoo-current/snapshots/portage-latest.tar.xz on this server.

-----------------------------------------
---- Linux Counter #606350 ----


7. Re: Emerge - Nothing to sync... returning (Só por Curiosidade) [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 08/10/2017 - 16:50h

Baixou o instantâneo?

Gu kibum kelkum-ishi, burzum-ishi. Akha-gum-ishi ashi gurum...  



8. Re: Emerge - Nothing to sync... returning (Só por Curiosidade)

Kowalski
kowalskii

(usa Arch Linux)

Enviado em 08/10/2017 - 23:01h

slblxs escreveu:
Caro @kowalski não é esse o comando. Tem existido algumas alterações nos repositórios e até na forma de sincronizar os repos, o comando que tem que sincronizar é este;

 
(chroot) # ego sync
(chroot) # emerge -auDN @world


Aqui tens essa alteração na wiki de instalação http://www.funtoo.org/Install#Downloading_the_Portage_tree e aqui para quem já tenha instalado tem que seguir esses passos http://www.funtoo.org/News:Kits_Are_Go_(And_Ego_Needs_a_Manual_Bump)


Puts... Maldita mania de ver a wiki versão português hein... Deve estar desatualizada.
Muito obrigado pela informação. Assim que sobrar um tempinho vou instalar de novo e seguir esses passos. Acabei instalando o Slack :P
mas tenho um espaço vazio no HD reservado para o Funtoo. Obrigado mesmo.

morgoth_bauglir escreveu:
Baixou o instantâneo?

Não consegui baixá-lo. Mas vou seguir a dica do @slblxs, nem estava por dentro dessas alterações.
___________________

Edit: Testei na máquina virtual, com o comando "ego sync" deu certo. Só não sei se vai clonar o git aqui por causa do firewall, mas depois em casa testo na máquina real. Muito obrigado!

-----------------------------------------
---- Linux Counter #606350 ----


9. Re: Emerge - Nothing to sync... returning (Só por Curiosidade) [RESOLVIDO]

carlos reis
slblxs

(usa Funtoo)

Enviado em 09/10/2017 - 11:53h

kowalskii escreveu:

slblxs escreveu:
Caro @kowalski não é esse o comando. Tem existido algumas alterações nos repositórios e até na forma de sincronizar os repos, o comando que tem que sincronizar é este;

 
(chroot) # ego sync
(chroot) # emerge -auDN @world


Aqui tens essa alteração na wiki de instalação http://www.funtoo.org/Install#Downloading_the_Portage_tree e aqui para quem já tenha instalado tem que seguir esses passos http://www.funtoo.org/News:Kits_Are_Go_(And_Ego_Needs_a_Manual_Bump)


Puts... Maldita mania de ver a wiki versão português hein... Deve estar desatualizada.
Muito obrigado pela informação. Assim que sobrar um tempinho vou instalar de novo e seguir esses passos. Acabei instalando o Slack :P
mas tenho um espaço vazio no HD reservado para o Funtoo. Obrigado mesmo.

morgoth_bauglir escreveu:
Baixou o instantâneo?

Não consegui baixá-lo. Mas vou seguir a dica do @slblxs, nem estava por dentro dessas alterações.
___________________

Edit: Testei na máquina virtual, com o comando "ego sync" deu certo. Só não sei se vai clonar o git aqui por causa do firewall, mas depois em casa testo na máquina real. Muito obrigado!

-----------------------------------------
---- Linux Counter #606350 ----


Não tem de quê, por isso deixei de seguir a instalação em português. Existem sempre pormenores, ou alterações.


10. Re: Emerge - Nothing to sync... returning (Só por Curiosidade) [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 09/10/2017 - 16:23h

funtoo mudou os repositórios e o kernel.

siga os links novos, que os colegas mandaram

Sobre o make.conf vazio, geralmente não funciona legal. Para editar, vc pode fazer uma busca, tipo:

"make.conf for funtoo. Use flags for gentoo; safe flags for gentoo etc....
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨
Albfneto,
Ribeirão Preto, S.P., Brasil.
Usuário Linux, Linux Counter: #479903.
Distros Favoritas: Sabayon, Gentoo, openSUSE, Mageia e OpenMandriva.


11. Re: Emerge - Nothing to sync... returning (Só por Curiosidade) [RESOLVIDO]

Kowalski
kowalskii

(usa Arch Linux)

Enviado em 09/10/2017 - 16:37h

albfneto escreveu:

funtoo mudou os repositórios e o kernel.

siga os links novos, que os colegas mandaram

Sobre o make.conf vazio, geralmente não funciona legal. Para editar, vc pode fazer uma busca, tipo:

"make.conf for funtoo. Use flags for gentoo; safe flags for gentoo etc....


Parece que o "ego sync" funcionará, só não consegui sincronizar aqui porque estou no trabalho, acho que o git, ou o protocolo que ele usa, é bloqueado.
É minha primeira instalação do Funtoo então não manjo nada ainda :P

Muito obrigado pelas suas dicas @albfneto, vou pesquisar usando os termos que você sugeriu.

Agradeço a todos que contribuíram e buscaram me ajudar, abraço :D
-----------------------------------------
---- Linux Counter #606350 ----