Não consigo instalar o firebird [RESOLVIDO]

1. Não consigo instalar o firebird [RESOLVIDO]

Péricles Guimarães Fortes
pgfortes

(usa Debian)

Enviado em 07/12/2010 - 16:44h

Olá pessoal, sou iniciante em linux e novo aqui VOL.
Gostaria que qlguem me auxiliiasse, pois não estou conseguindo instalar o firebird.
Já tentei instalar de várias maneiras, uma delas conforme o artigo http://www.vivaolinux.com.br/artigo/Instalando-o-Firebird-no-Debian/ , quando tento instalar da a seguinte mesnagem:

ServerSamba:~# aptitude install firebird2-super-server firebird2-utils-super firebird2-dev
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Lendo descrições de tarefas... Pronto
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "firebird2-super-server"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "firebird2-utils-super"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "firebird2-dev"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "firebird2-super-server"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "firebird2-utils-super"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "firebird2-dev"
Nenhum pacote será instalado, atualizado ou removido.
0 pacotes atualizados, 0 novos instalados, 0 a serem removidos e 3 não atualizados.
É preciso obter 0B de arquivos. Depois do desempacotamento, 0B serão usados.
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Lendo descrições de tarefas... Pronto

O que me parece que não foi instalado.

Minha situação é a seguinte:
tenho problemas com vírus na minha rede e gostaria de isolar meu sistema de controle da empresa em um servidor linux, para hospedar o banco de dados em firebird.

como o ubuntu eu consigo instalar o firebird mas no debian não tem jeito.
Desde já muito obrigado.


  


2. Re: Não consigo instalar o firebird [RESOLVIDO]

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 07/12/2010 - 18:37h

Péricles,

você não menciona qual a versão, mas vou supor que seja o lenny

tente aptitude install firebird2.0-super

e veja se muda alguma coisa.



3. Riesdra

Péricles Guimarães Fortes
pgfortes

(usa Debian)

Enviado em 10/12/2010 - 15:09h

Desulpe-me pela falha mas é o Lenny sim.
Tentei como sua dica, mas...
ServerSamba:/# aptitude install firebird2.0-super
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Lendo descrições de tarefas... Pronto
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "firebird2.0-super"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "firebird2.0-super"
Nenhum pacote será instalado, atualizado ou removido.
0 pacotes atualizados, 0 novos instalados, 0 a serem removidos e 3 não atualizados.
É preciso obter 0B de arquivos. Depois do desempacotamento, 0B serão usados.
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Lendo descrições de tarefas... Pronto

ServerSamba:/#



4. Re: Não consigo instalar o firebird [RESOLVIDO]

Péricles Guimarães Fortes
pgfortes

(usa Debian)

Enviado em 10/12/2010 - 15:17h


Antes que eu esqueça...
Riesdra obrigado pela força

Hoje tentei de outra forma mas agora para quando solicidado a senha do sysdba, informo a senha e pede novamente como se não aceitasse.

ServerSamba:/home/jonnes/Desktop/agora# cd FirebirdSS*
ServerSamba:/home/jonnes/Desktop/agora/FirebirdSS-2.1.3.18185-0.i686# ./install.sh

Firebird super 2.1.3.18185-0.i686 Installation

Press Enter to start installation or ^C to abort
Extracting install data



--- Warning ----------------------------------------------
The installation target directory: /opt/firebird
Already contains a prior installation of InterBase/Firebird.
This and files found in /usr/include and /usr/lib will be
archived in the file : /opt/firebird_20101210_1438.tar.gz

Press return to continue or ^C to abort
Archiving...
Done.
Deleting...
Done.
update-rc.d: warning: /etc/init.d/firebird missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
System startup links for /etc/init.d/firebird already exist.
Starting Firebird server: /opt/firebird/bin/fbmgr.bin: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

Fixing firebird's shell to /bin/sh

usermod : nenhuma mudança
Starting Firebird server: /opt/firebird/bin/fbmgr.bin: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory
Please enter new password for SYSDBA user: masterkey
/opt/firebird/bin/gsec: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

Please enter new password for SYSDBA user:


Mais uma vez obrigado por enquanto


5. Re: Não consigo instalar o firebird [RESOLVIDO]

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 10/12/2010 - 15:18h

esta dando erro com as bibliotecas ncurses, nunca instalei manual, só via aptitude

o que retorna o comando?

aptitude search firebird




6. Re: Não consigo instalar o firebird [RESOLVIDO]

Péricles Guimarães Fortes
pgfortes

(usa Debian)

Enviado em 13/12/2010 - 14:06h

Não tenho retorno:

ServerSamba:/home/jonnes# aptitude search firebird
ServerSamba:/home/jonnes#




7. Re: Não consigo instalar o firebird [RESOLVIDO]

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 14/12/2010 - 13:12h

posta o arquivo sources.list aqui, para vermos pois está estranho.


8. Re: Não consigo instalar o firebird [RESOLVIDO]

Péricles Guimarães Fortes
pgfortes

(usa Debian)

Enviado em 15/12/2010 - 11:33h

Gostaria primeiramente agradecer muito pela ajuda.

E informar que consegui instalar, baixei o libstdc++5_3.3.6-18_amd64.deb juntamente com o FirebirdSS-2.5.0.26074-0.amd64 e consegui finalmente.

Se alguem precisar de maiores detalhes podes me enviar um e-mail que respondo. vou criar um artigo de como eu fiz, pois não encontrei em lugar algum.

Agradeço pelo empenho.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts