Erro no Yum update [RESOLVIDO]

1. Erro no Yum update [RESOLVIDO]

William Lima
willdoidao

(usa Ubuntu)

Enviado em 24/01/2015 - 17:09h

Estou com um erro muito estranho do fedora 21, toda vez que tento atualizar ele faz a verificação corretamente, baixa os pacotes mas após isso dá a seguinte mensagem:

Tamanho total: 405 M
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
/usr/lib/python2.7/site-packages/yum/history.py:763: UnicodeWarning: Unicode equal comparison failed to convert both arguments to Unicode - interpreting them as being unequal
if checksum == sql_checksum:
Traceback (most recent call last):
File "/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/yummain.py", line 371, in user_main
errcode = main(args)
File "/usr/share/yum-cli/yummain.py", line 277, in main
return_code = base.doTransaction(inhibit=inhibit)
File "/usr/share/yum-cli/cli.py", line 797, in doTransaction
resultobject = self.runTransaction(cb=cb)
File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1794, in runTransaction
self.skipped_packages, rpmdb_problems, cmdline)
File "/usr/lib/python2.7/site-packages/yum/history.py", line 943, in beg
pid = self.pkg2pid(txmbr.po)
File "/usr/lib/python2.7/site-packages/yum/history.py", line 800, in pkg2pid
return self._ipkg2pid(po, create)
File "/usr/lib/python2.7/site-packages/yum/history.py", line 794, in _ipkg2pid
return self._pkgtup2pid(po.pkgtup, csum, create)
File "/usr/lib/python2.7/site-packages/yum/history.py", line 777, in _pkgtup2pid
checksum))
File "/usr/lib/python2.7/site-packages/yum/sqlutils.py", line 168, in executeSQLQmark
return cursor.execute(query, params)
sqlite3.ProgrammingError: You must not use 8-bit bytestrings unless you use a text_factory that can interpret 8-bit bytestrings (like text_factory = str). It is highly recommended that you instead just switch your application to Unicode strings.



  


2. Re: Erro no Yum update [RESOLVIDO]

Hugo Cerqueira
hrcerq

(usa Outra)

Enviado em 25/01/2015 - 16:10h


Parece que o banco de dados do yum está corrompido. Pesquisei sobre esse erro e só encontrei uma pessoa que conseguiu resolver, mas a solução é um pouco "crua". Aqui está o link:

https://ask.fedoraproject.org/en/question/33607/yum-update-unicodewarning-sqlite3programmingerror/

Acho um pouco arriscado. Talvez uma limpeza geral no cache do yum resolva, então talvez que você queira tentar isso primeiro:

yum clean all 



3. Re: Erro no Yum update [RESOLVIDO]

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 25/01/2015 - 16:25h

Já tentou atualizar pelo Yumex ??


4. Re: Erro no Yum update [RESOLVIDO]

Ruan
ru4n

(usa Debian)

Enviado em 25/01/2015 - 17:45h

Poste o resultado do comando locale
- -
~ ru4n


5. Re: Erro no Yum update [RESOLVIDO]

William Lima
willdoidao

(usa Ubuntu)

Enviado em 25/01/2015 - 23:15h

Funcionou!!!

Baixei o arquivo do link: https://gist.github.com/joepreludian/8948978/download#
E substitui o arquivo! Muito obrigado pela ajuda!


6. Re: Erro no Yum update [RESOLVIDO]

Mayco Luis
sedexx

(usa Outra)

Enviado em 02/02/2015 - 13:57h


Diga-me aonde colocou esse arquivos, para eu fazer no meu



7. Re: Erro no Yum update [RESOLVIDO]

William Lima
willdoidao

(usa Ubuntu)

Enviado em 02/02/2015 - 14:01h


/usr/lib/python2.7/site-packages/


8. Complexidade de senha

Vanessa Duarte
vduarte

(usa Ubuntu)

Enviado em 11/08/2017 - 10:45h

Esse tipo de erro se dá por causa da complexidade da senha. Eu consegui resolver criando uma senha de 7 dígitos, contendo 1 caracter especial e 1 número.
Mas se você já tentou promover o domínio uma vez, antes de tentar novamente remova a pasta através deste comando
# rm –Rf /usr/local/samba
e depois execute o make install novamente. Depois promova o domínio usando uma senha com as complexidades que mencionei. Pra mim deu certo ;)