Falha no HD

1. Falha no HD

Geraldo José Ferreira Chagas Júnior
gjr_rj

(usa Debian)

Enviado em 23/03/2010 - 01:31h

Olá pessoal!

inclui um segundo HD em minha máquina (Deabian lenny) como master na IDE 2. Ao carregar o o sistema apresenata o erro abaixo:

# more /var/log/dmesg
...
[ 6.036199] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 6.037669] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 6.037669] ide: failed opcode was: unknown
[ 6.086268] usb usb3: SerialNumber: 0000:00:03.2
[ 6.103737] ACPI: PCI Interrupt 0000:00:03.3[D] -> GSI 23 (level, low) -> IRQ 23
[ 6.121403] ehci_hcd 0000:00:03.3: EHCI Host Controller
[ 6.139038] ehci_hcd 0000:00:03.3: new USB bus registered, assigned bus number 4
[ 6.159057] PCI: cache line size of 64 is not supported by device 0000:00:03.3
[ 6.159078] ehci_hcd 0000:00:03.3: irq 23, io mem 0xcffff000
[ 6.186452] ehci_hcd 0000:00:03.3: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
[ 6.204126] usb usb4: configuration #1 chosen from 1 choice
[ 6.221765] hub 4-0:1.0: USB hub found
[ 6.239757] hub 4-0:1.0: 8 ports detected
[ 6.356165] usb usb4: New USB device found, idVendor=1d6b, idProduct=0002
[ 6.373918] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 6.391697] usb usb4: Product: EHCI Host Controller
[ 6.411700] usb usb4: Manufacturer: Linux 2.6.26-2-686 ehci_hcd
[ 6.429350] usb usb4: SerialNumber: 0000:00:03.3
[ 6.508982] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 6.512020] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 6.512020] ide: failed opcode was: unknown
[ 6.940004] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 6.940004] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 6.940004] ide: failed opcode was: unknown
[ 7.522449] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 7.522449] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 7.522449] ide: failed opcode was: unknown
[ 7.522449] hdc: UDMA/25 mode selected
[ 7.651278] ide1: reset: success
[ 8.108979] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 8.108979] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 8.108979] ide: failed opcode was: unknown
[ 8.540005] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 8.540005] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 8.540005] ide: failed opcode was: unknown
[ 8.540005] ide: failed opcode was: unknown
[ 8.872005] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 8.872005] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 8.872005] ide: failed opcode was: unknown
[ 9.713550] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 9.713550] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 9.713550] ide: failed opcode was: unknown
[ 9.713550] hdc: UDMA/16 mode selected
[ 9.830192] ide1: reset: success
[ 10.280004] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 10.280004] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 10.280004] ide: failed opcode was: unknown
[ 10.280004] end_request: I/O error, dev hdc, sector 0
[ 10.280004] Buffer I/O error on device hdc, logical block 0
[ 10.784004] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 10.784004] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 10.784004] ide: failed opcode was: unknown
[ 11.284004] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 11.284004] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 11.284004] ide: failed opcode was: unknown
[ 11.872005] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 11.872005] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 11.872005] ide: failed opcode was: unknown
[ 12.402404] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
[ 12.402404] hdc: dma_intr: error=0x84 { DriveStatusError BadCRC }
[ 12.402404] ide: failed opcode was: unknown
[ 12.402404] hdc: no DMA mode selected

...

O sistema carrega então eu listo os dispositivos e aparece:

# ls -l /dev/hdc*
brw-rw---- 1 root disk 22, 0 Mar 23 01:11 /dev/hdc

ou seja, nada de hdc1.

então, eu uso o hdparm e:




  


2. Re: Falha no HD

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 23/03/2010 - 01:51h

deixe eu ver se entendi....
vc colocou o 2 o HD, como Master, mas tem o Debian no primeiro, HD, que agora é slave...
acho que vai perder o boot, a não seu que troque na BIOS a ordem dos dispositivos, colocando o CDROM e depois o HDD SLAVE como dispositivo de boot.


3. Re: Falha no HD

Geraldo José Ferreira Chagas Júnior
gjr_rj

(usa Debian)

Enviado em 23/03/2010 - 02:08h

Acho que resolveu, o HD que estava na IDE 2 pifou. Acho que era esse o erro.