Partição "/" (root) cheia [RESOLVIDO]

1. Partição "/" (root) cheia [RESOLVIDO]

Raphael
cheatermaldito

(usa Debian)

Enviado em 12/11/2012 - 19:41h

Olá pessoal,

Instalei um servidor Debian 6.0 (squeeze), com Samba + Apache PHP + MySQL + Webmin.

Do nada, me deparo com esta situação:

[email protected]:/# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/vol1-root
46G 46G 0 100% /
tmpfs 1.9G 0 1.9G 0% /lib/init/rw
udev 1.9G 240K 1.9G 1% /dev
tmpfs 1.9G 0 1.9G 0% /dev/shm
/dev/sda1 228M 16M 201M 8% /boot
/dev/mapper/vol1-home
551G 200M 522G 1% /home
/dev/mapper/vol2-storage
1.8T 897G 844G 52% /storage
/dev/mapper/vol1-temp
19G 172M 18G 1% /tmp
/dev/mapper/vol1-usr 28G 1.8G 25G 7% /usr
/dev/mapper/vol1-var 39G 4.4G 33G 12% /var
/dev/sdd1 932G 44G 889G 5% /media/BKP_CRIACAO
/dev/sde1 932G 332M 932G 1% /media/BKP_BRD_UATT
[email protected]:/#

As partições /boot, /home, /storage, /tmp e /var estão separadas do /, não sei como o HD foi encher desse jeito, de uma hora para outra.

O que eu fiz antes de acontecer este problema (coincidência ou não) foi instalar o webmin e desinstalar o desktop através do comando tasksel remove desktop.

Alguem poderia me dar uma força pra descobrir o que pode estar acontecendo?

Valeu!


  


2. Re: Partição "/" (root) cheia [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 12/11/2012 - 19:48h

cheatermaldito escreveu:

Olá pessoal,

Instalei um servidor Debian 6.0 (squeeze), com Samba + Apache PHP + MySQL + Webmin.

Do nada, me deparo com esta situação:

[email protected]:/# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/vol1-root
46G 46G 0 100% /
tmpfs 1.9G 0 1.9G 0% /lib/init/rw
udev 1.9G 240K 1.9G 1% /dev
tmpfs 1.9G 0 1.9G 0% /dev/shm
/dev/sda1 228M 16M 201M 8% /boot
/dev/mapper/vol1-home
551G 200M 522G 1% /home
/dev/mapper/vol2-storage
1.8T 897G 844G 52% /storage
/dev/mapper/vol1-temp
19G 172M 18G 1% /tmp
/dev/mapper/vol1-usr 28G 1.8G 25G 7% /usr
/dev/mapper/vol1-var 39G 4.4G 33G 12% /var
/dev/sdd1 932G 44G 889G 5% /media/BKP_CRIACAO
/dev/sde1 932G 332M 932G 1% /media/BKP_BRD_UATT
[email protected]:/#

As partições /boot, /home, /storage, /tmp e /var estão separadas do /, não sei como o HD foi encher desse jeito, de uma hora para outra.

O que eu fiz antes de acontecer este problema (coincidência ou não) foi instalar o webmin e desinstalar o desktop através do comando tasksel remove desktop.

Alguem poderia me dar uma força pra descobrir o que pode estar acontecendo?

Valeu!


Bom sugestão é
desmonta os /media/BKP_CRIACAO e /media/BKP_BRD_UATT e verifica novamente se tem alguns arquivo gravado no /media/BKP_CRIACAO /media/BKP_BRD_UATT
só por curiosidade são HDs externos esses ?



3. Re: Partição "/" (root) cheia [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 12/11/2012 - 19:48h

Veja quais os maiores diretórios com o comando du.

# cd /
# du * -hs


4. Re: Partição "/" (root) cheia [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 12/11/2012 - 19:54h

o bom mesmo seria se tu tivesse o ncdu
seria melhor de visualizar

http://www.vivaolinux.com.br/dica/Usando-o-NcDU-%28Ncurses-Disk-Usage%29/


5. Re: Partição "/" (root) cheia [RESOLVIDO]

Raphael
cheatermaldito

(usa Debian)

Enviado em 12/11/2012 - 20:21h

danniel-lara escreveu:

Bom sugestão é
desmonta os /media/BKP_CRIACAO e /media/BKP_BRD_UATT e verifica novamente se tem alguns arquivo gravado no /media/BKP_CRIACAO /media/BKP_BRD_UATT
só por curiosidade são HDs externos esses ?


Então.. /media/BKP_CRIACAO e /media/BKP_BRD_UATT são dois HD's externos, montados automaticamente através do fstab no boot. Estes também estão fora do /.

Vlw!


6. Re: Partição "/" (root) cheia [RESOLVIDO]

Raphael
cheatermaldito

(usa Debian)

Enviado em 12/11/2012 - 20:30h

amarildosertorio escreveu:

Veja quais os maiores diretórios com o comando du.

# cd /
# du * -hs


[email protected]:/# du * -hs
4.8M bin
16M boot
240K dev
11M etc
2.4M home
0 initrd.img
114M lib
16K lost+found
73G media
4.0K mnt
4.0K opt
du: cannot access `proc/17937/task/17937/fd/4': No such file or directory
du: cannot access `proc/17937/task/17937/fdinfo/4': No such file or directory
du: cannot access `proc/17937/fd/4': No such file or directory
du: cannot access `proc/17937/fdinfo/4': No such file or directory
0 proc
136K root
5.1M sbin
4.0K selinux
8.0K srv
897G storage
0 sys
40K tmp
1.6G usr
4.2G var
0 vmlinuz
12K webmin-setup.out
[email protected]:/# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/vol1-root 46G 46G 0 100% /

outra detalhe é que após ter feito um simples reboot (shutdown -r now), a partição / montou em modo read only, já com 100% de uso. Usei o comando mount -n -o /, mas não consigo achar o arquivo que lotou esta partição...



7. Re: Partição "/" (root) cheia [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 12/11/2012 - 20:35h

cheatermaldito escreveu:

danniel-lara escreveu:

Bom sugestão é
desmonta os /media/BKP_CRIACAO e /media/BKP_BRD_UATT e verifica novamente se tem alguns arquivo gravado no /media/BKP_CRIACAO /media/BKP_BRD_UATT
só por curiosidade são HDs externos esses ?


Então.. /media/BKP_CRIACAO e /media/BKP_BRD_UATT são dois HD's externos, montados automaticamente através do fstab no boot. Estes também estão fora do /.

Vlw!


bom eu tive problema com isso
como eram usb e na hora de fazer backup a usb desconectava sozinha e lotava a /media
sugiro que desmonte essas partições e reinicia a maquina e verifica novamente se é mesmo essa partição que esta lotada

espero que ajude


8. Re: Partição "/" (root) cheia [RESOLVIDO]

Raphael
cheatermaldito

(usa Debian)

Enviado em 12/11/2012 - 20:41h

danniel-lara escreveu:

bom eu tive problema com isso
como eram usb e na hora de fazer backup a usb desconectava sozinha e lotava a /media
sugiro que desmonte essas partições e reinicia a maquina e verifica novamente se é mesmo essa partição que esta lotada

espero que ajude


Boa! Não havia pensado nisso. Vou esperar a job do backup terminar, e verificar isso...
Se for esse o problema, vou ter que criar outro volume e mapear como /media pra deixar fora do /.

Depois que terminar o backup eu posto aqui se era isso! Valeu brother.




9. Re: Partição "/" (root) cheia [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 12/11/2012 - 20:44h

danniel-lara escreveu:

cheatermaldito escreveu:

danniel-lara escreveu:

Bom sugestão é
desmonta os /media/BKP_CRIACAO e /media/BKP_BRD_UATT e verifica novamente se tem alguns arquivo gravado no /media/BKP_CRIACAO /media/BKP_BRD_UATT
só por curiosidade são HDs externos esses ?


Então.. /media/BKP_CRIACAO e /media/BKP_BRD_UATT são dois HD's externos, montados automaticamente através do fstab no boot. Estes também estão fora do /.

Vlw!


bom eu tive problema com isso
como eram usb e na hora de fazer backup a usb desconectava sozinha e lotava a /media
sugiro que desmonte essas partições e reinicia a maquina e verifica novamente se é mesmo essa partição que esta lotada

espero que ajude


Só por curiosidade, como resolveu o problema do usb desconectar sozinho ?


10. Re: Partição "/" (root) cheia [RESOLVIDO]

Daniel Lara Souza
danniel-lara

(usa Fedora)

Enviado em 12/11/2012 - 20:51h

eabreu escreveu:

danniel-lara escreveu:

cheatermaldito escreveu:

danniel-lara escreveu:

Bom sugestão é
desmonta os /media/BKP_CRIACAO e /media/BKP_BRD_UATT e verifica novamente se tem alguns arquivo gravado no /media/BKP_CRIACAO /media/BKP_BRD_UATT
só por curiosidade são HDs externos esses ?


Então.. /media/BKP_CRIACAO e /media/BKP_BRD_UATT são dois HD's externos, montados automaticamente através do fstab no boot. Estes também estão fora do /.

Vlw!


bom eu tive problema com isso
como eram usb e na hora de fazer backup a usb desconectava sozinha e lotava a /media
sugiro que desmonte essas partições e reinicia a maquina e verifica novamente se é mesmo essa partição que esta lotada

espero que ajude


Só por curiosidade, como resolveu o problema do usb desconectar sozinho ?


eu atualizei o kernel resolveu o problema
por algum motivo quando era feito o backup a USB se desconectava e eu procure na internet
e tinha um poste que o cara atualizou o kernel e resolveu o problema


11. Re: Partição "/" (root) cheia [RESOLVIDO]

Luís
clon¥

(usa Debian)

Enviado em 11/07/2014 - 18:16h

cheatermaldito escreveu:

Olá pessoal,

Instalei um servidor Debian 6.0 (squeeze), com Samba + Apache PHP + MySQL + Webmin.

Do nada, me deparo com esta situação:

[email protected]:/# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/vol1-root
46G 46G 0 100% /
tmpfs 1.9G 0 1.9G 0% /lib/init/rw
udev 1.9G 240K 1.9G 1% /dev
tmpfs 1.9G 0 1.9G 0% /dev/shm
/dev/sda1 228M 16M 201M 8% /boot
/dev/mapper/vol1-home
551G 200M 522G 1% /home
/dev/mapper/vol2-storage
1.8T 897G 844G 52% /storage
/dev/mapper/vol1-temp
19G 172M 18G 1% /tmp
/dev/mapper/vol1-usr 28G 1.8G 25G 7% /usr
/dev/mapper/vol1-var 39G 4.4G 33G 12% /var
/dev/sdd1 932G 44G 889G 5% /media/BKP_CRIACAO
/dev/sde1 932G 332M 932G 1% /media/BKP_BRD_UATT
[email protected]:/#

As partições /boot, /home, /storage, /tmp e /var estão separadas do /, não sei como o HD foi encher desse jeito, de uma hora para outra.

O que eu fiz antes de acontecer este problema (coincidência ou não) foi instalar o webmin e desinstalar o desktop através do comando tasksel remove desktop.

Alguem poderia me dar uma força pra descobrir o que pode estar acontecendo?

Valeu!


===========
Caríssimo,
Afinal, você conseguiu resolver o seu problema de espaço no "/"?

Eis as minhas partições e o meu problemas:

df -h
Sist. Arq. Size Used Avail Use% Montado em
/dev/sda2 19G 19G 0 100% /
tmpfs 1,9G 0 1,9G 0% /lib/init/rw
udev 1,9G 204K 1,9G 1% /dev
tmpfs 1,9G 0 1,9G 0% /dev/shm
/dev/sda4 1,8T 506G 1,2T 30% /home
/dev/sdb1 1,8T 1,2T 529G 70% /media/bkp-trab2-2TB
/dev/sdc1 1,8T 266G 1,5T 16% /media/trabalho2
/dev/sdd1 2,7T 488G 2,1T 19% /media/bkp-trab1-3TB
overflow 1,0M 0 1,0M 0% /tmp

O sda está em GPT, é possível aumentar o "/" por meio de comando (parted) sem precisar de uma reinstalação?

*** Já revisei várias pastas do tipo tmp, log e nada.

Aguardo com urgência e agradeço desde já aos colaboradores.
O que fez? Vc lembra?


12. Re: Partição "/" (root) cheia [RESOLVIDO]

Alberto Federman Neto.
albfneto

(usa Sabayon)

Enviado em 11/07/2014 - 18:35h

Post antigo, ressuscitado. 2012.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts