Os pacotes a seguir têm dependências desencontradas:

1. Os pacotes a seguir têm dependências desencontradas:

Renan Garcia de Almeida
[email protected]

(usa Debian)

Enviado em 07/03/2013 - 12:41h


Bom dia Amigos estou tentando instalar o LAMP para rodar o CAIIC 2.6, porém ao tentar instalar o my sql ocorre o seguite erro


[email protected]:/home/renan# apt-get install mysql
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote mysql
[email protected]:/home/renan# apt-get install mysql-server
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
mysql-server : Depende: mysql-server-5.1 mas não será instalado
E: Pacotes quebrados

---------------------------------------------

Este é meu source list

#

# deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official i386 CD Binary-1 20130223-13:15]/ squeeze main

#deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official i386 CD Binary-1 20130223-13:15]/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install. The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://ftp.debian.org/debian/ squeeze-updates main
deb-src http://ftp.debian.org/debian/ squeeze-updates main


Agradeço desde ja a ajuda.



  


2. Re: Os pacotes a seguir têm dependências desencontradas:

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 07/03/2013 - 12:52h

[email protected] escreveu:


Bom dia Amigos estou tentando instalar o LAMP para rodar o CAIIC 2.6, porém ao tentar instalar o my sql ocorre o seguite erro


[email protected]:/home/renan# apt-get install mysql
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote mysql
[email protected]:/home/renan# apt-get install mysql-server
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
mysql-server : Depende: mysql-server-5.1 mas não será instalado
E: Pacotes quebrados

---------------------------------------------

Este é meu source list

#

# deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official i386 CD Binary-1 20130223-13:15]/ squeeze main

#deb cdrom:[Debian GNU/Linux 6.0.7 _Squeeze_ - Official i386 CD Binary-1 20130223-13:15]/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install. The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
deb http://ftp.debian.org/debian/ squeeze-updates main
deb-src http://ftp.debian.org/debian/ squeeze-updates main


Agradeço desde ja a ajuda.


Adiciona o contrib e o non-free no sources.list e instala o mysql-server. Lembrando que isso pode desinstalar o postgresql ou o mariadb, caso você os use.


3. Re: Os pacotes a seguir têm dependências desencontradas:

Renan Garcia de Almeida
[email protected]

(usa Debian)

Enviado em 07/03/2013 - 12:59h

oLÁ lcavalheiro , obrigado pela ajuda, mas abusando da sua boa vontade só um pouco como faço pra adicionar essas linhas, sei que tenho que editar o source.list gedit/ete/apt/seource.list
mas o que devo adicionar no arquivo???


4. Re: Os pacotes a seguir têm dependências desencontradas:

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 07/03/2013 - 13:01h

[email protected] escreveu:

oLÁ lcavalheiro , obrigado pela ajuda, mas abusando da sua boa vontade só um pouco como faço pra adicionar essas linhas, sei que tenho que editar o source.list gedit/ete/apt/seource.list
mas o que devo adicionar no arquivo???


No seu sources.list você vai ver que algumas linhas terminam com a palavra main. Adicione após essa palavra main as palavras contrib e non-free. Vai ficar assim:
[quote]... main contrib non-free[/code]
Depois, roda um apt-get update, pra atualizar o cache do apt, e aí é correr pro abraço


5. Re: Os pacotes a seguir têm dependências desencontradas:

Renan Garcia de Almeida
[email protected]

(usa Debian)

Enviado em 07/03/2013 - 14:21h

lcavalheiro adicionado apt-get update ok, mas o erro continua... :(

vc tem um outro repositorio dessa versão do debian?


6. Re: Os pacotes a seguir têm dependências desencontradas:

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 07/03/2013 - 14:23h

[email protected] escreveu:

lcavalheiro adicionado apt-get update ok, mas o erro continua... :(

vc tem um outro repositorio dessa versão do debian?


O que o comando
$ apt-cache search mysql-server  
retorna?


7. Re: Os pacotes a seguir têm dependências desencontradas:

Renan Garcia de Almeida
[email protected]

(usa Debian)

Enviado em 07/03/2013 - 14:30h

[email protected]:/home/renan# apt-cache search mysql-server
cacti - Frontend to rrdtool for monitoring systems and services
mysql-server - MySQL database server (metapackage depending on the latest version)
mysql-server-5.1 - MySQL database server binaries and system database setup
mysql-server-core-5.1 - MySQL database server binaries



8. Re: Os pacotes a seguir têm dependências desencontradas:

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 07/03/2013 - 14:32h

[email protected] escreveu:

[email protected]:/home/renan# apt-cache search mysql-server
cacti - Frontend to rrdtool for monitoring systems and services
mysql-server - MySQL database server (metapackage depending on the latest version)
mysql-server-5.1 - MySQL database server binaries and system database setup
mysql-server-core-5.1 - MySQL database server binaries


Tenta instalar o mysql-server-core-5.1.


9. Re: Os pacotes a seguir têm dependências desencontradas:

Mauro da fontoura
MauroFontoura

(usa CentOS)

Enviado em 07/03/2013 - 14:41h

Pesquisei no site do Debiam e la diz o seguinte:


Package: mysql-server (5.1.66-0+squeeze1) [security]

servidor de banco de dados MySQL (meta-pacote dependente da última versão)

Este é um pacote vazio que depende da "melhor" versão do mysql-server do momento (atualmente, mysql-server-5.1), segundo os mantenedores do MySQL. Instale este pacote se está em dúvida sobre que versão do MySQL usar. Ele vai usar a versão recomendada pelos mantenedores do pacote.

MySQL é um servidor de banco de dados SQL rápido, estável e verdadeiramente multi-usuário e multi-tarefa. SQL (Structured Query Language - Linguagem Estruturada de Consulta) é a mais popular linguagem de consulta a banco de dados no mundo. Os principais objetivos buscados pelo MySQL são velocidade, robustez e facilidade de uso.




Eu conclui que voce deve instalar o pacote mysql-server-5.1.

# apt-get install mysql-server-5.1


10. Re: Os pacotes a seguir têm dependências desencontradas:

Renan Garcia de Almeida
[email protected]

(usa Debian)

Enviado em 07/03/2013 - 14:49h

o Core foi instalado com sucesso mann, mas ao executar o server-5.1 o erro continua :(
ah muito obrigado msm pela atenção (Y)


11. Re: Os pacotes a seguir têm dependências desencontradas:

Luís Fernando C. Cavalheiro
lcavalheiro

(usa Slackware)

Enviado em 07/03/2013 - 18:36h

Agora instala o mysql-server-5.1