OpenOffice 2.0

1. OpenOffice 2.0

Ricardo Franzen
rfranzen

(usa Ubuntu)

Enviado em 23/10/2005 - 00:57h

Boa noite

Mais alguém que instalou o OpenOffice2.0 através dos pacotes .deb que tem no site teve problemas com pacotes corrompidos?
Quando inicio o synaptic diz que tenho 16 pacotes quebrados. E estes são os do OpenOffice2.0. Já removi, baixei novamente e reinstalei os pacotes, mas não resolveu.
Alguém passou por isso? conseguiu resolver?


  


2. Re: OpenOffice 2.0

Perfil removido
removido

(usa Nenhuma)

Enviado em 23/10/2005 - 12:03h

O problema não são os pacotes, ou melhor, não é o download que corrompeu, mas as dependências quebradas.

O que ele disse é existem 16 erros nas dependências


3. OpenOffice 2.0

Angelo Cordovil
ANGELOO

(usa Linux Mint)

Enviado em 23/10/2005 - 16:49h

Tenta remover o pacote Openoffice, com o seguinte comando:
# apt-get --purge remove (nome do pacote).......
depois faça uma atualização do debian:
# apt-get update
e depois re instale o pacote


4. Re: OpenOffice 2.0

Ricardo Franzen
rfranzen

(usa Ubuntu)

Enviado em 23/10/2005 - 17:52h

Angeloo ja fiz isso, seria bom se tivesse pra instalar no apt, mas enquanto nao sai, vou instalar os pacotes que estao faltando. Na verdade não estao faltando, mas estao em versoes diferentes... (isso q o apt nao atualizou nada)


5. Re: OpenOffice 2.0

gustavo
guh

(usa Kurumin)

Enviado em 27/10/2005 - 22:35h

Me encontro com o mesmo problema..

dpkg: problemas de dependência impedem configuração de openoffice.org-writer:
openoffice.org-writer depende de libc6 (>= 2.3.5-1); porém:
Versão de libc6 no sistema é 2.3.2.ds1-22.
openoffice.org-writer depende de libgcc1 (>= 1:4.0.1); porém:
Versão de libgcc1 no sistema é 1:3.4.3-13.
openoffice.org-writer depende de libstdc++6 (>= 4.0.2); porém:
Versão de libstdc++6 no sistema é 3.4.3-13.


Erros foram encontrados durante processamento de:
openoffice.org-calc
openoffice.org-core02
openoffice.org-core04
openoffice.org-core04u
openoffice.org-core05
openoffice.org-core05u
openoffice.org-core09
openoffice.org-core10
openoffice.org-gnome-integration
openoffice.org-graphicfilter
openoffice.org-impress
openoffice.org-math
openoffice.org-pyuno
openoffice.org-spellcheck
openoffice.org-testtool
openoffice.org-writer

já tentei atualizar as versões dos seguintes arquivos: libc6, libstdc++6 e libgcc1, mais o problema persiste! Alguem sabe o que tenho que fazer?


6. Re: OpenOffice 2.0

Perfil removido
removido

(usa Nenhuma)

Enviado em 28/10/2005 - 11:33h

Creio que a atualização não é exatamente tão simples, ele depende do libc6 que existe apenas na unstable, ou seja, na versão stable definitivamente não permite usar o OpenOffice 2.0 (nem hoje nem nunca enquanto não tiver uma próxima versão), a testing um dia vai, mas hoje não (eu recomendo esperar), hoje, creio eu que apenas a unstable possui as versões corretas para usar o OpenOffice 2.0, infelizmente não há como fazer isso sem mudar inteiramente para a unstable, já que a libc6 é a base do sistema e nenhum programa da stable que dependa dela (95 % dos mesmos) rodará na versão unstable.


7. Re: OpenOffice 2.0

gustavo
guh

(usa Kurumin)

Enviado em 28/10/2005 - 15:04h

poutz, outra maneira de se instalar o openoffice? mesmo que seja em versões mais antigas?


8. Re: OpenOffice 2.0

Perfil removido
removido

(usa Nenhuma)

Enviado em 28/10/2005 - 15:26h

Versões antigas são facilmente instaladas... elas não dependiam do sistema tanto quanto a atual, antes, o OpenOffice era um pacote fechado, bastava ter o X e pronto, nenhuma dependência, hoje não, existem uma dezena delas...

Experimenta instalar a versão antiga do OpenOffice do próprio Debian ... basta instalar do repositório stable... sem problemas (e sem dependências incompletas).


9. Re: OpenOffice 2.0

gustavo
guh

(usa Kurumin)

Enviado em 28/10/2005 - 15:35h

Beleza então, é que eu fiquei sabendo do novo visual do OpenOffice, queria conferir a qualidade.
Valeu aê!


10. Re: OpenOffice 2.0

Alexandre Muzzio
th13f

(usa Debian)

Enviado em 09/11/2005 - 17:33h

Provavelmente o OO foi compilado usando compiladores livres para evitar o uso de maquinas virtuais proprietárias, por isso a necessidade das ultimas versões desses pacotes.


11. Re: OpenOffice 2.0

Ricardo Franzen
rfranzen

(usa Ubuntu)

Enviado em 09/11/2005 - 18:30h

th13f não entendi o que você quis dizer com seu comentário.

OpenOffice é livre e opensource, porque os desenvolvedores iriam, além de limitar extremamente os usuários, bloquear o uso de maquinas virtuais (?). E não entendi qual seu conceito de máquina virtual.

Se é ignorancia minha, desculpem e corrijam-me. Mas realmente não entendi.


12. Re: OpenOffice 2.0

Alexandre Muzzio
th13f

(usa Debian)

Enviado em 13/11/2005 - 23:36h

Exatamente por ele ser livre e open source ele não usa mais JVM (Java virtual machine) proprietárias. O OpenOffice.org tem parte do seu codigo desenvolvido em Java, por isso eles optaram por utilizar o gcj para compilar parte do projeto, e exatamente por isso ele precisa das ultimas versões desses pacotes que dão conflitos.



01 02