Oi 3g Velox Modem ZTE MF 626 HSDPA

1. Oi 3g Velox Modem ZTE MF 626 HSDPA

Fábio Luís Mendes
fabiolm

(usa Debian)

Enviado em 24/05/2009 - 13:06h

Por que nós achamos que as coisas devem ser complicadas?

Adquiri o modem ZTE MF 626 HSDPA junto com o serviço de internet móvel 3G da Oi Velox. Intalei pelo Windows (XP). Sem problemas, pois todo o software fornecido foi desenvolvido única e exclusivamente para este sistema.

Próximo passo: instalar no Linux Debian Unstable + KDE 4.2 + pacote network-manager (knetworkmanager) pré-instalados. O modem, assim como ocorre no Windows, é identificado como um disco externo (Oi 3G), onde é possível localizar os arquivos para instalação no Windows.

Conformado com esta dificuldade inicial, pesquisei inúmeros posts, com diversas instruções (complexas) sobre configuração.

Mas, a solução era muito mais simples que imaginava. Diria até que é possível instalá-lo no Linux de forma mais rápida que no Windows. Ou melhor, nem é preciso instalá-lo.

Simplesmente, "DESMONTE" o dispositivo de armazenamento que foi reconhecido inicialmente. No caso do KDE 4.2, vá até a barra inferior, clique no "Device Notifier" e, a seguir, no item correspondente ao "Oi 3g" (na parte lateral esquerda da linha, na seta para cima). Ou então, use algum outro meio de desmontar o dispositivo.

Aguarde aproximadamente 30s. O modem GSM é reconhecido automaticamente pelo sistema e já é possível se conectar através do Knetworkmanager. No meu caso, apareceu como (ttyUSB2) clicando com o botão direito do mouse no ícone do networkmanager. A seguir, é só ir dando "enter" para configurar a conexão e ela se estabelece sem nenhum problema.

Inclusive o cartão de armazenamento (opcional) microSD que inseri no modem também foi reconhecido e ficou disponível para ser utilizado, simultaneamente ao modem.

Ou seja, foi só desmontar o dispositivo inicial (com os arquivos para windows) e tudo funcionou perfeitamente.

Aliás, fiquei impressionado com a qualidade do serviço da Oi (usei em São Paulo - Ipiranga e em Santos). Muito satisfatório. Tomara que contine assim. Percebi que estão vendendo muito esse serviço.




  


2. Re: Oi 3g Velox Modem ZTE MF 626 HSDPA

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 24/05/2009 - 17:03h

Muito legal o q vc falou, mas pq vc não colocou na sessão d dicas do site? Assim, as pessoas q tivessem a msm dúvida podem usufruir da sua dica.


3. Re: Oi 3g Velox Modem ZTE MF 626 HSDPA

Fábio Luís Mendes
FabioLM

(usa Debian)

Enviado em 25/05/2009 - 18:47h

Infelizmente, a alegria durou pouco.

Após funcionar um dia muito bem como descrevi acima, a conexão "travou". Precisei reinicializar. Quando dou o "dmesg" o modem GSM é reconhecido como ttyUSB0. Mas ficou inacessível.
O networkmanager não abre mais a aba para fazer a conexão. O "Device Notifier" não reconhece nenhum dispositivo plugado.

Já tentei reconectar o modem várias vezes, sem sucesso. Já tentei outros procedimentos descritos na web, mais nada.

Não consigo entender: Funcionou tudo perfeitamente. Após um travamento da conexão, nada mais funciona.

Alguém pode ajudar ?

PS: Atualizei todos os pacotes do debian sid hoje. Mesmo assim, nada.




4. Re: Oi 3g Velox Modem ZTE MF 626 HSDPA

Fábio Luís Mendes
fabiolm

(usa Debian)

Enviado em 26/05/2009 - 13:59h

Consegui colocar novamente o modem ZTE 626 para funcionar no debian sid com os seguintes recursos:

1)Instalei os pacotes usb-modeswitch e wvdial
2)editei o arquivo /etc/usb_modeswitch.conf e retirei os comentários (# ;) da entrada referente ao modem
3)espetei o modem e deixei que o sistema o reconhecesse (/dev/ttyUSB0)
4)executei, como root, no terminal: usb_modeswitch (sem nenhum parâmetro)
5)o modem foi reinicializado, após aproximadamente 30s
6)o comando dmesg indica o direcionamento para /dev/ttyUSB3
7)executei o wvdialconf
8)o modem foi reconhecido e configurado automaticamente
9)executei wvdial
10)a conexão foi estabelecida sem problemas.

Assim, foi possível usar a internet 3g da Oi. Porém, ainda não consegui resolver alguns problemas:

O cartão microSD acoplado ao modem não é mais reconhecido e não consigo acessá-lo;
O networkmanager trava todo o sistema quanto tento estabelecer a conexão (/dev/ttyUSB3) através dele ao invés de usar o wvdial
Os procedimentos para “automatizar” o uso do usb_modeswitch (através do udev e networkmanager) que encontrei na web não funcionaram no meu caso.


5. Dúvidas que não querem calar

Fábio Luís Mendes
fabiolm

(usa Debian)

Enviado em 02/06/2009 - 19:50h

Talvez todas essas configurações não sejam mais necessárias. O fato é que a rede da OI está imprestável aqui em São Paulo.
Quando comprei o modem, no começo da propaganda, a conexão era perfeita: velocidade máxima. Após uma semana e muitos modens vendidos pela Oi, a velocidade já havia caido pela metade. Agora, quinze dias após, está entre muito lento e quase parando.
Já vivenciei esta história (Tim Web). Vendem um serviço sem controle, muito acima das capacidades instaladas da rede. Após pouco tempo, ninguém mais consegue usá-lo. Realmente, eu quis ser enganado.
Como estamos no meio de uma crise, que só a Bovespa parece que não percebeu, não acredito em grandes investimentos na rede da Oi.
Será que, algum dia, este país terá uma agência reguladora das telecomunicações de verdade? Não, a Anatel não.
Será que algum dia a propangada terá alguma relação com aquilo que é realmente oferecido?
Qual o sentido de oferecer uma internet banda larga 3G de 1Mb/s, quando não passa de internet “discada” de qualidade duvidosa?
O fato da promoção fornecer os dois primeiros meses grátis não torna a propaganda menos enganosa. Milhares de consumidores estão perdendo seu tempo, indo a uma loja da Oi, esperando horas na fila, para adquirir um serviço que praticamente não vai funcionar.
Enquanto isso, outras operadoras ficam prejudicadas quando tentam oferecer um preço justo por um serviço decente (lei de oferta e procura).
A Oi não tem um serviço pronto a oferecer, mas quer impedir que as concorrentes avancem no terreno. Quer ganhar tempo (dois meses?).
Uma regulamentação coerente do setor interessa a todos. Por exemplo, a ANATEL deveria publicar periodicamente um controle de qualidade dos serviços oferecidos pelas operadoras, para que os consumidores possam fazer escolhas conscientes. Qual a diferença entre controlar a qualidade da farinha, dos combustíveis e dos provedores de internet?
Devemos pensar nisso.


6. ...

Glauber GF
mcnd2

(usa Debian)

Enviado em 02/06/2009 - 22:59h

Caro amigo, não é só você ai em São Paulo que está sofrendo, eu aqui no Rio de Janeiro também.

Sendo que o meu é um modem USB 3G da Claro HUAWEI E226 e assinatura de 1Gb ilimitado. Sendo que durante as duas semanas iniciais que estava com o modem e o serviço habilitado tudo correu muito bem com conexão acima de 1Gb, depois disso a conexão veio a baixo sendo que fica ocilando entre 50kbps a 128kbps. Esse serviço 3G tem que melhorar bastante pois tem hora que fico mais de 1 min. e meio para abrir uma página de internet que as vezes quase sempre nem abre.

Mais fazer o que, é o unico jeito de eu ter internet banda larga quero dizer "curta" na minha área.

Até...e a espera do serviço melhorar...


7. Re: Oi 3g Velox Modem ZTE MF 626 HSDPA

Fábio Luís Mendes
fabiolm

(usa Debian)

Enviado em 04/06/2009 - 18:17h

Será que existe alguma forma de mudar o servidor de DNS do Oi 3G (vi que ele é automaticamente fornecido quando executo o wvdial). Há algum tempo, tive vários problemas de lentidão com a conexão da NET-VIRTUA. Quando configurei o roteador de casa para usar o servidor OpenDNS, ganhei muito em velocidade. Talvez uma parte do problema de velociade do Oi 3G seja uma deficiência no servidor de nomes da Oi, mas não sei como alterar esta configuração.

Outra coisa, quando executo o wvdialconf e o modem é reconhecido como /dev/ttyUSB2 o cartão microSD é reconhecido e fica disponível. Mas, quando o modem é reconhecido como /dev/ttyUSB3, o cartão não aparece. Como esse reconhecimento pelo wvdialconf parece "aleatório", não tenho segurança para usar essa memória auxiliar. Alguém sabe porque isso acontece? Qualquer sugestão é bem vinda.


8. Re: Oi 3g Velox Modem ZTE MF 626 HSDPA

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 05/06/2009 - 10:04h

No caso do DNS, basta vc colocar essa linha no seu arquivo /etc/resolv.conf:

nameserver 208.67.222.222
nameserver 208.67.220.220

Sendo q esse servidor ae é o OpenDNS. Ae vc pode colocar outro a gosto.


9. Re: Oi 3g Velox Modem ZTE MF 626 HSDPA

Fábio Luís Mendes
fabiolm

(usa Debian)

Enviado em 05/06/2009 - 15:13h

Renato, o meu resolv.conf tem o seguinte:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 200.222.0.34
nameserver 200.202.193.75

Vou adiante mesmo assim?


10. Re: Oi 3g Velox Modem ZTE MF 626 HSDPA

Renato Carneiro Pacheco
renato_pacheco

(usa Debian)

Enviado em 05/06/2009 - 15:18h

Vc pode anotar esses IP's (q deve ser o DNS q vc tá utilizando) e substitua por esses q eu t passei pra vc testar. Se vc não gostar, volte para os IP's anteriores, blz?



11. Re: Oi 3g Velox Modem ZTE MF 626 HSDPA

Fábio Luís Mendes
fabiolm

(usa Debian)

Enviado em 05/06/2009 - 15:36h

Caros Renato e acvsilva, obrigado pela ajuda.

acvsilva:

- Quando ao usb_modeswitch não ser necessário, acredito. No início deste post escrevi que o modem funcionou de primeira no KDE4 e eu nem sabia que este pacote existia. Só que depois, parou de funcionar (tão automaticamente quanto funcionava antes). Não consegui outra forma de fazer este modem funcionar, senão com este bendito pacote.
- Não estou usando mais o knetworkmanager que consegue travar todo o sistema, de uma forma que eu só conhecia no Windows.
- Quanto a utilizar o cartão microSD, além do perfeccionismo de querer tudo funcinando no linux, é mais prático, pois o modem parece um pen drive e assim não preciso carregar os dois comigo.
- vou testar a sua dica abaixo:

"para usar o opendns faça o seguinte:

abra o /etc/resolv.conf com seu editor preferido e apague tudo que estiver lá, inserindo:

search opendns.com
nameserver 208.67.222.222
nameserver 208.67.220.220

salve e faça como root:

$ sudo chattr +i /etc/resolv.conf"

Como postei acima, acredito que o resolv.conf é automaticamente reeditado cada vez que a conexão se estabelece. Pode ser que este último comando resolva. Vou testar.


12. Tenho ele na Vivo.

FERNANDO
Fernandobuntu

(usa Ubuntu)

Enviado em 08/06/2009 - 21:45h

Oi pessoal;

Tentei conectá-lo no Ubuntu 9.04. Taí um desafio pra quem gosta de Linux. A dica peguei no site http://ubuntuforum-br.org/index.php?topic=50178.0
Não funcionou!
Já tentei de tudo e não obtive resultado satisfatório. Ele conecta 1 segundo e cai. Não segura a conexão.
Onde estou errando?



01 02 03



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts