Não consigo atualizar apt-get update [RESOLVIDO]

1. Não consigo atualizar apt-get update [RESOLVIDO]

Marcelo V. Junior
marcelojr3

(usa Debian)

Enviado em 07/07/2010 - 12:17h

Galera alguem pode me ajudar, tive que formatar um server com o debian, voltei o backup dos dados, do /etc e do /var , porem agora o aptitude update ou apt-get update nao funciona de jeito nenhum o que me apresenta é isso:

Err http://ftp.br.debian.org lenny Release.gpg
Não foi possível resolver 'ftp.br.debian.org'
Err http://ftp.br.debian.org lenny/main Translation-pt_BR
Não foi possível resolver 'ftp.br.debian.org'
Err http://security.debian.org lenny/updates Release.gpg
Não foi possível resolver 'security.debian.org'
Err http://security.debian.org lenny/updates/main Translation-pt_BR
Não foi possível resolver 'security.debian.org'
Lendo listas de pacotes... Pronto
W: Falhou ao buscar http://ftp.br.debian.org/debian/dists/lenny/Release.gpg Nã o foi possível resolver 'ftp.br.debian.org'

W: Falhou ao buscar http://ftp.br.debian.org/debian/dists/lenny/main/i18n/Transl ation-pt_BR.gz Não foi possível resolver 'ftp.br.debian.org'

W: Falhou ao buscar http://security.debian.org/dists/lenny/updates/Release.gpg Não foi possível resolver 'security.debian.org'

W: Falhou ao buscar http://security.debian.org/dists/lenny/updates/main/i18n/Tra nslation-pt_BR.gz Não foi possível resolver 'security.debian.org'

W: Alguns arquivos de índice falharam para baixar, eles foram ignorados ou os a ntigos foram usados no lugar.
W: Você terá que executar apt-get update para corrigir estes problemas


Obrigado desde ja.


  


2. Re: Não consigo atualizar apt-get update [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 07/07/2010 - 12:43h

este endereços não estão disponíveis. poste aqui o conteúdo do seu /etc/apt/sources.list



3. Re: Não consigo atualizar apt-get update [RESOLVIDO]

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 07/07/2010 - 12:56h

passa os dados do aruqivo que foi pedido acima,
a net está funcioando corretamente nele?



4. Edite sua source.list e faça teste de ping

FHCS (P1R4T3)
L!N5X

(usa Debian)

Enviado em 07/07/2010 - 13:21h

Edite a source.list trocando "br" por "us" como: http://ftp.br.debian.org por http://ftp.us.debian.org

Caso não resolva verifique se tem conexão com a internet fazendo teste de ping.


5. Re: Não consigo atualizar apt-get update [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 07/07/2010 - 13:37h

faça o teste do ping e de preferência poste aqui seu sources.list ou se quiser use estes:

### Debian 5.0.5 'Lenny' (Espelhos Brasileiros).
deb http://ftp.br.debian.org/debian/ lenny main contrib non-free
deb http://ftp.br.debian.org/debian-security/ lenny/updates main contrib non-free
deb http://ftp.br.debian.org/debian/ lenny-proposed-updates main contrib non-free
deb http://ftp.br.debian.org/debian-multimedia lenny main non-free

### Debian 5.0.5 'Lenny' (Volatile).
deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

### Debian 5.0.5 'Lenny' (Espelhos Oficiais).
deb http://ftp.debian.org/debian/ lenny main contrib non-free
deb http://security.debian.org/ lenny/updates main contrib non-free
deb http://ftp.debian.org/debian/ lenny-proposed-updates main contrib non-free
deb http://www.debian-multimedia.org/ lenny main non-free



6. Re: Não consigo atualizar apt-get update [RESOLVIDO]

Marcelo V. Junior
marcelojr3

(usa Debian)

Enviado em 07/07/2010 - 15:37h

Meu sources.list é esse.
a conectividade esta ok , eu pingo tdo qnto é site..

6 deb http://ftp.br.debian.org/debian/ lenny main
7 deb http://security.debian.org/ lenny/updates main
8 deb-src http://security.debian.org/ lenny/updates main



7. Re: Não consigo atualizar apt-get update [RESOLVIDO]

Perfil removido
removido

(usa Nenhuma)

Enviado em 07/07/2010 - 15:53h


Se a net está funcionando, usa esses espelhos oficiais:


### Debian 5.0.5 'Lenny'.
deb http://ftp.debian.org/debian/ lenny main contrib non-free
#deb-src http://ftp.debian.org/debian/ lenny main contrib non-free

### Debian 5.0.5 'Lenny' Updates.
deb http://security.debian.org/ lenny/updates main contrib non-free
#deb-src http://security.debian.org/ lenny/updates main contrib non-free

### Debian 5.0.5 'Lenny' Proposed Updates.
#deb http://ftp.debian.org/debian/ lenny-proposed-updates main contrib non-free
#deb-src http://ftp.debian.org/debian/ lenny-proposed-updates main contrib non-free

### Debian 5.0.5 'Lenny' (Volatile).
deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib non-free

### Debian 5.0.5 'Lenny' Multimídia.
deb http://www.debian-multimedia.org/ lenny main non-free
#deb-src http://www.debian-multimedia.org/ lenny main non-free


*** Desativei o Proposed Updates e adicionei o Volatile e o Multimídia.
*** Não entendi o porque do repo deb-src ativado, por isso os desativei.


*** Atualize as listas:

$ sudo apt-get update


*** Instale as chaves GPG:

$ sudo apt-get install debian-archive-keyring debian-keyring -y --force-yes
$ sudo apt-get install debian-multimedia-keyring -y --force-yes



8. Re: Não consigo atualizar apt-get update [RESOLVIDO]

Marcelo V. Junior
marcelojr3

(usa Debian)

Enviado em 07/07/2010 - 16:28h

blz vou testar amanha no cliente e dou um feedback



9. Re: Não consigo atualizar apt-get update [RESOLVIDO]

Marcelo V. Junior
marcelojr3

(usa Debian)

Enviado em 12/07/2010 - 09:57h

ta complicado a coisa aqui !
alterei o source.list e da a mesma msg como se eu estivesse offline,
aptitude update
Err http://volatile.debian.org lenny/volatile Release.gpg
Não foi possível resolver 'volatile.debian.org'
Err http://volatile.debian.org lenny/volatile/main Translation-pt_BR
Não foi possível resolver 'volatile.debian.org'
Err http://volatile.debian.org lenny/volatile/contrib Translation-pt_BR
Não foi possível resolver 'volatile.debian.org'
Err http://volatile.debian.org lenny/volatile/non-free Translation-pt_BR
Não foi possível resolver 'volatile.debian.org'
Err http://security.debian.org lenny/updates Release.gpg
Não foi possível resolver 'security.debian.org'
Err http://security.debian.org lenny/updates/main Translation-pt_BR
Não foi possível resolver 'security.debian.org'
Err http://security.debian.org lenny/updates/contrib Translation-pt_BR
Não foi possível resolver 'security.debian.org'
Err http://security.debian.org lenny/updates/non-free Translation-pt_BR
Não foi possível resolver 'security.debian.org'
Err http://ftp.debian.org lenny Release.gpg
Não foi possível resolver 'ftp.debian.org'
Err http://ftp.debian.org lenny/main Translation-pt_BR
Não foi possível resolver 'ftp.debian.org'
Err http://ftp.debian.org lenny/contrib Translation-pt_BR
Não foi possível resolver 'ftp.debian.org'
Err http://ftp.debian.org lenny/non-free Translation-pt_BR
Não foi possível resolver 'ftp.debian.org'
Lendo listas de pacotes... Pronto

..Tdo isso foi depois que deu pau no servidor ,formatei, e voltei o bkp, e substitui o /var e o /etc, acho que essa foi a zica!

olhem o que aparece qndo dou o comando aptitude install htop (por exemplo):

server:/var/cache# aptitude install htop
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Lendo informações estendidas de estado
Inicializando estados de pacotes... Pronto
Lendo descrições de tarefas... Pronto
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "htop"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "htop"
Os pacotes a seguir estão QUEBRADOS:
acpi-support-base adduser apache2 aspell-pt-br aspell-pt-pt bash-completion console-common cupsys debconf debconf-i18n debian-archive-keyring
dictionaries-common initramfs-tools libcurses-ui-perl libtext-wrapi18n-perl locales lsb-base makedev ncurses-base perl-modules proftpd python
python-minimal reportbug ssh tasksel ucf util-linux-locales
Os pacotes a seguir serão REMOVIDOS:
cups-common{u} defoma{u} fontconfig-config{u} foomatic-db{u} foomatic-filters{u} gs-common{u} gs-esp{u} gsfonts{u} libglib2.0-data{u} libmd5-perl{u}
libpango1.0-common{u} libthai-data{u} libx11-data{u} mysql-common{u} openssh-blacklist{u} openssh-blacklist-extra{u} openssl-blacklist{u} psfontmgr{u}
squid-common{u} ssl-cert{u} ttf-dejavu{u} ttf-dejavu-core{u} ttf-dejavu-extra{u} vim-runtime{u} x-ttcidfont-conf{u} x11-common{u} xfonts-encodings{u}
0 pacotes atualizados, 0 novos instalados, 27 a serem removidos e 5 não atualizados.
à preciso obter 0B de arquivos. Depois do desempacotamento, 112MB serão liberados.
Os pacotes a seguir possuem dependências não satisfeitas:
console-common: Depende: debianutils (>= 1.13) o qual é um pacote virtual.
Depende: kbd o qual é um pacote virtual. ou
console-tools (>= 1:0.2.3dbs-54) o qual é um pacote virtual.
python-minimal: Depende: python2.5-minimal (>= 2.5.2) mas não é instalável.
Depende: dpkg (>= 1.13.20) mas não é instalável.
acpi-support-base: Depende: acpid (>= 1.0.4) mas não é instalável.
Depende: console-utilities o qual é um pacote virtual.
libtext-wrapi18n-perl: Depende: libtext-charwidth-perl o qual é um pacote virtual.
reportbug: Depende: apt mas não é instalável.
perl-modules: Depende: perl (>= 5.10.0-1) o qual é um pacote virtual.
libcurses-ui-perl: Depende: perl (>= 5.6.0-16) o qual é um pacote virtual.
Depende: libcurses-perl o qual é um pacote virtual.
Depende: libterm-readkey-perl o qual é um pacote virtual.
apache2: Depende: apache2-mpm-worker (>= 2.2.9-10+lenny4) mas não é instalável. ou
apache2-mpm-prefork (>= 2.2.9-10+lenny4) mas não é instalável. ou
apache2-mpm-event (>= 2.2.9-10+lenny4) mas não é instalável.
debian-archive-keyring: Depende: gnupg o qual é um pacote virtual.
locales: Depende: glibc-2.7-1 o qual é um pacote virtual.
debconf-i18n: Depende: liblocale-gettext-perl o qual é um pacote virtual.
Depende: libtext-iconv-perl o qual é um pacote virtual.
Depende: libtext-charwidth-perl o qual é um pacote virtual.
python: Depende: python2.5 (>= 2.5.2) mas não é instalável.
makedev: Depende: base-passwd (>= 3.0.4) o qual é um pacote virtual.
adduser: Depende: perl-base (>= 5.6.0) o qual é um pacote virtual.
Depende: passwd (>= 1:4.0.12) o qual é um pacote virtual.
initramfs-tools: Depende: klibc-utils (>= 1.5.9-1) o qual é um pacote virtual.
Depende: cpio o qual é um pacote virtual.
Depende: module-init-tools o qual é um pacote virtual.
Depende: udev (>= 0.086-1) mas não é instalável.
Depende: findutils (>= 4.2.24) o qual é um pacote virtual.
lsb-base: Depende: sed o qual é um pacote virtual.
Depende: ncurses-bin o qual é um pacote virtual.
ucf: Depende: coreutils (>= 5.91) o qual é um pacote virtual.
ssh: Depende: openssh-client o qual é um pacote virtual.
Depende: openssh-server o qual é um pacote virtual.
tasksel: Depende: liblocale-gettext-perl o qual é um pacote virtual.
Depende: aptitude (>= 0.2.15-1) o qual é um pacote virtual.
aspell-pt-br: Depende: aspell (>= 0.60.3-3) o qual é um pacote virtual.
bash-completion: Depende: bash (>= 3.1dfsg-9) o qual é um pacote virtual.
aspell-pt-pt: Depende: aspell (>= 0.60.3-3) o qual é um pacote virtual.
proftpd: Depende: proftpd-basic mas não é instalável.
Depende: proftpd-mod-mysql mas não é instalável.
Depende: proftpd-mod-pgsql mas não é instalável.
Depende: proftpd-mod-ldap mas não é instalável.
ncurses-base: Depende: libncurses5 o qual é um pacote virtual.
debconf: Pré-Depende: perl-base (>= 5.6.1-4) o qual é um pacote virtual.
dictionaries-common: Depende: perl-base (>= 5.6.0-16) o qual é um pacote virtual.
Depende: libtext-iconv-perl o qual é um pacote virtual.
cupsys: Depende: cups mas não é instalável.
util-linux-locales: Depende: util-linux (>= 2.13.1.1-0) o qual é um pacote virtual.
Depende: util-linux (< 2.13.1.1.0-0) o qual é um pacote virtual.
Impossível resolver dependências! Desistindo...
Os pacotes a seguir estão QUEBRADOS:
acpi-support-base adduser apache2 aspell-pt-br aspell-pt-pt bash-completion console-common cupsys debconf debconf-i18n debian-archive-keyring
dictionaries-common initramfs-tools libcurses-ui-perl libtext-wrapi18n-perl locales lsb-base makedev ncurses-base perl-modules proftpd python
python-minimal reportbug ssh tasksel ucf util-linux-locales
Os pacotes a seguir serão REMOVIDOS:
cups-common{u} defoma{u} fontconfig-config{u} foomatic-db{u} foomatic-filters{u} gs-common{u} gs-esp{u} gsfonts{u} libglib2.0-data{u} libmd5-perl{u}
libpango1.0-common{u} libthai-data{u} libx11-data{u} mysql-common{u} openssh-blacklist{u} openssh-blacklist-extra{u} openssl-blacklist{u} psfontmgr{u}
squid-common{u} ssl-cert{u} ttf-dejavu{u} ttf-dejavu-core{u} ttf-dejavu-extra{u} vim-runtime{u} x-ttcidfont-conf{u} x11-common{u} xfonts-encodings{u}
0 pacotes atualizados, 0 novos instalados, 27 a serem removidos e 5 não atualizados.
à preciso obter 0B de arquivos. Depois do desempacotamento, 112MB serão liberados.
O aptitude falhou em encontrar uma solução para estas dependências. Você pode resolvê-las por conta própria manualmente ou digitar 'n' para sair.
Os pacotes a seguir possuem dependências não satisfeitas:
console-common: Depende: debianutils (>= 1.13) o qual é um pacote virtual.
Depende: kbd o qual é um pacote virtual. ou
console-tools (>= 1:0.2.3dbs-54) o qual é um pacote virtual.
python-minimal: Depende: python2.5-minimal (>= 2.5.2) mas não é instalável.
Depende: dpkg (>= 1.13.20) mas não é instalável.
acpi-support-base: Depende: acpid (>= 1.0.4) mas não é instalável.
Depende: console-utilities o qual é um pacote virtual.
libtext-wrapi18n-perl: Depende: libtext-charwidth-perl o qual é um pacote virtual.
reportbug: Depende: apt mas não é instalável.
perl-modules: Depende: perl (>= 5.10.0-1) o qual é um pacote virtual.
libcurses-ui-perl: Depende: perl (>= 5.6.0-16) o qual é um pacote virtual.
Depende: libcurses-perl o qual é um pacote virtual.
Depende: libterm-readkey-perl o qual é um pacote virtual.
apache2: Depende: apache2-mpm-worker (>= 2.2.9-10+lenny4) mas não é instalável. ou
apache2-mpm-prefork (>= 2.2.9-10+lenny4) mas não é instalável. ou
apache2-mpm-event (>= 2.2.9-10+lenny4) mas não é instalável.
debian-archive-keyring: Depende: gnupg o qual é um pacote virtual.
locales: Depende: glibc-2.7-1 o qual é um pacote virtual.
debconf-i18n: Depende: liblocale-gettext-perl o qual é um pacote virtual.
Depende: libtext-iconv-perl o qual é um pacote virtual.
Depende: libtext-charwidth-perl o qual é um pacote virtual.
python: Depende: python2.5 (>= 2.5.2) mas não é instalável.
makedev: Depende: base-passwd (>= 3.0.4) o qual é um pacote virtual.
adduser: Depende: perl-base (>= 5.6.0) o qual é um pacote virtual.
Depende: passwd (>= 1:4.0.12) o qual é um pacote virtual.
initramfs-tools: Depende: klibc-utils (>= 1.5.9-1) o qual é um pacote virtual.
Depende: cpio o qual é um pacote virtual.
Depende: module-init-tools o qual é um pacote virtual.
Depende: udev (>= 0.086-1) mas não é instalável.
Depende: findutils (>= 4.2.24) o qual é um pacote virtual.
lsb-base: Depende: sed o qual é um pacote virtual.
Depende: ncurses-bin o qual é um pacote virtual.
ucf: Depende: coreutils (>= 5.91) o qual é um pacote virtual.
ssh: Depende: openssh-client o qual é um pacote virtual.
Depende: openssh-server o qual é um pacote virtual.
tasksel: Depende: liblocale-gettext-perl o qual é um pacote virtual.
Depende: aptitude (>= 0.2.15-1) o qual é um pacote virtual.
aspell-pt-br: Depende: aspell (>= 0.60.3-3) o qual é um pacote virtual.
bash-completion: Depende: bash (>= 3.1dfsg-9) o qual é um pacote virtual.
aspell-pt-pt: Depende: aspell (>= 0.60.3-3) o qual é um pacote virtual.
proftpd: Depende: proftpd-basic mas não é instalável.
Depende: proftpd-mod-mysql mas não é instalável.
Depende: proftpd-mod-pgsql mas não é instalável.
Depende: proftpd-mod-ldap mas não é instalável.
ncurses-base: Depende: libncurses5 o qual é um pacote virtual.
debconf: Pré-Depende: perl-base (>= 5.6.1-4) o qual é um pacote virtual.
dictionaries-common: Depende: perl-base (>= 5.6.0-16) o qual é um pacote virtual.
Depende: libtext-iconv-perl o qual é um pacote virtual.
cupsys: Depende: cups mas não é instalável.
util-linux-locales: Depende: util-linux (>= 2.13.1.1-0) o qual é um pacote virtual.
Depende: util-linux (< 2.13.1.1.0-0) o qual é um pacote virtual.
Resolver estas dependências manualmente? [N/+/-/_/:/?]

Obrigado :|




10. Re: Não consigo atualizar apt-get update [RESOLVIDO]

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 13/07/2010 - 10:21h

tenta este comando, dpkg --configure -a

não sei seria a melhor coisa a fazer em um servidor, mas já tentou usar?

apt-get -f install




11. to com o mesmo problema so que no pc de casa

renan rodrigues da costa silva
renanrodrigues

(usa Ubuntu)

Enviado em 10/02/2011 - 00:16h

aparece o seguinte erro no meu debian Squeeze qndo dou um #aptitude update

E: Não foi possível abrir arquivo de trava /var/lib/apt/lists/lock - open (13: Permissão negada)
E: Não foi possível bloquear o diretório de listas..você é root?



12. Re: Não consigo atualizar apt-get update [RESOLVIDO]

fabricio erdmann
fabricio.er

(usa Debian)

Enviado em 10/02/2011 - 00:26h

renanrodrigues para usar o comando 'apt-get' é preciso ser o root ou usar o sudo para "se tornar o root momentaneamente".

para se tornar o root você pode usar o comando 'su', ou 'sudo su'. de preferencia pelo sudo su e use o root apenas quando for necessário.



01 02



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts