Erro dpkg

13. Re: Erro dpkg

Yasmin S. B.
YasminSi

(usa Debian)

Enviado em 24/02/2021 - 11:40h


clodoaldops escreveu:

Tente desbloquear o Apt

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get -f remove
sudo apt-get update
sudo apt-get upgrade


dpkg: problemas com dependências impedem a configuração de grub-efi-amd64-bin:
grub-efi-amd64-bin depende de grub-common (= 2.02~beta3-5+deb9u2); porém:
Versão de grub-common no sistema é 2.02~beta3-5+deb9u1.

dpkg: erro ao processar o pacote grub-efi-amd64-bin (--configure):
problemas de dependência - deixando desconfigurado
Configurando ppp (2.4.7-1+4+deb9u1) ...
dpkg: problemas com dependências impedem a configuração de grub-efi-amd64:
grub-efi-amd64 depende de grub-common (= 2.02~beta3-5+deb9u2); porém:
Versão de grub-common no sistema é 2.02~beta3-5+deb9u1.
grub-efi-amd64 depende de grub-efi-amd64-bin (= 2.02~beta3-5+deb9u2); porém:
Pacote grub-efi-amd64-bin não está configurado ainda.

dpkg: erro ao processar o pacote grub-efi-amd64 (--configure):
problemas de dependência - deixando desconfigurado

Erros foram encontrados durante o processamento de:
grub-efi-amd64-bin
grub-efi-amd64
grub2-common

W: Erro GPG: https://policorp.com.br/repositorio/d9/positivo ./ InRelease: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY AE9BC4AEACC8C53A
W: The repository 'http://policorp.com.br/repositorio/d9/positivo ./ InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.




  


14. Re: Erro dpkg

Yasmin S. B.
YasminSi

(usa Debian)

Enviado em 24/02/2021 - 11:46h


Pebis escreveu:


posta a saída desse comando:

cat /var/lib/dpkg/status | grep "Package: grub-common" -A10


cat /var/lib/dpkg/status | grep "Package: grub-common" -A10Package: grub-common
Status: install ok installed
Priority: optional
Section: admin
Installed-Size: 14768
Maintainer: GRUB Maintainers <[email protected]>
Architecture: amd64
Multi-Arch: foreign
Source: grub2
Version: 2.02~beta3-5+deb9u1
Replaces: grub-coreboot (<< 2.00-4), grub-efi (<< 1.99-1), grub-efi-amd64 (<< 2.00-4), grub-efi-ia32 (<< 2.00-4), grub-efi-ia64 (<< 2.00-4), grub-ieee1275 (<< 2.00-4), grub-linuxbios (<< 1.96+20080831-1), grub-pc (<< 2.00-4), grub-yeeloong (<< 2.00-4)



15. Re: Erro dpkg

Paulo Jr
Pebis

(usa Debian)

Enviado em 24/02/2021 - 20:31h


Que repositório é esse Policorp?

Posta seus repositório aí... O sistema está quebrado por conflito de versões de software... pode ser o repositório adicionado que está causando o problema.

posta as saídas dos comando:

cat /etc/apt/sources.list
ls -l /etc/apt/sources.list.d/


16. Re: Erro dpkg

Ricardo Groetaers
ricardogroetaers

(usa Linux Mint)

Enviado em 25/02/2021 - 00:44h

Pebis escreveu: Que repositório é esse Policorp?

Se não me falha a memória, é uma empresa com a qual a Positivo tem parceria.
Ela faz "drivers" para sistemas Linux para computadores da Positivo.
Seus repositórios não podem ser acessados publicamente "por fora". Ver:
https://policorp.com.br/




17. Re: Erro dpkg

Yasmin S. B.
YasminSi

(usa Debian)

Enviado em 25/02/2021 - 17:38h


Ryuk escreveu:


YasminSi escreveu:

Ryuk escreveu:

Tentaí:
sudo rm -f /var/lib/dpkg/info/grub-common.*
sudo dpkg --configure -a
sudo apt-get install -f
sudo apt update && sudo apt upgrade




Apareceu isso aqui


Atenção ao digitar os comandos, tem erros aí... "sudo apt update e && sudo apt upgrade". O correto não tem esse "e" (em negrito)!

Faça o seguinte:
sudo rm -f /var/lib/dpkg/info/grub*
sudo apt update
sudo apt upgrade

Agora deve apagar tudo relacionado ao pacotes "grub".

Obs: Se tiver logado como "root" não precisa digitar o "sudo" antes dos comandos.


[code][sudo apt upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
grub-efi-amd64 : Depende: grub-common (= 2.02~beta3-5+deb9u2) mas 2.02~beta3-5+deb9u1 está instalado
grub-efi-amd64-bin : Depende: grub-common (= 2.02~beta3-5+deb9u2) mas 2.02~beta3-5+deb9u1 está instalado
grub2-common : Depende: grub-common (= 2.02~beta3-5+deb9u2) mas 2.02~beta3-5+deb9u1 está instalado
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).
sudo apt --fix-broken install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
libjsoncpp1 libmicrodns0
Utilize 'sudo apt autoremove' para os remover.
The following additional packages will be installed:
grub-common
Pacotes sugeridos:
multiboot-doc grub-emu
Os pacotes a seguir serão atualizados:
grub-common
1 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 2 não atualizados.
3 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/2.174 kB de arquivos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Lendo logs de mudanças... Feito
dpkg: aviso: falta ficheiro de lista de ficheiros 'grub-efi-amd64-bin'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'grub-efi-amd64'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'grub2-common'; assumindo que o pacote não tem actualmente ficheiros instalados
dpkg: aviso: falta ficheiro de lista de ficheiros 'grub-common'; assumindo que o pacote não tem actualmente ficheiros instalados
(Lendo banco de dados ... 166619 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../grub-common_2.02~beta3-5+deb9u2_amd64.deb ...
A descompactar grub-common (2.02~beta3-5+deb9u2) sobre (2.02~beta3-5+deb9u1) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/grub-common_2.02~beta3-5+deb9u2_amd64.deb (--unpack):
a tentar sobre-escrever '/etc/grub.d/05_debian_theme', que também está no pacote oem 1.0.22
dpkg-deb: erro: o subprocesso colar foi morto pelo sinal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/grub-common_2.02~beta3-5+deb9u2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
/code]



18. Re: Erro dpkg

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 25/02/2021 - 17:41h

-usar repositórios não oficiais no Debian é pedir p/ ter dores de cabeça



19. Re: Erro dpkg

Yasmin S. B.
YasminSi

(usa Debian)

Enviado em 25/02/2021 - 17:49h


ricardogroetaers escreveu:

Pebis escreveu: Que repositório é esse Policorp?

Se não me falha a memória, é uma empresa com a qual a Positivo tem parceria.
Ela faz "drivers" para sistemas Linux para computadores da Positivo.
Seus repositórios não podem ser acessados publicamente "por fora". Ver:
https://policorp.com.br/



È isso mesmo. O meu é da Positivo. Minha sources:
[email protected]:~$ sudo cat /etc/apt/sources.list
[sudo] senha para usuario:
deb http://debian.c3sl.ufpr.br/debian/ stretch main contrib non-free
# deb-src http://debian.c3sl.ufpr.br/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
# deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://debian.c3sl.ufpr.br/debian/ stretch-updates main contrib non-free
# deb-src http://debian.c3sl.ufpr.br/debian/ stretch-updates main

[email protected]:~$ sudo ls -l /etc/apt/sources.list.d/
total 16
-rw-r--r-- 1 root root 49 fev 23 19:42 oem.list
-rw-r--r-- 1 root root 49 fev 23 19:42 oem.list.save
-rw-r--r-- 1 root root 54 fev 23 19:42 positivo.list
-rw-r--r-- 1 root root 54 fev 23 19:42 positivo.list.save




01 02