Debian Lenny - Lento

1. Debian Lenny - Lento

Felipe
felipefv

(usa Debian)

Enviado em 16/05/2009 - 19:40h

Pessoal, acabei de instalar o Debian Lenny e estou enfrentando alguns problemas relacionados a velocidade de execução e vídeo. E estes problemas ficaram mais evidentes por que hoje mesmo eu tinha instalado (do zero) a versão Etch e, então, pude comparar.
Primeiro percebi que, diferente da instalação que fiz hoje do Etch, ele não abriu o Gnome a primeira vez com a resolução máxima do monitor (talvez aí esteja o problema da lentidão: o driver de vídeo). Além disso, quando fui até a configuração e pedi para entrar com 1280x1024, a tela não ficou totalmente preenchida, sobrando uns 3cm do lado direito e mais 1cm do lado esquerdo.
Bom, o que me deixa mais confuso é que com o Etch não tive problema algum, ou seja, o vídeo tava perfeito e a execução dos aplicativos muito rápida. Realmente tá ruim de trabalhar assim... Quando abri o Iceweasel em um vídeo do YouTube foi pedir pra morrer. O som clipava, travava alguns segundos e o vídeo rodava nuns 5 quadros por minuto. Tentei até rodar com 1GB de RAM pra tirar a dúvida, mas esse problema continuou.
Posso estar deixando passar algo muito básico, pois, não tenho tempo nesse sistema. Por isso, por favor, peço a ajuda de vcs.

PC, Asus P5P800MX, Intel Celeron 2,66GHz, HD 80GB, 512MB RAM.
Quando instalei o ETCH selecionei: Ambiente Desktop e Sistema Básico.
Quando instalei o LENNY selecionei: (as mesmas opções acima).
Resumo dos problemas com LENNY: lentidão (abertura de aplicativos, minimizar e maximizar janelas, navegar, etc) e resolução não fecha o monitor todo.


  


2. Re: Debian Lenny - Lento

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 16/05/2009 - 20:21h

poste seu xorg.conf aqui para nós.



3. xorg.conf

Felipe
felipefv

(usa Debian)

Enviado em 16/05/2009 - 20:25h

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "abnt2"
Option "XkbLayout" "br"
Option "XkbVariant" "abnt2"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
EndSection



Esse negócio tá genérico? Pelo que pesquisei, a minha placa de vídeo onboard é Intel.


4. Re: Debian Lenny - Lento

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 16/05/2009 - 20:29h

faça uma cópia do seu em um outro arquivo, e substitua por este reinicie e veja o que dá;

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
# cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
# sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
# sudo dpkg-reconfigure xserver-xorg

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
# paths to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Intel Corporation 82865G Integrated Graphics Device"
Driver "i810"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "CT510G(15")"
Option "DPMS"
HorizSync 30-54
VertRefresh 50-120
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation 82865G Integrated Graphics Device"
Monitor "CT510G(15")"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection



5. Re: Debian Lenny - Lento

Felipe
felipefv

(usa Debian)

Enviado em 16/05/2009 - 20:41h

Deu erro na inicializacao...


6. Re: Debian Lenny - Lento

anna kamilla
annakamilla

(usa Manjaro Linux)

Enviado em 16/05/2009 - 20:44h

olha tenho um dri dessa placa para o ubuntu tenta instalar no debian http://www.4shared.com/file/105820725/4026ca71/dri-intel_343006-20051210_i386.html

http://www.4shared.com/file/105820877/d8031825/xserver-xorg-video-intel_241origtar.html

instalei elas no meu pc e deu certo.

tenta tambem procurar por intel i810 no synaptic.

não sei por que os drivers dos chiptsets intel estão dando problema no debian e ubuntu.




7. Re: Debian Lenny - Lento

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 16/05/2009 - 20:48h

verifiquei se este driver já está instalado, "xserver-xorg-video-intel", caso não esteja instale ele ai com apt-get ou aptitude.



8. Re: Debian Lenny - Lento

Felipe
felipefv

(usa Debian)

Enviado em 16/05/2009 - 21:02h

Os drivers i810 da Intel e o "xserver-xorg-video-intel" estão instalados. O pacote .deb que vc me passou não rodou (talvez eu tenha feito o procedimento errado).

Bom, esse Lenny tá me dando dor de cabeça. Além desses problemas de lentidão e vídeo, cada inicialização do Gnome ele desorganiza ícones do taskbar. Como é que posso pensar em instalar isso nos computadores da empresa? Aí quebra...

Qual seria o problema de instalar a versão Etch? São só as atualizações que, no futuro, não existirão mais?

Valeu!


9. Re: Debian Lenny - Lento

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 16/05/2009 - 21:19h

O problema do ecth a princípio seria não reconhecimento de algum dispositivo, mas isto acho que não ocorreu ai, e posteriormente a falta de atualizações.

teste outro xorg; qualquer coisa você retorna a cópia anterior sua.

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Intel Corporation 82865G Integrated Graphics Device"
Driver "i810"
VendorName "Intel Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection




10. Re: Debian Lenny - Lento

Felipe
felipefv

(usa Debian)

Enviado em 16/05/2009 - 21:30h

riesdra,
To rodando com a config que vc me passou, mas o problema no monitor continua (preenchimento parcial) e lentidao em algumas execucoes continua. YouTube continua horrivel (mas dai talvez ja seja um problema do player que vem junto com o Lenny).

Eu acho mesmo que vou voltar pro Etch. Vim pro Lenny pq tava quebrando a cabeca pra instalar o flash player no Etch, mas no fim acabei vendo no backports.org como fazer (e tinha funcionado). Alem disso, eu quis manter o sistema atualizado, mas ta complicado.

Vc ve algum ponto negativo em voltar pra Etch?


11. Re: Debian Lenny - Lento

Ricardo Libanio
riesdra

(usa Debian)

Enviado em 16/05/2009 - 21:36h

fora os que postei na mensagem anterior não.


12. Re: Debian Lenny - Lento

Felipe
felipefv

(usa Debian)

Enviado em 16/05/2009 - 21:41h

riesdra,

Vc acha que é o vídeo que tá deixando o Linux lento? Pq eu tava pensando em passar um pouco de trabalho, reinstalando a Etch e verificando o que sai no xorg.conf.

Mas achas que pode ter mais alguma coisa envolvida além do driver de vídeo? Não sei, talvez seja característico dessa Lenny ser um pouco mais pesada... O que achas, tem mais alguma coisa pra gente testar antes de eu reinstalar a Etch?



01 02 03



Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts