problema com dependência infinita de pacotes [RESOLVIDO]

1. problema com dependência infinita de pacotes [RESOLVIDO]

Vinicius marcon correa
umbreonelite123

(usa Ubuntu)

Enviado em 13/04/2021 - 21:04h


ja faz cerca de um ano que eu tenho instalado ParrotOS (Debian) no meu computador e esse problema vem ocorrendo, e mesmo quando eu reinstalo meu OS, esse problema volta a aparecer quando eu dou um `apt upgrade`. Eu tenho um problema com dependencias de pacotes em relacao a versao que simplesmente nao consigo resolver. Como pode ver abaixo, toda vez que eu tento utilizar comandos para instalar qualquer pacote `apt install`, quando tento remover um pacote `apt remove` ou simplesmente atualizar meus pacotes `apt upgrade`, ele para e mostra varios pacotes com problemas de dependencia por causa da sua versao, entao eu nao consigo ultilizar nenhum desses tres comandos ate conseguir resolver esse problema


#apt-get upgrade

apt upgrade is unsafe on rolling release distributions.

using apt full-upgrade instead

use apt upgrade --force to override



A ler as listas de pacotes... Pronto
A construir árvore de dependências
A ler a informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigir isso.
Os pacotes a seguir têm dependências não satisfeitas:
cpp-9 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
g++-9 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
gcc-9 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
Depende: libgcc-9-dev (= 9.2.1-4) mas 9.3.0-22 está instalado
lib32gcc1 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
lib32stdc++6 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libasan5 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libatomic1 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libcc1-0 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libgcc-9-dev : Depende: libgomp1 (>= 9.3.0-22) mas 9.2.1-4 está instalado
Depende: libitm1 (>= 9.3.0-22) mas 9.2.1-4 está instalado
Depende: libatomic1 (>= 9.3.0-22) mas 9.2.1-4 está instalado
Depende: libasan5 (>= 9.3.0-22) mas 9.2.1-4 está instalado
Depende: liblsan0 (>= 9.3.0-22) mas 9.2.1-4 está instalado
Depende: libtsan0 (>= 9.3.0-22) mas 9.2.1-4 está instalado
Depende: libubsan1 (>= 9.3.0-22) mas 9.2.1-4 está instalado
Depende: libquadmath0 (>= 9.3.0-22) mas 9.2.1-4 está instalado
libgcc1 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libgfortran5 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libgomp1 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libitm1 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
liblsan0 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libobjc-9-dev : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
Depende: libgcc-9-dev (= 9.2.1-4) mas 9.3.0-22 está instalado
libobjc4 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libquadmath0 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libstdc++-9-dev : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
Depende: libgcc-9-dev (= 9.2.1-4) mas 9.3.0-22 está instalado
libstdc++6 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libtsan0 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
libubsan1 : Depende: gcc-9-base (= 9.2.1-4) mas 9.3.0-22 está instalado
E: Dependências não satisfeitas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).



Eu ja tentei todo tipo de comando que se pode imaginar durante meses e procurei por varios comandos e respostas em diferentes perguntas pelo StackOverflow, eu inclusive tentei atualizar o pacote gcc-9-base para uma versao mais nova, porem agora outras pacotes estao pedindo pela versao antiga, ou seja, eu estou preso nesse ciclo de dependencias.

Eu ja tentei remover os pacotes e instalar novamente alguns deles para ver se corrigia com esssa versao com `dpkg` e o Synaptic mas tambem nao funcionou

Alguem sabe como eu posso resolver esse problema? talvez uma forma de atualizar todos os pacotes para a versao atual, ou atualizar tudo para uma versao mais nova como o gcc-10? eu preciso consertar essas dependencias pra conseguir usar o `apt-get` novamente


  


2. Re: problema com dependência infinita de pacotes [RESOLVIDO]

Mauriciodez
Mauriciodez

(usa Debian)

Enviado em 13/04/2021 - 23:54h


vc fez o sugerido ???
apt --fix-broken install 



------------------------------------------------------| Linux User #621728 |------------------------------------------------------

" Nem sempre é amigo aquele que te tira do buraco !!! ( Saddam Hussein )"

------------------------------------------------------| Linux User #621728 |------------------------------------------------------




3. Re: problema com dependência infinita de pacotes [RESOLVIDO]

Vinicius marcon correa
umbreonelite123

(usa Ubuntu)

Enviado em 14/04/2021 - 00:56h


Mauriciodez escreveu:


vc fez o sugerido ???
apt --fix-broken install 



Sim, tentei inumeros comandos de apt mas nenhum deles funciona, eu literalmente estou impossibilitado de usar o comando apt-get e qualquer switch dele porque sempre que eu uso ele retorna essa lista de dependências e nao executa nada



4. Re: problema com dependência infinita de pacotes [RESOLVIDO]

Cézar Augusto
cizordj

(usa Debian)

Enviado em 14/04/2021 - 08:08h

Você mexeu no sources.list? Porque pra mim isso parece problema de release