Placa de rede nao é eth0 no Debian 10 [RESOLVIDO]

1. Placa de rede nao é eth0 no Debian 10 [RESOLVIDO]

Carlos Maxwell
softgyn

(usa Debian)

Enviado em 09/10/2020 - 17:10h

Boa tarde pessoal, precisando de socorro ...
estou tentando montar um servidor firewall, para usar o squid por exemplo, e compartilhar a internet atraves de uma segunda placa de rede para acesso de outros computadores, vamos ao cenario:
cpu com 1 rede on board e 2 off-board (coloquei uma segunda off-board porque achei estranho que nao conseguia compartilhar a internet)
entao, o estranho é nao esta configurando na instalacao como eth0 ou eth1 eassim por diante, agora esta aparecendo enp4s0 ou enp5s0 ou ainda enp1s0
por exclusao consigo saber quem é quem, mas o negocio que ficou dificil..., por favor podem postar um modelo de configuracao para 2 placas com essas mudancas???

de antemao agradeco a todos que puderem ajudar

obrigado


  


2. MELHOR RESPOSTA

Carlos A. P. Cunha
Carlos_Cunha

(usa Deepin)

Enviado em 09/10/2020 - 20:34h

Faz bastante tempo que mudou, isso por conta de uma melhor garantia que uma interface não iniciara com nome de outra, isso anteriormente era atrelado ao UDEV, mas nunca foi 100%, agora é quase impossível ocorrer isso, pois a mais componentes para amarar um nome de interface.
Na verdade é so vc adpatar o que esta fazendo para novos nome, nada de mais, infelizmente nem tudo pode ser apenas copia e colar...
Se esta usando algo que ainda usa nomenclatural ethX já indica que é algo antigo(não que não seja valido).
Uma forma simples de vc saber qual é qual e deixar um cabo ligado ver se pro sistema esta UP. assim consegue "marcar fisicamente" qual interface é X ou Y de uma fora facil.




#-------------------------------------------------------------------------------------#
"Falar é fácil, me mostre o código." - Linus Torvalds
#-------------------------------------------------------------------------------------#


3. Re: Placa de rede nao é eth0 no Debian 10 [RESOLVIDO]

Marcelo Oliver
msoliver

(usa Debian)

Enviado em 09/10/2020 - 19:05h


softgyn escreveu:

Boa tarde pessoal, precisando de socorro ...
estou tentando montar um servidor firewall, para usar o squid por exemplo, e compartilhar a internet atraves de uma segunda placa de rede para acesso de outros computadores, vamos ao cenario:
cpu com 1 rede on board e 2 off-board (coloquei uma segunda off-board porque achei estranho que nao conseguia compartilhar a internet)
entao, o estranho é nao esta configurando na instalacao como eth0 ou eth1 eassim por diante, agora esta aparecendo enp4s0 ou enp5s0 ou ainda enp1s0
por exclusao consigo saber quem é quem, mas o negocio que ficou dificil..., por favor podem postar um modelo de configuracao para 2 placas com essas mudancas???

de antemao agradeco a todos que puderem ajudar

obrigado

Boa noite.
O comando:
dmesg|grep 'eth' 

mostra para "qual nome" a placa foi "renomeada"



______________________________________________________________________
Importante: echo -e "\n$(lynx --dump goo.gl/a9KeFc|sed -nr '/^[ ]+Se/,/dou.$/p')\n"
Att.: Marcelo Oliver
______________________________________________________________________


4. Re: Placa de rede nao é eth0 no Debian 10 [RESOLVIDO]

leandro peçanha scardua
leandropscardua

(usa Ubuntu)

Enviado em 09/10/2020 - 23:22h

Rodando ethtool -i enp2s0 (apt-get install ethtool se n tiver instalado) vc consegue várias informações sobre o driver da placa o q permite inferir o fornecedor.


5. Placa de rede nao é eth0 no Debian 10

Carlos Maxwell
softgyn

(usa Debian)

Enviado em 15/10/2020 - 10:11h

meu amigo carlos_cunha, fiz exatamente isso, deixei o caboconectado, e observo a placa que levantou. de qualquer forma eu agradeco muito as contribuicoes,me ajudaram sim.


6. Placa de rede nao é eth0 no Debian 10

Carlos Maxwell
softgyn

(usa Debian)

Enviado em 15/10/2020 - 10:13h

Aos admins, como faco para dar como resolvido o topico?
obrigado


7. Re: Placa de rede nao é eth0 no Debian 10 [RESOLVIDO]

Carlos A. P. Cunha
Carlos_Cunha

(usa Deepin)

Enviado em 20/10/2020 - 20:04h

softgyn escreveu:

Aos admins, como faco para dar como resolvido o topico?
obrigado


Deve estar no inicio do seu post ou na lista de perguntas que vc tem interação.

#-------------------------------------------------------------------------------------#
"Falar é fácil, me mostre o código." - Linus Torvalds
#-------------------------------------------------------------------------------------#







Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts