Instalei o Navegador Tor - Mas ele não abre e não tem nenhum ícone pra clicar..

1. Instalei o Navegador Tor - Mas ele não abre e não tem nenhum ícone pra clicar..

Francisco Oliveira
Chicooliveira

(usa Debian)

Enviado em 03/04/2019 - 22:15h

Oi pessoal, boa noite..
Instalei o navegador Tor no Debian 9 mas ele não abre. Tentei reinstalar algumas vezes, a máquina reporta que ele está instalado.. mas não consigo abrir ele. Alguém saberia me dizer qual é "a mágica" pra fazer ele funcionar? Obrigado.


  


2. Re: Instalei o Navegador Tor - Mas ele não abre e não tem nenhum ícone pra clicar..

Andre (pinduvoz)
pinduvoz

(usa Debian)

Enviado em 03/04/2019 - 23:33h

Abra o terminal e tente digitando:

tor + Tab + enter

O tab vai autocompletar o comando de abertura do Tor.

Outra opção é o comando que eu usei quando instalei o Tor, que era:

start-tor-browser


__________________________________
Linux Registered User nº 439378
Ubuntu Forum Member Since Nov/07/2006
VOL Member SInce Jul/01/2008



3. Re: Instalei o Navegador Tor - Mas ele não abre e não tem nenhum ícone pra clicar..

Francisco Oliveira
Chicooliveira

(usa Debian)

Enviado em 04/04/2019 - 00:57h

pinduvoz escreveu:

Abra o terminal e tente digitando:

tor + Tab + enter

O tab vai autocompletar o comando de abertura do Tor.

Outra opção é o comando que eu usei quando instalei o Tor, que era:

start-tor-browser


__________________________________
Linux Registered User nº 439378
Ubuntu Forum Member Since Nov/07/2006
VOL Member SInce Jul/01/2008


Fala pinduvoz, blz man? Obg por ter respondido. .

Então.. O primeiro comando (tor + Tab + enter) responde: "Tor não vai poder te ajudar se vc fizer isso errado.."

E o segundo (start-tor-browser) reporta; "comando não encontrado"

Tentei como "normal user" e "como super user".
Eu devo estar errando em algo muito básico; Tipo, abrindo o terminal no diretório errado ou algo assim.
Tô usando o Debian 9

Agradeço sua ajuda amigo, boa noite.

Att,

Chicooliveira.


4. Re: Instalei o Navegador Tor - Mas ele não abre e não tem nenhum ícone pra clicar..

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 04/04/2019 - 01:07h

Execute este script em um terminal.

------------------------------------------

!#/bin/bash

wget https://dist.torproject.org/torbrowser/8.0.8/tor-browser-linux64-8.0.8_pt-BR.tar.xz && tar -Jxf ./tor-browser-linux64-8.0.8_pt-BR.tar.xz
cd ./tor-browser_pt-BR/Browser/ && sh -c '"$(dirname "$*")"/Browser/start-tor-browser --detach || ([ ! -x "$(dirname "$*")"/Browser/start-tor-browser ] && "$(dirname "$*")"/start-tor-browser --detach)' dummy %k

--------------------------------------------

Este script ira baixar descompactar e fazer 1ª execução do Tor Browser .

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


5. Re: Instalei o Navegador Tor - Mas ele não abre e não tem nenhum ícone pra clicar..

Francisco Oliveira
Chicooliveira

(usa Debian)

Enviado em 04/04/2019 - 01:49h

aguamole escreveu:

Execute este script em um terminal.

------------------------------------------

!#/bin/bash

wget https://dist.torproject.org/torbrowser/8.0.8/tor-browser-linux64-8.0.8_pt-BR.tar.xz && tar -Jxf ./tor-browser-linux64-8.0.8_pt-BR.tar.xz
cd ./tor-browser_pt-BR/Browser/ && sh -c '"$(dirname "$*")"/Browser/start-tor-browser --detach || ([ ! -x "$(dirname "$*")"/Browser/start-tor-browser ] && "$(dirname "$*")"/start-tor-browser --detach)' dummy %k

--------------------------------------------

Este script ira baixar descompactar e fazer 1ª execução do Tor Browser .

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.


Fala João.. como estamos?

Primeiro eu executei seu comando como "normal user" - isso gerou umas trezentas linhas e todas elas tinham a frase "permissão negada" ao final.
Depois executei o mesmo comando como root. O Debian reportou que o Tor não pode ser executado como root.

Tirei os prints, coloquei no meu drive pra te mostrar.

Tá aqui o link:
https://drive.google.com/drive/folders/1dvkBgQlZOI2ROpliH6s7jpAZmpMuic-b?usp=sharing

Att,

Chicooliveira.


6. Re: Instalei o Navegador Tor - Mas ele não abre e não tem nenhum ícone pra clicar..

João Cláudio de Alcântara
aguamole

(usa Lubuntu)

Enviado em 04/04/2019 - 08:55h

Porque sera que você não tem permissão de escrita na sua própria pasta de usuário.

Entre na pasta que o root descompacto do arquivo baixado pelo script.
$ cd ./tor-browser_pt-BR/Browser/
Este comando é para executar o Tor mais você pode clicar no arquivo 2 vezes também para executar é preciso alterar a permissão de execução.
$ sh -c '"$(dirname "$*")"/Browser/start-tor-browser --detach || ([ ! -x "$(dirname "$*")"/Browser/start-tor-browser ] && "$(dirname "$*")"/start-tor-browser --detach)' dummy %k

Se você não tem permissão na sua própria pasta de usuário é estranho tenta ai.

CPU Q6600 GTX 750 SofRaid 4xSSD 4Gb DDR2 mesmo assim uso Lubuntu.






Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts