Erro "sudo apt-get update" (e pra que serve?)

1. Erro "sudo apt-get update" (e pra que serve?)

Thársos Lima Gonçalves Xavier Souza
Thársos Vert

(usa Debian)

Enviado em 21/09/2019 - 00:26h

Olá, sou novo no "mundo Linux" e por mais que esta seja uma pergunta simples, você já vai ajudar muito se puder responder.

Utilizei o comando sudo apt-get update e apareceu o seguinte erro:
https://drive.google.com/file/d/1Fq970XOxyLp2BCmfEFsAAS03cZwzxhjH/view?usp=sharing

Confesso que não sei ao certo pra que serve este comando, então se puder dizer e recomendar como estudar/aprender Linux (Debian principalmente) vai ajudar muito.

Além disso, tentei instalar alguns softwares (antes desse erro aparecer) e não consegui (porque eu não sabia), acredito que os arquivos incompletos da instalação que não deu certo influenciou pra que isso acontecesse. Se for possível apagar arquivos errados, como os de instalações que não deram certo, me explica por favor como apagar ou resolver pra que não fique dando problema mais pra frente.

Desde já obrigado pela atenção!


  


2. Re: Erro "sudo apt-get update" (e pra que serve?)

niquelnausea
niquelnausea

(usa Arch Linux)

Enviado em 21/09/2019 - 01:26h

em sistemas linux e comum o conceito de repositórios onde são armazenados os pacotes, e então os desenvolvedores lá disponibilizam esses pacotes.

Confesso que não sei ao certo pra que serve este comando

apt é o gerenciador de pacotes do debian (também usado em n outras distros). além de instalar e remover esses pacotes, gerencia dependências e atualizações.
o "apt-get update" atualiza as informações no eu pc, de modo a saber o que esta ou não nos repositórios.

esses erros são causados por repositórios que ou estão com problemas, ou fora do ar. de uma procurada aqui no fórum porque existe bastante material explicando como resolver este problema. sem entender o que é o apt e como funciona, dificilmente conseguira evitar problemas como este.


3. Re: Erro

Stanislaus K
StanislausK

(usa FreeBSD)

Enviado em 21/09/2019 - 08:12h

Ola,

preciso antes de mais nada algumas informações:

1. Marca e Modelo de seu equipamento... pelo que estou vendo, o seu equipamento veio (infelizmente) com uma distro Linux instalada?!? Não me leve a mal, mas pelo que venho acompanhando na comunidade VOL, equipamentos que já vem instalados com Linux dão problemas, pelo serviço ter sido mal feito, e com um suporte inadequado (só de ver a sua lista de repositórios, já me deixa frustado!). Péssimo para a imagem do Linux (não sei se isso é proposital)! O que era para facilitar, somente complica mais... e deixe muitos usuários insatisfeitos.

Ao que parece, o seu sistema é um "FrankenDebian" (so de ver a mistura de ppa do Ubuntu com Debian, já é problemático!)... leia mais sobre em:

DontBreakDebian
Advice For New Users On Not Breaking Their Debian System


"Debian Stable should not be combined with other releases" (...) "Ubuntu, Mint or other derivative repositories are not compatible with Debian" (...) "The reason that Debian Stable is so reliable is because software is extensively tested and bug-fixed before being included. This means that the most recent version of software is often not available in the Stable repositories. But it doesn't mean that the software is too old to be useful".

Fonte: https://wiki.debian.org/DontBreakDebian


2. No Terminal digite os seguintes comandos (separadamente):

uname -a

e depois:

lspci

e mostre o que aparece!


3. apt update x apt upgrade:

- o apt-get update (ou apt update): tem a função de atualizar localmente (no seu equipamento) as informações existentes nos repositórios (por exemplo, do Debian), a respeito dos pacotes e dependências que estão no seu equipamento. Ou seja, efetua uma comparação para verificar o que precisa ou não se atualizado.

- apt-get upgrade (ou apt upgrade): após efetuar o update, para que ocorra atualização completa de todos os pacotes que possuem novas versões no repositório, usa-se esse comando.

4. No Terminal use o comando: cat /etc/apt/sources.list
e mostre o que aparece!




4. Re: Erro "sudo apt-get update" (e pra que serve?)

Clodoaldo Santos
clodoaldops

(usa Linux Mint)

Enviado em 21/09/2019 - 12:41h

Não faltam informações

https://sempreupdate.com.br/qual-a-diferenca-entre-comandos-apt-e-apt-get/








Patrocínio

Site hospedado pelo provedor RedeHost.
Linux banner
Linux banner
Linux banner

Destaques

Artigos

Dicas

Tópicos

Top 10 do mês

Scripts